Backup+ Lets You Backup Your App Data on Android Lollipop

Even though Android 5.0 Lollipop hasn’t yet seen its official release, quite … more

TechTalk Compiles All the Android News You Need in One App

If you’re as obsessed with mobile devices as the vast majority of our forum … more

Android App Review: Google Inbox to Improve Your Life – XDA TV

Recently, Google+ exploded with the announcement of Google Inbox, as … more

Damp the LG G3 Thermal Throttling

As our mobile devices grow thinner and more powerfulwith each passing generation, it’s inevitable … more
Post Reply

[Q] Phone reboot upon starting Google Maps

OP Davian64

13th February 2014, 08:08 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Feb 2014
I play around with my phone, testing roms, kernels and tweaks until google maps stop working on my phone. the last time it work was when i'm using Maclaw's CM11.

I decided to return to stock rom and recovery using odin and thats when the problem started. I followed the steps from here.

The phone reboot each time I start Google Maps. I tried going back to CM11 but the phone reboot each time I start Camera (previously it was working fine). (I may hare to try CM11 again to see if Google Maps working in CM11)

Then I try to revert back to Original Stock Rom With Kies following the steps here but the problem persist.

Any idea to solve this problem?
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-02-13-15-39-57.png
Views:	1197
Size:	64.5 KB
ID:	2576551  
13th February 2014, 12:00 PM   |  #2  
DjWacko's Avatar
Member
Flag Hasselt
Thanks Meter: 14
 
46 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by Davian64

I play around with my phone, testing roms, kernels and tweaks until google maps stop working on my phone. the last time it work was when i'm using Maclaw's CM11.

I decided to return to stock rom and recovery using odin and thats when the problem started. I followed the steps from here.

The phone reboot each time I start Google Maps. I tried going back to CM11 but the phone reboot each time I start Camera (previously it was working fine). (I may hare to try CM11 again to see if Google Maps working in CM11)

Then I try to revert back to Original Stock Rom With Kies following the steps here but the problem persist.

Any idea to solve this problem?


Hi,

Maybe a corrupted data partition.
Do a real format data + media in recovery.
After that, try again flashing .

Greetz

Hopes it works
The Following User Says Thank You to DjWacko For This Useful Post: [ View ]
13th February 2014, 12:59 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by DjWacko

Hi,

Maybe a corrupted data partition.
Do a real format data + media in recovery.
After that, try again flashing .

Greetz

Hopes it works



Hi,

Is real format data + media in recovery means wipe data/factory reset in recovery? I believe i did that before flashing stock rom using stock recovery.

I had an idea just now and I try several apps from play store, compass apps and any apps that uses compass and each apps reboot my phone upon starting. Logically Google Maps also use compass. So this might be the problem but strangely i could use Waze with no problem at all.

If compass related app is the problem, how do i fix this?

Thank you
13th February 2014, 01:58 PM   |  #4  
DjWacko's Avatar
Member
Flag Hasselt
Thanks Meter: 14
 
46 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by Davian64


Hi,

Is real format data + media in recovery means wipe data/factory reset in recovery? I believe i did that before flashing stock rom using stock recovery.

I had an idea just now and I try several apps from play store, compass apps and any apps that uses compass and each apps reboot my phone upon starting. Logically Google Maps also use compass. So this might be the problem but strangely i could use Waze with no problem at all.

If compass related app is the problem, how do i fix this?

Thank you



Hi

real format isn't the same as wipe data/factory reset.

Real format = In recovery go to mounts and storage --> format real data and media

Strange that the compass isn't working. Try to uninstall non standaard compass apps from your Phone. And try google maps again.
Install app one by one, and see what app is causing the problem.

If not, it's recommend to do a full clean install again at your Phone.

Greetz
The Following User Says Thank You to DjWacko For This Useful Post: [ View ]
13th February 2014, 03:41 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by DjWacko

Hi

real format isn't the same as wipe data/factory reset.

Real format = In recovery go to mounts and storage --> format real data and media

Strange that the compass isn't working. Try to uninstall non standaard compass apps from your Phone. And try google maps again.
Install app one by one, and see what app is causing the problem.

If not, it's recommend to do a full clean install again at your Phone.

Greetz



Thanks.

I will try and report later as I'm currently doing offline charging. I'm a newbie, do you mind telling me the steps for full clean install?

Thank you
13th February 2014, 07:29 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by DjWacko

Hi

real format isn't the same as wipe data/factory reset.

Real format = In recovery go to mounts and storage --> format real data and media

Strange that the compass isn't working. Try to uninstall non standaard compass apps from your Phone. And try google maps again.
Install app one by one, and see what app is causing the problem.

If not, it's recommend to do a full clean install again at your Phone.

Greetz

I did format real data and media. still not working. I also install Maclaw's CM10.1 using steps from here, Camera is working, unlike CM11 but Maps still not working.

I also tried several compass app. Result are the same. Non of the apps works and phone reboot as soon as the apps start.

Thank you
13th February 2014, 08:55 PM   |  #7  
DjWacko's Avatar
Member
Flag Hasselt
Thanks Meter: 14
 
46 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by Davian64

I did format real data and media. still not working. I also install Maclaw's CM10.1 using steps from here, Camera is working, unlike CM11 but Maps still not working.

I also tried several compass app. Result are the same. Non of the apps works and phone reboot as soon as the apps start.

Thank you

Mmm, really strange it doesn't work
I'm on carbon rom now for some testing. The only app with gps needed on this rom is Google earth.
I tested that app, and all is working fine here.

Maybe a dead gps at your Phone?


Greetz
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes