Mozilla Ditches Google, Makes Yahoo Default Search Engine

Mozilla and Google have had a long-standing relationship of about 10 years. Google … more

Learn More About Linux with Linux Man Pages

Linux is quite a powerful and very configurable operating system. Thanks to some user-friendly … more

Detect, Avoid IMSI-Catcher Attacks with Android IMSI-Catcher Detector

Privacy is always an important topic, as well as a delicate one to … more

Materialized LeanDroid Fights Your Poor Battery Life

Battery life has always been one of the biggest problems facing most Android devices. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] symlinks failed when installing CM 11 KitKANG

OP FriendlyPear

16th February 2014, 08:09 AM   |  #1  
FriendlyPear's Avatar
OP Junior Member
Flag Copenhagen
Thanks Meter: 0
 
7 posts
Join Date:Joined: Sep 2012
Hi,

I am trying to flash CM 11 KitKANG to my Desire, but without succes so far.

The installation log from 4EXT reads:

Installing KitKANG
Installing Gapps to /data
Creating symliks
symlink: some symlinks failed
E:Error in /sdcard/cm-11-kitkang-20140208-v0.5:slim.zip
(status 7)

Does anyone know what is causing this and what I can do to resolve it?

I have followed instructions and got a 1024mb ext4 sd-ext partition and AlphaRev Jelly Hboot; as well as tried both the latest 4EXT and twrp recoveries. This is the only ROM so far that I have tried installing that fails.

All help appreciated, thanks.
16th February 2014, 10:35 AM   |  #2  
Member
Flag Zagreb
Thanks Meter: 11
 
54 posts
Join Date:Joined: Apr 2011
More
Are You sure that You have AlphaRev Jelly hboot?Boot in 4ext recovery and check info tab.
Size of your system partition must be 250 mb.
16th February 2014, 01:14 PM   |  #3  
FriendlyPear's Avatar
OP Junior Member
Flag Copenhagen
Thanks Meter: 0
 
7 posts
Join Date:Joined: Sep 2012
Yes.

Opening info in 4EXT I see:

system / mtd3 / 250.0MiB
data / mtd5 / 185.8MiB
cache / mtd4 / 5.0 MiB


By the way, I am using 4EXT Recovery Touch version 1.0.0.5 RC9. It is dated Jul 13, 2013 and the newest version according to the 4EXT Recovery Updater app. That is still pre-KitKat though, so am I missing a recovery?
16th February 2014, 01:43 PM   |  #4  
jmcclue's Avatar
Recognized Contributor
Thanks Meter: 1,386
 
3,581 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by FriendlyPear

Yes.

Opening info in 4EXT I see:

system / mtd3 / 250.0MiB
data / mtd5 / 185.8MiB
cache / mtd4 / 5.0 MiB


By the way, I am using 4EXT Recovery Touch version 1.0.0.5 RC9. It is dated Jul 13, 2013 and the newest version according to the 4EXT Recovery Updater app. That is still pre-KitKat though, so am I missing a recovery?

Yh try flashing latest 4ext (1.0.0.6 RC1)
The Following User Says Thank You to jmcclue For This Useful Post: [ View ]
16th February 2014, 02:15 PM   |  #5  
FriendlyPear's Avatar
OP Junior Member
Flag Copenhagen
Thanks Meter: 0
 
7 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by jmcclue

Yh try flashing latest 4ext (1.0.0.6 RC1)

Where do I find that?

I guess your "4eXT Recovery Touch ... as PB99IMG" thread is linking to the older version, which is the same I get from the 4EXT app.
16th February 2014, 03:00 PM   |  #6  
Member
Flag Zagreb
Thanks Meter: 11
 
54 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by FriendlyPear

Yes.

Opening info in 4EXT I see:

system / mtd3 / 250.0MiB
data / mtd5 / 185.8MiB
cache / mtd4 / 5.0 MiB


By the way, I am using 4EXT Recovery Touch version 1.0.0.5 RC9. It is dated Jul 13, 2013 and the newest version according to the 4EXT Recovery Updater app. That is still pre-KitKat though, so am I missing a recovery?

I managed to install this rom with this version of 4ext.
Maybe is something wrong with your sd partition.Somewhere on the forums I saw that guys solved that problem by
mounting sd-ext in recovery before installing rom.
The Following User Says Thank You to Tonal4Nagual For This Useful Post: [ View ]
16th February 2014, 04:44 PM   |  #7  
FriendlyPear's Avatar
OP Junior Member
Flag Copenhagen
Thanks Meter: 0
 
7 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by Tonal4Nagual

I managed to install this rom with this version of 4ext.
Maybe is something wrong with your sd partition.Somewhere on the forums I saw that guys solved that problem by
mounting sd-ext in recovery before installing rom.

Got it to work with the new v0.6!

Think you are right about the SD card being the problem. I removed it from the phone and reformatted with my PC using a card reader. Strange thing is that I have been formatting the card many times, also after I first saw the symlink failure, but always from phone recovery.So maybe one of the recoveries created an error that the following ones didn't...

Thanks for your help.
16th February 2014, 05:27 PM   |  #8  
Member
Flag Zagreb
Thanks Meter: 11
 
54 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by FriendlyPear

Got it to work with the new v0.6!

Think you are right about the SD card being the problem. I removed it from the phone and reformatted with my PC using a card reader. Strange thing is that I have been formatting the card many times, also after I first saw the symlink failure, but always from phone recovery.So maybe one of the recoveries created an error that the following ones didn't...

Thanks for your help.

I'm glad you made it.
Partitioning SD card is always better to do with 4ext or gparted with sim inserted in phone.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes