Bring Back LTE on the Google Nexus 4 Running Lollipop

One of the predecessors of the latest, largest, and greatest Gooogle Nexus 6(theGoogle … more

Google Maps, My Maps, YouTube, Androidify, Slides, Music Updated–Here’s What’s New

In the last few weeks, Google has been … more

SuperSU BETA: Root Android Lollipop on Stock Kernel

Up until now, if you wanted to get root on Android 5.0, you needed to flash a modified … more

Android App Review: Get Amaze with Material Design – XDA TV

Material Design is all the buzz in the Android world right now. Android 5.0 … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Xperia Play boot loops every time something is flashed via CWM

OP x2110311x

17th February 2014, 08:32 PM   |  #1  
x2110311x's Avatar
OP Junior Member
Flag Canton, Ohio
Thanks Meter: 1
 
22 posts
Join Date:Joined: Feb 2014
Hi, I've been having some problems with my Xperia Play getting stuck in a boot loop after flashing anything, or restoring a backup in CWM. This includes mods, like Adrenoboost, and the NXT Lockscreen, to themes. I have the Xperia Play R800x with an unlocked bootloader (via unlock code from Sony) and I'm using stock 2.3.3 Gingerbread, with the stock Kernel. I boot CWM by hotBooting LuPuS with Fastboot. I'm not really sure what to do because I really want to install these mods, and because restoring my nandroid backups also gets it stuck in a bootloop, I have to reflash the stock .ftf with FlashTool and reroot it every time.
17th February 2014, 09:14 PM   |  #2  
WhiteWashed's Avatar
Senior Member
Flag Vivaro
Thanks Meter: 45
 
138 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by x2110311x

Hi, I've been having some problems with my Xperia Play getting stuck in a boot loop after flashing anything, or restoring a backup in CWM. This includes mods, like Adrenoboost, and the NXT Lockscreen, to themes. I have the Xperia Play R800x with an unlocked bootloader (via unlock code from Sony) and I'm using stock 2.3.3 Gingerbread, with the stock Kernel. I boot CWM by hotBooting LuPuS with Fastboot. I'm not really sure what to do because I really want to install these mods, and because restoring my nandroid backups also gets it stuck in a bootloop, I have to reflash the stock .ftf with FlashTool and reroot it every time.

Hi. Not all mods are 100% compatible with stock ROM so you should use a custom one. Many custom ROMs are better than the stock one.
17th February 2014, 09:17 PM   |  #3  
x2110311x's Avatar
OP Junior Member
Flag Canton, Ohio
Thanks Meter: 1
 
22 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by WhiteWashed

Hi. Not all mods are 100% compatible with stock ROM so you should use a custom one. Many custom ROMs are better than the stock one.

My only problem is, when I flash other ROMs they don't work, unless I also flash a custom Kernel. Anytime I flash a custom kernel, WiFi never connects, even if I flash the WiFi modules. It gets stuck at Obtaining IP Address, then stops.
17th February 2014, 09:25 PM   |  #4  
WhiteWashed's Avatar
Senior Member
Flag Vivaro
Thanks Meter: 45
 
138 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by x2110311x

My only problem is, when I flash other ROMs they don't work, unless I also flash a custom Kernel. Anytime I flash a custom kernel, WiFi never connects, even if I flash the WiFi modules. It gets stuck at Obtaining IP Address, then stops.

There's are some Gingerbread based roms that work also with the stock kernel and won't give you any problem with wifi (personal experience).
Try the gbx_play v3-rebuild here: http://forum.xda-developers.com/show....php?t=1897634
Or the Gin2kitkat here: http://forum.xda-developers.com/show....php?t=1631144

Try to flash one of these and let us know
Remember that before you flash a ROM you MUST make a wipe data/factory reset, wipe cache and wipe Dalvik Cache (in advanced options).
Last edited by WhiteWashed; 17th February 2014 at 09:30 PM.
17th February 2014, 09:51 PM   |  #5  
x2110311x's Avatar
OP Junior Member
Flag Canton, Ohio
Thanks Meter: 1
 
22 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by WhiteWashed

There's are some Gingerbread based roms that work also with the stock kernel and won't give you any problem with wifi (personal experience).
Try the gbx_play v3-rebuild here: http://forum.xda-developers.com/show....php?t=1897634
Or the Gin2kitkat here: http://forum.xda-developers.com/show....php?t=1631144

Try to flash one of these and let us know
Remember that before you flash a ROM you MUST make a wipe data/factory reset, wipe cache and wipe Dalvik Cache (in advanced options).

I do wipe the data and cache. I know how to install ROMs, I've done it with TWRP on my Kindle Fire, but I get stuck in a boot loop every time. I'll try these ROMs and see how they go.
18th February 2014, 12:59 AM   |  #6  
x2110311x's Avatar
OP Junior Member
Flag Canton, Ohio
Thanks Meter: 1
 
22 posts
Join Date:Joined: Feb 2014
Quote:
Originally Posted by WhiteWashed

There's are some Gingerbread based roms that work also with the stock kernel and won't give you any problem with wifi (personal experience).
Try the gbx_play v3-rebuild here: http://forum.xda-developers.com/show....php?t=1897634
Or the Gin2kitkat here: http://forum.xda-developers.com/show....php?t=1631144

Try to flash one of these and let us know
Remember that before you flash a ROM you MUST make a wipe data/factory reset, wipe cache and wipe Dalvik Cache (in advanced options).

I did a Factory Reset on CWM, then flashed Gin2KitKat, and wiped the cache and dalvik cache and it's stuck on the Android boot animation. It's been sitting there for like 10 minutes or so now. Flashtool does recognize it though.
Quote:

Connected Device: R800
Installed version of busybox: BusyBox x1.21.1-Stericson (2013-09-26 14:33:26 BST) multi-call binary
Android Version: 2.3.7 / kernel version 2.6.32.9-perf / Build number: 4.0.2.A.0.79

18th February 2014, 01:08 AM   |  #7  
x2110311x's Avatar
OP Junior Member
Flag Canton, Ohio
Thanks Meter: 1
 
22 posts
Join Date:Joined: Feb 2014
It worked fine as soon as I hotBooted it with LuPus. I'm gonna try installing the other ROM I wanted and hotBooting LuPus
18th February 2014, 06:26 AM   |  #8  
WhiteWashed's Avatar
Senior Member
Flag Vivaro
Thanks Meter: 45
 
138 posts
Join Date:Joined: Jan 2014
Strange, I have the opposite problem: lupus doesn't boot any ROM for me, excepting ICs ones.
In fact, to install a GB ROM I always have to flash first the stock rom and fw, and then flash the ROM with a custom recovery. Anyway by "hot booting" you mean custom recovery right?

Sent from my R800i using xda app-developers app
Last edited by WhiteWashed; 18th February 2014 at 06:29 AM.
19th February 2014, 12:31 AM   |  #9  
x2110311x's Avatar
OP Junior Member
Flag Canton, Ohio
Thanks Meter: 1
 
22 posts
Join Date:Joined: Feb 2014
No, what I'm doing is using Fastboot to boot the phone with the kernel, without flashing it, to test it out. As soon as you shut the phone off, and turn it back on, it boots with whatever kernel is flashed on it

Sent from my R800x using xda app-developers app
19th February 2014, 06:31 AM   |  #10  
WhiteWashed's Avatar
Senior Member
Flag Vivaro
Thanks Meter: 45
 
138 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by x2110311x

No, what I'm doing is using Fastboot to boot the phone with the kernel, without flashing it, to test it out. As soon as you shut the phone off, and turn it back on, it boots with whatever kernel is flashed on it

Sent from my R800x using xda app-developers app

That's what I mean with custom recovery (don't confuse with custom kernel).
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes