Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] CM11 nightly headphone jack not working right

OP jplecher

23rd February 2014, 09:54 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
9 posts
Join Date:Joined: Jan 2011
Hello! Since I can't post this in Sprint Galaxy Note II Original Android Development until I posted ten times so this is really for CyanogenMod 11 nightlies ROM experts.

I'm using nightly CM11 2/22/14 with plasma kernel. This issue has to do with a headphone jack while plug in and using either Apollo or any other music player. If I open another app the sound goes off but when I close the app the sound comes on. This is also true with using the status bar, when I move the status bar down sound goes off and comes back on when status bar goes back up. The same is also true if the phone goes to sleep.. again sound goes off.

There is no problem with the sound system when I unplug the jack. I haven't had this problem in the past with the Official CM11 ROM. Does this has something to do with nightlies? I tried using Soundabout and other music players but still no luck.

Anyone out there experiencing the same or know how to fix this? Any help would be grateful! Thanks in advance.
Last edited by jplecher; 23rd February 2014 at 10:40 PM. Reason: Clarification: missing words
27th February 2014, 07:09 AM   |  #2  
Junior Member
Thanks Meter: 4
 
10 posts
Join Date:Joined: Mar 2012
I was on the 2/11 nightly for a couple weeks and had similar issues. I use Play Music app, stock kernel and V4A. I installed Carbon KK last night and its just as bad if not worse. With headphones in, audio seems to cut out if anything takes focus over player.

Sent from my SPH-L900 using xda app-developers app
28th February 2014, 05:47 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
9 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by Skeptical

I was on the 2/11 nightly for a couple weeks and had similar issues. I use Play Music app, stock kernel and V4A. I installed Carbon KK last night and its just as bad if not worse. With headphones in, audio seems to cut out if anything takes focus over player.

Sent from my SPH-L900 using xda app-developers app

Thanks! Gonna try tonight nightly and see if that resolve the issue. Wish me luck.
3rd March 2014, 07:07 PM   |  #4  
OP Junior Member
Thanks Meter: 1
 
9 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by jplecher

Thanks! Gonna try tonight nightly and see if that resolve the issue. Wish me luck.

It was the nightly! Seemed to be working fine now!
The Following User Says Thank You to jplecher For This Useful Post: [ View ]
5th March 2014, 12:55 AM   |  #5  
Junior Member
Thanks Meter: 4
 
10 posts
Join Date:Joined: Mar 2012
Are you still on CM then? Still having the issue with Carbon so maybe I'll need to switch back for a bit. Thanks for confirming.

Sent from my SPH-L900 using xda app-developers app
6th March 2014, 10:45 PM   |  #6  
OP Junior Member
Thanks Meter: 1
 
9 posts
Join Date:Joined: Jan 2011
Quote:
Originally Posted by Skeptical

Are you still on CM then? Still having the issue with Carbon so maybe I'll need to switch back for a bit. Thanks for confirming.

Sent from my SPH-L900 using xda app-developers app

Sorry just back from vacation... yes still using CM latest nightly 2/24.
9th April 2014, 10:53 AM   |  #7  
Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Aug 2010
Has this problem been fixed in the latest cm11 builds?
16th April 2014, 02:24 AM   |  #8  
Junior Member
Thanks Meter: 6
 
28 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by Blabah

Has this problem been fixed in the latest cm11 builds?

I still have it and after searching, I have not come on a fix.

My problem is exactly as OP described. I had the issue with builds from the 3rd, 6th, 9th, and 13th of April.

Edit:

Combination of fixes:

1. Disable hot word detection in Google Now launcher. Go home, then menu button, settings, voice, and turn hot word off.
2. Start playing the music before you plug in the headphones.
Last edited by NH Apache; 16th April 2014 at 02:39 AM.
The Following 2 Users Say Thank You to NH Apache For This Useful Post: [ View ]
9th May 2014, 06:38 PM   |  #9  
OpKnight's Avatar
Junior Member
Flag Philadelphia
Thanks Meter: 4
 
18 posts
Join Date:Joined: Jul 2012
Google Play Music's volume cuts off when Google Hot word detection if ON...
I had the same issue... and have tried multiple CM nightlies with the same result. it was driving me nuts. As soon as i changed to another application Or checked the status bar the sound would mute. You are correct in turning OFF the Google "hot word" detection which turns off "OK Google" as the solution to the problem. Not sure if the problem is on Google's end OR in the CM's Team's ROM?

Thanks,


Quote:
Originally Posted by NH Apache

I still have it and after searching, I have not come on a fix.

My problem is exactly as OP described. I had the issue with builds from the 3rd, 6th, 9th, and 13th of April.

Edit:

Combination of fixes:

1. Disable hot word detection in Google Now launcher. Go home, then menu button, settings, voice, and turn hot word off.
2. Start playing the music before you plug in the headphones.

The Following User Says Thank You to OpKnight For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes