Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,768,001 Members 39,985 Now Online
XDA Developers Android and Mobile Development Forum

Initial audio delay over bluetooth

Tip us?
 
blackjoker4215
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Question Initial audio delay over bluetooth

Everyone,

I am having about 2-3 seconds of no audio when using my Bose soundlink mini with my Surface 2 Pro and watching videos. I have tried re-pairing the device as well as uninstalling the drivers from device manager and reinstalling them to no avail. Any ideas? Thanks.
 
SixSixSevenSeven
Old
#2  
Senior Member
Thanks Meter 323
Posts: 1,620
Join Date: Dec 2012
Is this only when the device first pairs or does it persist for the entire session? On first pairing, that is entirely normal. Entire session, bluetooth does have latency but not 2 seconds worth, very strange, it is usually enough to spot lip sync errors in films I find.
 
blackjoker4215
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Quote:
Originally Posted by SixSixSevenSeven View Post
Is this only when the device first pairs or does it persist for the entire session? On first pairing, that is entirely normal. Entire session, bluetooth does have latency but not 2 seconds worth, very strange, it is usually enough to spot lip sync errors in films I find.
Strange thing is, when I first pair my surface to the speakers and watch a video, there is no delay. The delay only happens on every video after that.
 
hisoft
Old
#4  
Senior Member
Thanks Meter 17
Posts: 172
Join Date: Feb 2009
I have all time delay problem with my old Windows Mobile device. That time it happen because Bluetooth audio service have a large buffer. The problem were solve by change it to smaller value.

Hope this can help you.
 
blackjoker4215
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 13
Join Date: Oct 2010
Quote:
Originally Posted by hisoft View Post
I have all time delay problem with my old Windows Mobile device. That time it happen because Bluetooth audio service have a large buffer. The problem were solve by change it to smaller value.

Hope this can help you.
How do I do this?
 
hisoft
Old
#6  
Senior Member
Thanks Meter 17
Posts: 172
Join Date: Feb 2009
Quote:
Originally Posted by blackjoker4215 View Post
How do I do this?
At that time I adjust Windows Mobile Registry. But I can't find this on Windows 8/RT.

This for Windows Mobile.
http://blog.vpire.com/1174/setting-windows-mobile-a2dp/

And this for Android.
http://forum.xda-developers.com/showthread.php?t=708685
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


[OTA Captured] Android 4.4.3 Lands on European HTC One M7

The secound release of the Android L Developer Previewmay be the new hotness for … more

Take a Perfectly Stable Shot with Open Camera

The camera app on our Android smartphones and tablets isn’t something we focus on all … more

Motorola Droid X Receives Almost Fully Functional KitKat Port

While we are all wondering when Google will decide to officially release … more

XDA Xposed Tuesday: Kids Mode for Your Phone – XDA Developer TV

The greatest thing about technology is its ability to teach and promote … more