Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,786,442 Members 42,657 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Odd sound problem

Tip us?
 
xxcrashxx
Old
(Last edited by xxcrashxx; 1st March 2014 at 02:49 AM.)
#1  
Member - OP
Thanks Meter 3
Posts: 50
Join Date: Dec 2007
Default [Q] Odd sound problem

Long story short, I just picked up an AT&T HTC One X(Stock everything, S-on, not rooted) off ebay as a "fixer upper". The seller said the speaker and microphone wasn't working and included the parts. After changing them out, still no sound. I have also tried syncing my bluetooth headset and I don't get any sound through there, nor do headphones work, videos won't play. When I attempt to use voice search, the Google Search application crashes and doesn't give a chance to record anything.

I have tried doing a factory reset through the phone and through the bootloader, but the audio problem still exists. I think the phone had water damage, I need to clean up the board good first. Is there a chance that only the audio processor shorted out? Does anyone know where this chip is located?

Firmware version 3.18, running 4.1.1
 
xxcrashxx
Old
#2  
Member - OP
Thanks Meter 3
Posts: 50
Join Date: Dec 2007
So I have given the board an ultrasonic bath in M.E.K and gave it 24 hours to fully evaporate. Put the phone back together, but the audio still doesn't work at all, even replaced the bottom mic/back speaker ribbon. And also usb doesn't work in the phone, or fastboot. The computer just see's an unknown usb device when it's connected. Device Manager shows an unknown usb device, and under hardware ID it just says USB\UNKNOWN.

Anyone have any ideas on anything I could try to fix the audio, or the USB problem??
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes