Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,427 Members 40,117 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Cannot activate the Play Store

Tip us?
 
7turnips
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 3
Join Date: Mar 2014
Default [Q] Cannot activate the Play Store

So I sideloaded the Play APK from Android Police, but after putting in my Google account information, it tells me "Couldn't sign in: There was a problem communicating with Google servers. Try again later". I have internet connection, and have tried waiting a couple hours. Google and Youtube work fine. This is very frustrating to me since I can't do much without play apps...
 
ellentracymac2
Old
#2  
ellentracymac2's Avatar
Junior Member
Thanks Meter 1
Posts: 8
Join Date: Sep 2013
Default Same issue with Play Store

Quote:
Originally Posted by 7turnips View Post
So I sideloaded the Play APK from Android Police, but after putting in my Google account information, it tells me "Couldn't sign in: There was a problem communicating with Google servers. Try again later". I have internet connection, and have tried waiting a couple hours. Google and Youtube work fine. This is very frustrating to me since I can't do much without play apps...
I'm having the same issue using rooted Lokifizh Marz's Imperium Operative ROM. It's been two days. No joy. I've had to download and install APK files instead.
 
Lokifish Marz
Old
#3  
Lokifish Marz's Avatar
Recognized Contributor / Recognized Developer
Thanks Meter 3,276
Posts: 2,859
Join Date: Mar 2011
Location: Olympus Mons, Mars

 
DONATE TO ME
Quote:
Originally Posted by ellentracymac2 View Post
I'm having the same issue using rooted Lokifizh Marz's Imperium Operative ROM. It's been two days. No joy. I've had to download and install APK files instead.

Imperium Operative ROM was discontinued/put on hold a while back. Only the Patch/MOD are current and actively developed right now.
Ubuntop- U4A/Webtop hybrid for all Tegra2 Motorola phones (Fully integrated Ubuntu Desktop)
Live ROM (One "ROM" over 12 phones) (Featured on XDA Portal and multiple other sites around the world and as base by many devs)
Imperium Initiative Photon (used as base by many Photon devs)
Imperium Initiative LS970 (used as base by many LS970 devs)
Imperium Agent LS970 (LS970 version of Live ROM)
Evo Desktop PC (Featured on XDA Portal and multiple other sites around the world)
(Nexus Q)uantum Singularity Project (Media Center, File Server, Website Server, LinuxonAndroid in little black ball of joy)
Umeox x201 EnSec Enhanced Security Patch and Live ROM Installer (used by multiple devs world wide on over 6 different models/versions of x201's)
Every Android device I've owned since the Hero- Media Center, File Server, Website Server
 
ellentracymac2
Old
#4  
ellentracymac2's Avatar
Junior Member
Thanks Meter 1
Posts: 8
Join Date: Sep 2013
Quote:
Originally Posted by Lokifish Marz View Post
Imperium Operative ROM was discontinued/put on hold a while back. Only the Patch/MOD are current and actively developed right now.
My mistake, I have run only the Patch/Mod. It's FANTASTIC. Thank you for all your work. Still not Play Store. I will update to 01/01/2014 now.
 
Lokifish Marz
Old
#5  
Lokifish Marz's Avatar
Recognized Contributor / Recognized Developer
Thanks Meter 3,276
Posts: 2,859
Join Date: Mar 2011
Location: Olympus Mons, Mars

 
DONATE TO ME
Quote:
Originally Posted by ellentracymac2 View Post
My mistake, I have run only the Patch/Mod. It's FANTASTIC. Thank you for all your work. Still not Play Store. I will update to 01/01/2014 now.
I'm going to double check it by flashing all three of my TS's to stock but as recent as 1AM today I've not had and play store install issues. It may be a play store server side issue which I've seen more than once. Even my all my Nexus devices have done this from time to time.
Ubuntop- U4A/Webtop hybrid for all Tegra2 Motorola phones (Fully integrated Ubuntu Desktop)
Live ROM (One "ROM" over 12 phones) (Featured on XDA Portal and multiple other sites around the world and as base by many devs)
Imperium Initiative Photon (used as base by many Photon devs)
Imperium Initiative LS970 (used as base by many LS970 devs)
Imperium Agent LS970 (LS970 version of Live ROM)
Evo Desktop PC (Featured on XDA Portal and multiple other sites around the world)
(Nexus Q)uantum Singularity Project (Media Center, File Server, Website Server, LinuxonAndroid in little black ball of joy)
Umeox x201 EnSec Enhanced Security Patch and Live ROM Installer (used by multiple devs world wide on over 6 different models/versions of x201's)
Every Android device I've owned since the Hero- Media Center, File Server, Website Server
 
ellentracymac2
Old
#6  
ellentracymac2's Avatar
Junior Member
Thanks Meter 1
Posts: 8
Join Date: Sep 2013
Quote:
Originally Posted by Lokifish Marz View Post
I'm going to double check it by flashing all three of my TS's to stock but as recent as 1AM today I've not had and play store install issues. It may be a play store server side issue which I've seen more than once. Even my all my Nexus devices have done this from time to time.
Thank you. I wanted to let you know I've flashed the latest update that you posted today (as an aside, the version still reports its the 02/21/2014). Anyway, still no play store. Same errors. OK with Nexus 7/ 4/Memo Pad(s). Do you think it could have something to do with the two-step verification process I've initiated with my Google account? Maybe the TS doesn't work well with that? Should I try to flash back to stock. Try again?
 
ellentracymac2
Old
#7  
ellentracymac2's Avatar
Junior Member
Thanks Meter 1
Posts: 8
Join Date: Sep 2013
Quote:
Originally Posted by Lokifish Marz View Post
I'm going to double check it by flashing all three of my TS's to stock but as recent as 1AM today I've not had and play store install issues. It may be a play store server side issue which I've seen more than once. Even my all my Nexus devices have done this from time to time.
It was the Google two-step verification process. It's not bothered any of my other devices, but the TS didn't agree with it. As soon as I disabled it, Play Store is up and active. Thank you for your help and quick responses Lokifish Marz. Have a great evening.
The Following User Says Thank You to ellentracymac2 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


CyanogenMod 11 M10 Available for Supported Devices

Summer vacation isover for most students out there, and it’s the time to get back to … more

XDA Forums Added for the First Batch of Android One Devices!

Just yesterday, we talked about the highly anticipated launch of the first batch … more

XDA Xposed Tuesday: DonkeyGuard, Don’t Be a Donkey, Control Your Device – XDA Developer TV

Some applications ask for the world … more

Use Facebook Pictures as a LWP with Facebook View

One of the best things that Android has always offeredits users is the ability to tailor … more