Add Frequency Bands to Your Qualcomm Device

Those of you who travel quite a bit undoubtedly own more than one device due to frequency band … more

More Android 5.0 Details Revealed, Microsoft Band Fitness Tracker – XDA TV

Google talks more about Android 5.0 Lollipop! That and much … more

Google Allows Search Queries To Interact With Apps

Android 5.0 Lollipop brings lots of new features that are quite useful for end users and … more

Lenovo Officially Owns Motorola, Following ~$3 Billion Deal

Google is now officially no longer the owner of American phone manufacturer … more
Post Reply

Moto G not detected win 8.1

OP abcduploader

6th March 2014, 09:46 AM   |  #1  
abcduploader's Avatar
OP Junior Member
Flag Kolkata
Thanks Meter: 6
 
26 posts
Join Date:Joined: Jan 2012
More
Hi,

I updated my moto g(xt1033) to kitkat as soon as i got the phone .

most of the time i use airdroid to transfer files . But recently when i tried to connect via MTP mode the device was not detected . It was neither detected in camera mode .

In the device manager its showing an error .
The drivers for this device are not installed. (Code 28)

There are no compatible drivers for this device.

Please help .
6th March 2014, 09:49 AM   |  #2  
Senior Member
Thanks Meter: 485
 
1,019 posts
Join Date:Joined: Jul 2011
+1
same problem here. though i got adb to work with win 8.1
6th March 2014, 09:53 AM   |  #3  
robin0800's Avatar
Senior Member
Thanks Meter: 87
 
272 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by reversegear

+1
same problem here. though i got adb to work with win 8.1

Install Motorola drivers

https://motorola-global-en-uk.custhe...p/30,6720,9050
6th March 2014, 10:41 AM   |  #4  
Senior Member
Thanks Meter: 485
 
1,019 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by robin0800

Install Motorola drivers

https://motorola-global-en-uk.custhe...p/30,6720,9050

tried that still not working
6th March 2014, 10:43 AM   |  #5  
abcduploader's Avatar
OP Junior Member
Flag Kolkata
Thanks Meter: 6
 
26 posts
Join Date:Joined: Jan 2012
More
Quote:
Originally Posted by reversegear

tried that still not working

+1 tried not working .
6th March 2014, 12:24 PM   |  #6  
avercros's Avatar
Senior Member
Flag Armenia
Thanks Meter: 62
 
343 posts
Join Date:Joined: Jan 2012
More
For me works like a charm, check your drivers installation.
6th March 2014, 05:54 PM   |  #7  
Junior Member
Thanks Meter: 1
 
14 posts
Join Date:Joined: Jul 2010
Quote:
Originally Posted by abcduploader

+1 tried not working .

You need to disable some driver enforcement business in Windows 8.1 before you can install the drivers.

http://www.howtogeek.com/167723/how-...igned-drivers/

Refer to the above link, after restarting, install Moto Drivers again. (http://download.clockworkmod.com/dri...iver_5.4.0.exe)

Let me know.
6th March 2014, 07:26 PM   |  #8  
mr_nooby's Avatar
Senior Member
Thanks Meter: 475
 
1,223 posts
Join Date:Joined: Jul 2012
Donate to Me
More
Windows 8.1 installs Microsoft USB drivers which won't allow you to use the phone even if you install drivers. You must search for your original USB drivers and install them instead of the windows 8.1 ones.

Sent from my XT1032 using xda app-developers app
6th March 2014, 10:38 PM   |  #9  
Senior Member
Thanks Meter: 32
 
108 posts
Join Date:Joined: Apr 2011
You might need some RNDIS drivers.
7th March 2014, 04:10 AM   |  #10  
renatoakamur's Avatar
Member
Flag São Paulo - SP
Thanks Meter: 4
 
69 posts
Join Date:Joined: Aug 2010
More
Try a factory reset. Worked for me.

My Moto G (XT1033) was working with some bugs to connect on Win 8.1 before the kit kat. After the update has stopped completely. I did a factory reset and everything is fine now.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Moto G Q&A, Help & Troubleshooting by ThreadRank