Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,266 Members 41,903 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Help: Black Screen after bootanimation

Tip us?
 
tenjou_89
Old
(Last edited by tenjou_89; 10th March 2014 at 06:10 PM.)
#1  
Member - OP
Thanks Meter 1
Posts: 45
Join Date: Mar 2014
Prompt [Q] Help: Black Screen after bootanimation

hello xda. i need your help. im desperate. i dont know what else to do with my moto g here's what happened:

 
first of all, i dropped my moto g into the water.
right after i got it out, it startet bootlooping. then it turned off by itself after almost an hour had passed.

i put it in a bag full of rice for the rest of the night and almost the whole following day. then i plugged it into the wall charger, and it wouldnt charge at all. the only sign of life was the blinking led.
so i took it to Movistar-Peru for repair, and told me the obvious: water damage was not covered in the warranty, then my phone was returned to me.

so i decided to tear it down by myself.

everything was looking fine. the water indicators were red, but everything was clean except for the battery socket: there was mineral condensation around it. i wiped it out, cleaned it away and then the phone would actually charge the battery icon displayed normally.
so i let it charge for 3 hours and after it was completely charged i turned it on. just to run into a black screen after the bootnimation.

good news is it actually can boot into fastboot mode and can access recovery menu.


 
i did some research here, and seemed like my phone needed a full stock flash (thatīs what i thought). i decided to unlock the bootloader, using motorola unique code. (i thought it may be needed for flashing, but it seems it is not necessary)

in recovery, my sdcard folders display normally, i can wipe data/factory reset it normally, BUT when i try to erase cache partition, the phone reboots.

so i started flashing my device through fastboot. i should mention that before i dropped it into the water, i had installed 4.4.2 ota update. but whenever i tried to flash a 4.4.2 rom, i got hab check failed for sysyem, for recovery and sometimes for boot.
now, i've tried several official motorola signed jelly bean roms (nextel br, movistar sp, claro ar, etc etc) including original Movistar Pe jb rom (which ive already flashed uncountable times) with no errors on flashing, but neither of them got me passed the black screen after bootanimation. (the phone is not off, cause the backlight remains on). the only way of getting out of it is rebooting into fastboot mode again (volume- and power).

i've also tried relocking the bootloader, and the process gives me no errors (the word "locked" displays by the end, though the phone then reboots into the "warning bl unlcked" screen) , but regardless of that and the relocking process turning out okay, status code 3 is displayed in menu, meaning the bl wasnt really relocked..?)


in short:

-dropped into water, started bootloop, then it turned itself off.
-next day it would display black screen after bootnimation, no matter what i did.
-if i choose wipe cache partition, the phone reboots.
-i've flashed it "sucsessfully" several times, still runs into a black screen after bootnimation.
-i've unlocked the boootloader
-if i try to reclock: process turns out okay("locked" word by the end), but status code remains being 3.
-i dont care about backups, i had nothing important in my phone (gdrive ftw)

my concearns are:

-possible hardware unrepairable damage
-bootloader got corrupted
-mineral condensation is still there deep inside the components
-maybe gpu? emmc corrupted? semi brick? idk..

my questions are:

-what can i do from now?
-i've read that a new bootloader can be flashed into the phone. risk of bricking my phone?
-if the bootloader is the problem, flashing a new one would solve it?
-in general, what am i doing wrong in all of this? has my phone any chance of functioning normally, at all?

please help me , i miss my phone, i got it for christmas, it is my first smartphone and i woudl like to bring it back to life if possible. thank you for reading.
 
grahameaddicott
Old
#2  
Junior Member
Thanks Meter 1
Posts: 3
Join Date: Mar 2014
Default I can help!

My girlfriend dropped her Moto G in water too, and it also started showing a black screen after the boot animation. I just managed to fix it.

Even if you have done some of this stuff, do it again anyway.

1-Power phone off
2-Press and hold volume down key for 3 seconds, then press the power key, then release both
3-You will see the boot options menu
4-Press the volume down key to scroll to RECOVERY, then press volume up to select it
5-You will see the Motorola logo, then after 10-30 seconds (maybe longer), you will see a Android logo with an exclamation symbol
6-Press and hold the Volume Up key for 10 seconds, then tap the power button
7-You will see a new menu
8-Use the Volume down key to scroll to Wipe data/factory reset, and then press the power key to select it.
9-Then use the volume down key to select yes, and use the power button to confirm
10-Let the phone format, then press the power key to reboot.

Once the phone has switched back on, wait and see what happens. If the Motorola logo comes on and then stays on for ages WAIT! It takes ages, but the phone will come back to life normally and be working in a few minutes! If you see a black screen again:

Repeat steps 1-7
When you see the new menu again, this time select the cache wipe option (it's the last option on the list)
Let the phone wipe and then it should reboot
This time you will defo see the Motorola logo on the screen for ages. Just keep waiting and press nothing. Hopefully after a minute or 2 it will then take you to the welcome screen

Hope this helped. I couldnt find any advice so had to experiment haha
The Following User Says Thank You to grahameaddicott For This Useful Post: [ Click to Expand ]
 
tenjou_89
Old
#3  
Member - OP
Thanks Meter 1
Posts: 45
Join Date: Mar 2014
Thank you for replying to my problem

i have already done your steps uncountable times.
every time i try to wipe cache, the phone reboots. it does not wipe anything at all, it just instantly reboots. then bootanimation, then black screen again, but nothing happens. not even after 2 minutes, after 5 or 10. nothing. just black screen until battery drains completely from continously powering the backlight. do you think maybe the water hardware-bricked my phone? also, im ocassionally getting blue screens out of a sudden, then the phone powers itself off.
 
grahameaddicott
Old
#4  
Junior Member
Thanks Meter 1
Posts: 3
Join Date: Mar 2014
Ah, ok, sorry my suggestion didn't help. I had exactly the same problem, so surprised this didn't help you. After being dropped in water, all I got was a black screen after the initial start animation. I don't really know much about phones tbh, I just managed to fix mine through trial and error. My girlfriends phone was initially sent to a shop for repair, and although the guy couldn't fix it, he said there was no signs of water damage. Not really sure then why the phone stopped working, but the method I suggested did work for me. I don't think there was anything else I tried. It's worth mentioning maybe that it took 6 weeks before I could fix the phone. Maybe it took that long to fully dry out? Straight after the accident though the phone was put in a bowl of rice for days so it should have been dried pretty quick. Don't really know what else to suggest, sorry I couldn't be more help. Have faith though, I reckon it'll come back to life soon
 
tenjou_89
Old
#5  
Member - OP
Thanks Meter 1
Posts: 45
Join Date: Mar 2014
thank you for posting a reply and thank you for your advice. i appreciatte the attention given. i will further try some other methods in hope of a solution.
 
liveroy
Old
#6  
liveroy's Avatar
Senior Member
Thanks Meter 38
Posts: 190
Join Date: Jun 2007
Location: Stara Zagora

 
DONATE TO ME
Your bootloader is working fine, dont touch it.
Unlock the bootloader and try to install cwm or twrp recovery, mount and format /data , /cache , /system through the recovery (if you manage it get recovery working ofc).
After that download mfastboot and flash stock rom with it.

Btw if you ever put anything into bag of rise, DON'T CLOSE the bag, you`ll probably do more damage than good this way.It should be done in open-air conditions.
Mental issues lead to the use of long signatures

Care much for receiving Thanks?Bitching at the others about it doesn't help, instead better stfu and gtfo.
 
soumik shah
Old
#7  
soumik shah's Avatar
Member
Thanks Meter 10
Posts: 75
Join Date: Apr 2012
Quote:
Originally Posted by grahameaddicott View Post
My girlfriend dropped her Moto G in water too, and it also started showing a black screen after the boot animation. I just managed to fix it.

Even if you have done some of this stuff, do it again anyway.

1-Power phone off
2-Press and hold volume down key for 3 seconds, then press the power key, then release both
3-You will see the boot options menu
4-Press the volume down key to scroll to RECOVERY, then press volume up to select it
5-You will see the Motorola logo, then after 10-30 seconds (maybe longer), you will see a Android logo with an exclamation symbol
6-Press and hold the Volume Up key for 10 seconds, then tap the power button
7-You will see a new menu
8-Use the Volume down key to scroll to Wipe data/factory reset, and then press the power key to select it.
9-Then use the volume down key to select yes, and use the power button to confirm
10-Let the phone format, then press the power key to reboot.

Once the phone has switched back on, wait and see what happens. If the Motorola logo comes on and then stays on for ages WAIT! It takes ages, but the phone will come back to life normally and be working in a few minutes! If you see a black screen again:

Repeat steps 1-7
When you see the new menu again, this time select the cache wipe option (it's the last option on the list)
Let the phone wipe and then it should reboot
This time you will defo see the Motorola logo on the screen for ages. Just keep waiting and press nothing. Hopefully after a minute or 2 it will then take you to the welcome screen

Hope this helped. I couldnt find any advice so had to experiment haha
It worked for me, Thanks
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...