Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Weird Battery

OP Proz00

11th March 2014, 12:05 PM   |  #1  
OP Senior Member
Thanks Meter: 39
 
805 posts
Join Date:Joined: Jun 2010
More
Hey All

so the battery is sometimes working good
2.5 hours screen time took 45% battery

and sometimes i charge the battery and the battery doesn't hold a few mins
its shutdown and need to recharge it again

what is the problem the battery or the charging connection ?

it start when i plug it to charger with 30-40%
if its empty and i charge it its wont do this problem

thx for help, sry for the English
11th March 2014, 01:44 PM   |  #2  
Junior Member
Flag Sydney
Thanks Meter: 1
 
18 posts
Join Date:Joined: Oct 2008
More
Quote:
Originally Posted by Proz00

Hey All

so the battery is sometimes working good
2.5 hours screen time took 45% battery

and sometimes i charge the battery and the battery doesn't hold a few mins
its shutdown and need to recharge it again

what is the problem the battery or the charging connection ?

it start when i plug it to charger with 30-40%
if its empty and i charge it its wont do this problem

thx for help, sry for the English

My battery died just after 1month use. I bought a cheap battery off ebay as i suspected the battery was the cause of my phone dying as it would constantly be on a bootloop even after i restored it to stock but cheap battery solved my problem. So i suspect you have a faulty battery and probably try a cheap battery off ebay and see if it solves your problem.
The Following User Says Thank You to kutenkind For This Useful Post: [ View ]
12th March 2014, 03:31 PM   |  #3  
Member
Thanks Meter: 9
 
61 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by Proz00

Hey All

so the battery is sometimes working good
2.5 hours screen time took 45% battery

and sometimes i charge the battery and the battery doesn't hold a few mins
its shutdown and need to recharge it again

what is the problem the battery or the charging connection ?

it start when i plug it to charger with 30-40%
if its empty and i charge it its wont do this problem

thx for help, sry for the English

This was my exact problem as well... charging was weird...it would be at like 70% then just reboot then be at 30% and wouldn't boot till I charged it a little... I replaced the battery and everything works fine....

Sent from my LG-E980 using xda app-developers app
The Following User Says Thank You to MythicBlue For This Useful Post: [ View ]
12th March 2014, 03:36 PM   |  #4  
OP Senior Member
Thanks Meter: 39
 
805 posts
Join Date:Joined: Jun 2010
More
thx i bought 2 batteries for 15$
but need to wait month to them
Last edited by Proz00; 12th March 2014 at 06:14 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes