Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,368 Members 51,991 Now Online
XDA Developers Android and Mobile Development Forum

format () expects 5 args, got 4

Tip us?
 
RealtorRod
Old
#1  
Member - OP
Thanks Meter 3
Posts: 48
Join Date: Jan 2011
Default format () expects 5 args, got 4

So I was trying to upgrade my i337m rom today and was greeted with this error format () expects 5 args, got 4 on all of them except for a 4.4.2 version of Gummy.

Kinda sucks. No matter what I do now, Odin back to stock etc I cannot get around it...
 
RedInuYasha
Old
#2  
Member
Thanks Meter 8
Posts: 58
Join Date: Apr 2011
Quote:
Originally Posted by RealtorRod View Post
So I was trying to upgrade my i337m rom today and was greeted with this error format () expects 5 args, got 4 on all of them except for a 4.4.2 version of Gummy.

Kinda sucks. No matter what I do now, Odin back to stock etc I cannot get around it...
http://forum.xda-developers.com/show...ostcount=11261
 
RealtorRod
Old
#3  
Member - OP
Thanks Meter 3
Posts: 48
Join Date: Jan 2011
Quote:
Originally Posted by RedInuYasha View Post
I have no idea what Philz is?

I downloaded the rom, installed it to external sd (and internal storage), CW in, clear cache, dalvik and wipe, error, error, error except the Gummy (which I hate, I cannot stand AOSP )

I will dig around on Philz
 
ChronoReverse
Old
#4  
Senior Member
Thanks Meter 158
Posts: 1,031
Join Date: Jun 2010
The reason you're getting an error is because your recovery conforms to the new scripting commands and the zip you're flashing is using the old method.

Philz has an advanced version of the recovery you're using. There's a checkbox to allow use of the old method and then it'll flash fine.
 
RealtorRod
Old
#5  
Member - OP
Thanks Meter 3
Posts: 48
Join Date: Jan 2011
Quote:
Originally Posted by ChronoReverse View Post
The reason you're getting an error is because your recovery conforms to the new scripting commands and the zip you're flashing is using the old method.

Philz has an advanced version of the recovery you're using. There's a checkbox to allow use of the old method and then it'll flash fine.
Perfect, here is the one I used: http://forum.xda-developers.com/show....php?t=2322675
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes