Default Push notifications delayed!

I have some problems with my push notifications (gmail, tapatalk, whatsapp) when my phone is connect on Wifi, all notifications are delayed for about few minutes! In settings/wifi/advanced/keep wifi on during sleep i set to Always and thats not problem. Do someone have similar problem, how to fix this push notifications come instantly, not delayed? I have Cisco EPC3925 router. Thanks