Remove All Ads from XDA
Post Reply Subscribe to Thread Email Thread
Hi guys,
after some complication with EFS folder (because of corupted flashing) I have white stripes on screen instead BOOT LOGO which is visible after power on.
Boot animation was normal, means Samsung logo with sound was O.K.
When I search XDA threads then Google etc. etc., I saw some ideas where was BOOT LOGO extracted from ROM's file BOOT.IMG and so on.
Well, I do some research and see that picture with BOOT LOGO (not to be confused with BOOT ANIMATION, because this animation is in file and that file is in folder system/media/ your device and it's no important for me) and now I know that BOOT LOGO picture is in PARAM.BIN/param.lfs (thanks to VEBULOUS and KETUT):
  • lrwxrwxrwx root root 2014-03-15 19:06 BOOT -> /dev/block/mmcblk0p5
  • lrwxrwxrwx root root 2014-03-15 19:06 BOTA0 -> /dev/block/mmcblk0p1
  • lrwxrwxrwx root root 2014-03-15 19:06 BOTA1 -> /dev/block/mmcblk0p2
  • lrwxrwxrwx root root 2014-03-15 19:06 CACHE -> /dev/block/mmcblk0p8
  • lrwxrwxrwx root root 2014-03-15 19:06 EFS -> /dev/block/mmcblk0p3
  • lrwxrwxrwx root root 2014-03-15 19:06 HIDDEN -> /dev/block/mmcblk0p10
  • lrwxrwxrwx root root 2014-03-15 19:06 OTA -> /dev/block/mmcblk0p11
  • lrwxrwxrwx root root 2014-03-15 19:06 PARAM -> /dev/block/mmcblk0p4 <--- Here is hide Boot Logo picture
  • lrwxrwxrwx root root 2014-03-15 19:06 RADIO -> /dev/block/mmcblk0p7
  • lrwxrwxrwx root root 2014-03-15 19:06 RECOVERY -> /dev/block/mmcblk0p6
  • lrwxrwxrwx root root 2014-03-15 19:06 SYSTEM -> /dev/block/mmcblk0p9
  • lrwxrwxrwx root root 2014-03-15 19:06 USERDATA -> /dev/block/mmcblk0p12

Now we know all about partitions and in which partition is BOOT LOGO.
Here is the deal:
We replace boot logo picture in param.lfs.
Warning!!! Everything from now you make at your own risk.
Before this make you a backup of your ROM and EFS partition separately with recovery (CWRM or TWRP, I used last CWM recovery Philz Touch) :

EDIT: But for sure, you can use by my opinion best recovery for Samsung Galaxy HighOnAndroid by Zedomax

I made script and you can install it with your CWM or TWRP recovery, and this is important: Reboot your device after flash this MOD again to recovery! and then boot normaly
You can change your logo pictures by your own. When you unzip my MOD you can see folder "pic" and in this folder file "logo.jpg".
When you change"logo.jpg" by your own picture remember that picture must be 1280x800 (landscape mode) or 800x1280 (portrait mode).
If you somebody got original BOOT LOGO from Samsung Galaxy Note 10.1 (GT-N8000) I would appreciate if someone sent it to me or put the link here to download it.
The second one MOD is the same as first one, but the picture inside the MOD is original black&white Samsung Galaxy Note 10.1 logo
Here is compatible device: (device with sign * I tried my MOD on it by myself with my pals to whom I thank )
  • - Samsung Galaxy Note 10.1 GT-N8000 *
  • - Samsung Galaxy Note 10.1 GT-N8010 *
  • - Samsung Galaxy Note 8.0 GT-N5100 *
  • - Samsung Galaxy Note 8.0 GT-N5110 *
  • - Samsung Galaxy Note 2 GT-N7100
  • - Samsung Galaxy S3 GT-I9300
  • - Samsung Galaxy S3 GT-I9305 LTE
  • - Samsung Galaxy Note 2 GT-N7105 LTE
  • - Hyundai T7, T10 *
  • - Ployer Momo 11 *
  • - Ramos W30 HD, W42
  • - Freelander I20, PD10, PD90 *
  • - Gpad D90
  • - Newman N2
  • - Lenovo K860i *
  • - Lenovo P700i *
  • - Primal P9X
  • - Teamgee S901
  • - Oumei X3
  • - Beneve Miracle Fly
  • - Voyo Q909, Q101, V909
  • - Onn M8
  • - S97, T7, T7S
  • - Meizu MX2, MX4
  • - Excelvan ET1002

If you like my MOD use it, spread it and send me your own BOOT LOGO pictures or just be satisfied like me!
The second MOD is the same as the first one, but the LOGO BOOT picture is original black and white Samsung Galaxy Note 10.1 logo

As you know. All device with Android has their own partitions, so, when you want to injecting BOOT LOGO picture to other than in my list devices, you must looking for PARAM...
for example in HTC devices has this partition another number: dev/block/mmcblk0pX, where the "X" is partition number block!
You can try it, but only at your own risk!
And then and only you can rewrite script with correct number partiton!

The best and easiest way to change the picture is open this ZIP file in Total Commander, where on the left side you will see content of MOD and on the right side you will have prepare logo.jpg (1280x800 or what your screen size is). Then just copy your picture from right side to the left side, Total Commander will ask you "this file already exist, overwright?" and you click YES and we will continue. After then, when you want to close open ZIP file, Total Commander will ask you again "content of ZIP file has been changed, refresh this ZIP?" and you again click YES and that's all. Now you have new ZIP with new logo.jpg inside without unpacking ZIP. Sorry for this step by step method like for newbie (nothing personal ), but when I made this MOD, then I never unpacked this ZIP with external ZIP application again. And this method I always use for all packed files. No need external unpacker

Regards and happy modding! Peter
Attached Files
File Type: zip - [Click for QR Code] (273.2 KB, 146 views)
File Type: zip - [Click for QR Code] (234.5 KB, 99 views)
Last edited by tanker32; 29th March 2014 at 01:07 AM. Reason: added new CWM link
7th August 2014, 06:52 PM |#2  
Senior Member
Flag Eindhoven
Thanks Meter: 37
Wow works good!
23rd September 2014, 10:56 PM |#3  
Inside 4ndroid's Avatar
Senior Member
Flag Dewsbury
Thanks Meter: 266
Donate to Me
Originally Posted by Neorpowa

Wow works good!

id didnt work on my Note 2 n7105 LTE.. trie everyting now... if you have any idea how i can do it without me having to instal ubuntu on my computer please let me know..
21st December 2015, 07:47 AM |#4  
beorn75's Avatar
Junior Member
Flag Carpineti (RE)
Thanks Meter: 0
Some help please
Hey tanker32,
I have some questions, as your method failed on my GT-i9300 but I wish to find a solution with you
Firstly, you wrote the the image size to be 800x1280 (portrait mode), I both tried with your size and with original GT-i9300 size that is 780x1280.
No need to say it failed with both images
What do you suggest to try now?
I am running last TWRP .
The odd stuff is that, when I run install zip from TWRP, it doesn't act as usual, that is to let me see the log of the process while working then waiting for my action after it is done, instead it blinks and goes back to start page (the one with all the choices).
10th January 2016, 04:17 PM |#5  
Mustafa Jafri's Avatar
Senior Member
Flag Karachi
Thanks Meter: 12
Didn't worked on my Note 2 N7105.
11th January 2016, 02:12 PM |#6  
Junior Member
Thanks Meter: 1
Hey, I will you create a zip for my yu yunique!....
I also lost my boot logo...and at present an app icon is my logo. So plz will u port an logo for my yu yunique default brand logo.....i will give you the brand logo image!.......
But where it is located?

Sent from my YU4711 using XDA Forums
Post Reply Subscribe to Thread

boot logo, efs corrupt, exynos

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools
Display Modes