Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,412 Members 45,113 Now Online
XDA Developers Android and Mobile Development Forum

EFS corrupetd: can't restore backupped folder

Tip us?
 
flapane
Old
#1  
flapane's Avatar
Senior Member - OP
Thanks Meter 46
Posts: 329
Join Date: Jul 2010
Location: Naples
Default EFS corrupetd: can't restore backupped folder

It seems that, for somehwat reason, my IMEI corrupted after switching back from TMo UK to my italian carrier. I couldn't connect to the radio right after having landed.
I did a backup of EFS folder about 1 year ago.
However, copyng nv_data.bin and imei folder from the backup to /efs folder, and changing the permissions (chown set to "radio"), didn't work.
I still get "baseband unknown" and no IMEI.
I tried using Root Explorer and adb: the result is the same.
What am I missing?
Thanks in advance
Device: TMo Samsung Vibrant (1850mAh) (GPS HW fix!)
ROM: CM11nightly - Modem: KA7 - Kernel: CM kernel
My theme pics: 1 - 2 - 3
HSDPA:


Flavio's page -> www.flapane.com
 
dzee206
Old
#2  
dzee206's Avatar
Senior Member
Thanks Meter 317
Posts: 594
Join Date: Oct 2011
Location: Seattle
restore a nand with non corrupted efs folder, if that fails odin back to stock and work your way back up to kk.
DEVICE: Vibrant-T959
ROM: C-RoM 7.1
KERNEL: Neo - Kernel CMA TWRP 23.04


The Following User Says Thank You to dzee206 For This Useful Post: [ Click to Expand ]
 
flapane
Old
#3  
flapane's Avatar
Senior Member - OP
Thanks Meter 46
Posts: 329
Join Date: Jul 2010
Location: Naples
Yep, I eventually ODIN'ed to stock.
I wonder why I couldn't restore my backup of EFS folder...
Device: TMo Samsung Vibrant (1850mAh) (GPS HW fix!)
ROM: CM11nightly - Modem: KA7 - Kernel: CM kernel
My theme pics: 1 - 2 - 3
HSDPA:


Flavio's page -> www.flapane.com
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes