Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,925 Members 53,348 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Battery indication weirdness

Tip us?
 
benjimarshall
Old
(Last edited by benjimarshall; 26th April 2014 at 10:26 AM.) Reason: Accidental excessive whitespace
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Default [Q] Battery indication weirdness

Help!!!!!!!!!

I charged my Nexus 7 2012 32gb yesterday morning, and took it off charge in the afternoon. I lightly used it in the evening, and it probably went to bed on ~60-70% charge. My alarm went off as usual at 07:00 this morning, and as far as I can remember, when it woke me up with that alarm the indicator in the top right was in roughly the right position for ~60-70% charge. Come back to it 5 minutes later after getting dressed, I tried to dab the power button to wake it up. That failed. I tried holding it down, trying to turn it on (it randomly turns itself off at times, for the record, so I suspected that). That also failed. I plugged it in to the charger, and it displayed a black screen with the occasional fuzzy rainbow line flickering on the screen.

In absolute panic, I googled this on my phone, and everybody recommended to take it back to PC World, apart from this one person, somewhere, suggesting to unplug it, leave it alone for a while, and try to turn it on then.

So I did that. I waited half an hour, and tried to turn it on. It successfully worked, apart from the fact that it suggested to me it had 0% charge, which is frankly impossible. Nonetheless I plugged it in, and the battery interface in Settings seems to be doing all kinds of weird things. For starters, I've charged it for half an hour, and it still is on 0%.
 

The first photo shows it on its lock screen, plugged in. Note it asks for me to plug it in a charger, but in the top right it alleges that it is plugged in, due to the lightning bolt. Weird.
 

Take picture 2. 0% charge, same as what the notification drop down says. Then "Unknown". Wonderful. Normally,that should say charging, or not charging. But "Unknown"? That doesn't sound good.
 

Then picture 3. The battery usage graph. My understanding is that batteries discharge on a gradient, often a steep one, but not exactly the cliff drop here.

What on earth is going on, and do I really need to take it back to PC World, or can it be fixed?
 
benjimarshall
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2014
Quote:
Originally Posted by benjimarshall View Post
Help!!!!!!!!!

I charged my Nexus 7 2012 32gb yesterday morning, and took it off charge in the afternoon. I lightly used it in the evening, and it probably went to bed on ~60-70% charge. My alarm went off as usual at 07:00 this morning, and as far as I can remember, when it woke me up with that alarm the indicator in the top right was in roughly the right position for ~60-70% charge. Come back to it 5 minutes later after getting dressed, I tried to dab the power button to wake it up. That failed. I tried holding it down, trying to turn it on (it randomly turns itself off at times, for the record, so I suspected that). That also failed. I plugged it in to the charger, and it displayed a black screen with the occasional fuzzy rainbow line flickering on the screen.

In absolute panic, I googled this on my phone, and everybody recommended to take it back to PC World, apart from this one person, somewhere, suggesting to unplug it, leave it alone for a while, and try to turn it on then.

So I did that. I waited half an hour, and tried to turn it on. It successfully worked, apart from the fact that it suggested to me it had 0% charge, which is frankly impossible. Nonetheless I plugged it in, and the battery interface in Settings seems to be doing all kinds of weird things. For starters, I've charged it for half an hour, and it still is on 0%.
 

The first photo shows it on its lock screen, plugged in. Note it asks for me to plug it in a charger, but in the top right it alleges that it is plugged in, due to the lightning bolt. Weird.
 

Take picture 2. 0% charge, same as what the notification drop down says. Then "Unknown". Wonderful. Normally,that should say charging, or not charging. But "Unknown"? That doesn't sound good.
 

Then picture 3. The battery usage graph. My understanding is that batteries discharge on a gradient, often a steep one, but not exactly the cliff drop here.

What on earth is going on, and do I really need to take it back to PC World, or can it be fixed?
EDIT

I've got advice elsewhere and my fix was simply turning the device off, power cable out, then booting it to the Android Bootloader. From there I selected the shutdown option using the volume and power keys, and waited till I was sure it had shutdown. With the off device, I plugged in the power cable, and then turned it on normally. Problem solved.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes