FORUMS

OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

Make Your Lockscreen More Productive With Widgets

Are you running Android Lollipop? Do you miss the ability to add widgets to your lock … more
Post Reply Subscribe to Thread Email Thread
Hi. I've read around the web that Chromecast uses it's own DNS regardless of what's on the router.
I can't figure out how to block that.
I have a Vodafone Huawei HG658c
I have the passwords for the Admin settings, and can access static route and all that, but no matter what guides I read I can't figure it out.
I'm also using Unblock-us. I have it working on everything but chromecast.
I'd even go as far as letting a trusted member teamview in to get this working. Or I can provide any screenshots of my router page needed.
8th May 2014, 09:31 PM |#2  
Senior Member
Thanks Meter: 112
 
More
Post your static routes page.
The Following User Says Thank You to DJames1 For This Useful Post: [ View ]
8th May 2014, 09:37 PM |#3  
irish-sid's Avatar
OP Senior Member
Thanks Meter: 182
 
More
Quote:
Originally Posted by DJames1

Post your static routes page.

Attached
Attached Thumbnails
Click image for larger version

Name:	1stat.PNG
Views:	433
Size:	46.8 KB
ID:	2733023  
8th May 2014, 11:25 PM |#4  
Senior Member
Thanks Meter: 112
 
More
Ok, you should be able to create static routes to disable Google DNS.

Check your router's home page to see what your LAN address range is. (for example something like 192.168.1.1 - 192.168.1.255, with a mask of 255.255.255.0 would be typical, but yours might be different) You need to pick an address in this range that doesn't exist, e.g., something like 192.168.1.99)

Then enter a static route with:

Destination network address: 8.8.8.0
Subnet mask: 255.255.255.0
Gateway: 192.168.1.99 (or whatever non-existent LAN address you picked above)

Probably ok to leave on Interface as Auto, or pick LAN or LAN+wireless if you have to choose.

And repeat for 8.8.4.0.

This only blocks Google DNS. Then you still have to insert your unblock-us DNS addresses in the router's DNS fields.
Last edited by DJames1; 8th May 2014 at 11:29 PM.
The Following User Says Thank You to DJames1 For This Useful Post: [ View ]
8th May 2014, 11:36 PM |#5  
irish-sid's Avatar
OP Senior Member
Thanks Meter: 182
 
More
Quote:
Originally Posted by DJames1

Ok, you should be able to create static routes to disable Google DNS.

Check your router's home page to see what your LAN address range is. (for example something like 192.168.1.1 - 192.168.1.255, with a mask of 255.255.255.0 would be typical, but yours might be different) You need to pick an address in this range that doesn't exist, e.g., something like 192.168.1.99)

Then enter a static route with:

Destination network address: 8.8.8.0
Subnet mask: 255.255.255.0
Gateway: 192.168.1.99 (or whatever non-existent LAN address you picked above)

Probably ok to leave on Interface as Auto, or pick LAN or LAN+wireless if you have to choose.

And repeat for 8.8.4.0.

This only blocks Google DNS. Then you still have to insert your unblock-us DNS addresses in the router's DNS fields.

Ah, so it's an unused address I have to put? I'll give this a go and let you know. Thanks a LOT!!!!!
9th May 2014, 12:17 AM |#6  
irish-sid's Avatar
OP Senior Member
Thanks Meter: 182
 
More
Doesn't seemed to have worked. I even tried the other Google dns's too (see pic)

Nothing is on .123 so I put the address as that.
Chromecast is static on .125
I have the unblockus dns address in correctly as all other devices work.
I've rebooted everything too to make sure.
Starts playing fine on laptop or phone, but when casted it comes up with "We're having trouble playing this title........"
Attached Thumbnails
Click image for larger version

Name:	dun.png
Views:	226
Size:	40.1 KB
ID:	2733195  
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes