Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

R/W problem [solved kinda]

OP stovo06

8th May 2014, 11:06 PM   |  #1  
stovo06's Avatar
OP Senior Member
Flag st. louis, mo
Thanks Meter: 170
 
576 posts
Join Date:Joined: Sep 2012
I've got a problem and can't seem to find a fix.
Been rooted and s-off for a couple weeks now.
I started out getting rooted through htc dev unlock and flashing Capt's recovery (the one that erased everything). I installed Viper and after some persistence a good guy talked me into s-off.
No problems.
Last night I decided to get crazy and try a new ROM. I chose Bad Boyz cause OMJ always seems like a legit person.
So to my problem in the best details possible (my apologies if all this is unnecessary)...
I did a backup (of course) and installed Bad Boyz ROM. During setup I hit a bump. HTC was restoring my setup and apps and it got stuck so I rebooted. Immediately after that I finished setup and then Google play kept giving me an "error 920".
I went into recovery and using Capt's 2.7.0.7 twrp fixed permissions. That didn't work. I restored my Viper backup. That didn't work. Using Titanium Backup I wiped Google play store data then cache. That worked!
However, one problem solved a bigger one arises.
I no longer have the ability to move files from internal sd to external.
I've tried everything I can think of. I've checked on ES File Manager it says it's R/W but fails when tried. Same with Root Explorer and FX.
I've wiped and reinstalled Viper but same problem.
I've read MassStash's thread and tried to go into system/etc/permission/platform but it already shows as rw.

So I'm stumped. Can anyone help?


Sent from my 831C using XDA Free mobile app
Last edited by stovo06; 9th May 2014 at 02:09 AM.
9th May 2014, 07:05 AM   |  #2  
EVOuser94's Avatar
Senior Member
Flag Bloomsdale
Thanks Meter: 402
 
804 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by stovo06

I've got a problem and can't seem to find a fix.
Been rooted and s-off for a couple weeks now.
I started out getting rooted through htc dev unlock and flashing Capt's recovery (the one that erased everything). I installed Viper and after some persistence a good guy talked me into s-off.
No problems.
Last night I decided to get crazy and try a new ROM. I chose Bad Boyz cause OMJ always seems like a legit person.
So to my problem in the best details possible (my apologies if all this is unnecessary)...
I did a backup (of course) and installed Bad Boyz ROM. During setup I hit a bump. HTC was restoring my setup and apps and it got stuck so I rebooted. Immediately after that I finished setup and then Google play kept giving me an "error 920".
I went into recovery and using Capt's 2.7.0.7 twrp fixed permissions. That didn't work. I restored my Viper backup. That didn't work. Using Titanium Backup I wiped Google play store data then cache. That worked!
However, one problem solved a bigger one arises.
I no longer have the ability to move files from internal sd to external.
I've tried everything I can think of. I've checked on ES File Manager it says it's R/W but fails when tried. Same with Root Explorer and FX.
I've wiped and reinstalled Viper but same problem.
I've read MassStash's thread and tried to go into system/etc/permission/platform but it already shows as rw.

So I'm stumped. Can anyone help?


Sent from my 831C using XDA Free mobile app

Sir, simple I had same issue... When I open ES Explorer, I find the Root Explorer Option, tick it off, Exit out go to Superuser and clear any ES Explorer opinion you find. Go open ES Explorer and press back key when it asks for Root Permissions, go to Root Explorer option and tick it back on, accept Root Permissions! Then you press and hold on Root Options, It'll pop up a R/W menu where you can remount system, and external card, etc... If that doesn't do it it's got me beat!!

Sent from my 831C using XDA Premium 4 mobile app
Last edited by EVOuser94; 9th May 2014 at 08:38 AM.
The Following User Says Thank You to EVOuser94 For This Useful Post: [ View ]
10th May 2014, 12:35 AM   |  #3  
stovo06's Avatar
OP Senior Member
Flag st. louis, mo
Thanks Meter: 170
 
576 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by EVOuser94

Sir, simple I had same issue... When I open ES Explorer, I find the Root Explorer Option, tick it off, Exit out go to Superuser and clear any ES Explorer opinion you find. Go open ES Explorer and press back key when it asks for Root Permissions, go to Root Explorer option and tick it back on, accept Root Permissions! Then you press and hold on Root Options, It'll pop up a R/W menu where you can remount system, and external card, etc... If that doesn't do it it's got me beat!!

Sent from my 831C using XDA Premium 4 mobile app


EVOuser94 you better quit calling me sir! Make me think I'm old lol.
Not sure what the issue was. Just one particular file that appeared when changing ROMs wanted to be stubborn. Finally just deleted the file and put it behind me.
Thanks to Vinchenzop from the Viper team on the HTC Max & EVO 4g lte and MassStash for assistance in helping a brother out. Think I'd still be messing with it if it weren't for them 👍
Anyway problem (kinda) solved

Sent from my 831C using XDA Free mobile app
10th May 2014, 12:42 AM   |  #4  
BD619's Avatar
Forum Moderator
Flag Xda-Dev,NV
Thanks Meter: 8,085
 
8,449 posts
Join Date:Joined: Apr 2012
Donate to Me
More
2 words for you...
Root Explorer
Has never failed to do anything I have asked it to do.
Best $3-4 bucks I;ve ever spent.
Last edited by BD619; 10th May 2014 at 01:18 AM.
The Following User Says Thank You to BD619 For This Useful Post: [ View ]
10th May 2014, 01:43 AM   |  #5  
EVOuser94's Avatar
Senior Member
Flag Bloomsdale
Thanks Meter: 402
 
804 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by stovo06

EVOuser94 you better quit calling me sir! Make me think I'm old lol.
Not sure what the issue was. Just one particular file that appeared when changing ROMs wanted to be stubborn. Finally just deleted the file and put it behind me.
Thanks to Vinchenzop from the Viper team on the HTC Max & EVO 4g lte and MassStash for assistance in helping a brother out. Think I'd still be messing with it if it weren't for them 👍
Anyway problem (kinda) solved

Sent from my 831C using XDA Free mobile app

Lol, you could always delete the file in recovery.... But yeah, what's the kinda part about still?

Sent from my 831C using XDA Premium 4 mobile app
The Following User Says Thank You to EVOuser94 For This Useful Post: [ View ]
10th May 2014, 02:54 AM   |  #6  
stovo06's Avatar
OP Senior Member
Flag st. louis, mo
Thanks Meter: 170
 
576 posts
Join Date:Joined: Sep 2012
Quote:
Originally Posted by BD619

2 words for you...
Root Explorer
Has never failed to do anything I have asked it to do.
Best $3-4 bucks I;ve ever spent.

Got it.
Strongly agree.





Quote:
Originally Posted by EVOuser94

Lol, you could always delete the file in recovery.... But yeah, what's the kinda part about still?

Sent from my 831C using XDA Premium 4 mobile app

Never figured out why it wouldn't move (with ES, Root Ex, or FX Ex). So I just said f it and deleted the folder. So problem (kinda) solved lol.

Check out TheMikMik
10th May 2014, 04:58 AM   |  #7  
EVOuser94's Avatar
Senior Member
Flag Bloomsdale
Thanks Meter: 402
 
804 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by stovo06

Got it.
Strongly agree.







Never figured out why it wouldn't move (with ES, Root Ex, or FX Ex). So I just said f it and deleted the folder. So problem (kinda) solved lol.

Check out TheMikMik

Lol, fair enough....

Sent from my 831C using XDA Premium 4 mobile app
The Following User Says Thank You to EVOuser94 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes