Battery Charged in 30 Seconds? Maybe in 2016

Phones and tablets are getting more and more power hungry with each passing generation. Their … more

ZArchive Manages Your File Archives

Today smartphones are quite powerful devices that can handle multiple processes at once. In fact, some of … more

Regain Double Tap to Wake Functionality on the Nexus 6

A few months ago, Google announced its newest flagship device, the Nexus 6, alongside … more

Clean Your Recent Apps – XDA Xposed Tuesday

In this day and age, you have quite a few apps installed and running on your Android … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Usb Port cover missing, can it be replaced?

OP ben.cordy

8th May 2014, 11:11 PM   |  #1  
OP Member
Thanks Meter: 6
 
86 posts
Join Date:Joined: Dec 2009
Hi all, just got my SW2 tonight used! Loving it so far! Unfortunately the previous owner pulled the black part of the port cover off by accident and then lost it. Theres still a clear plastic piece with the bits that actually go into the port. Has this happened to anyone else? I'm worried without the black part moisture may get in? I know the remaining bit does fill the post but with out the black square I'm not sure if it's vulnerable.

What do you guys think? Anyone had this break on them?

I've attached an image of the piece that's left!
Attached Thumbnails
Click image for larger version

Name:	2014-05-08 22.09.31.jpg
Views:	179
Size:	241.5 KB
ID:	2733052  
9th May 2014, 12:20 AM   |  #2  
kill_dano's Avatar
Senior Member
Thanks Meter: 56
 
220 posts
Join Date:Joined: Oct 2007
Quote:
Originally Posted by ben.cordy

Hi all, just got my SW2 tonight used! Loving it so far! Unfortunately the previous owner pulled the black part of the port cover off by accident and then lost it. Theres still a clear plastic piece with the bits that actually go into the port. Has this happened to anyone else? I'm worried without the black part moisture may get in? I know the remaining bit does fill the post but with out the black square I'm not sure if it's vulnerable.

What do you guys think? Anyone had this break on them?

I've attached an image of the piece that's left!

I think the rubber gasket is still attached. Check for it. if so, then find something made of black plastic and shape it into the right size with a dremel. then glue it on.
9th May 2014, 08:28 AM   |  #3  
OP Member
Thanks Meter: 6
 
86 posts
Join Date:Joined: Dec 2009
Quote:
Originally Posted by kill_dano

I think the rubber gasket is still attached. Check for it. if so, then find something made of black plastic and shape it into the right size with a dremel. then glue it on.

Is the rubber gasket that clear is piece? Guessing the black bit is actually very thin as there isn't much more room!
9th May 2014, 03:40 AM   |  #4  
princemarcus19's Avatar
Senior Member
Flag Bronx,NY
Thanks Meter: 39
 
238 posts
Join Date:Joined: Jan 2011
More
**** just happened to me 2 days ago,lucky i have my pieace, amma super gule it bck its hard to pull it out with the cover even thou platic layer is protecting it.

Sent from my C6833 using XDA Free mobile app
9th May 2014, 08:29 AM   |  #5  
OP Member
Thanks Meter: 6
 
86 posts
Join Date:Joined: Dec 2009
Quote:
Originally Posted by princemarcus19

**** just happened to me 2 days ago,lucky i have my pieace, amma super gule it bck its hard to pull it out with the cover even thou platic layer is protecting it.

Sent from my C6833 using XDA Free mobile app

Gutted! Wish the piece was still here for this one! Doubt Sony can provide replacements!
19th May 2014, 02:17 PM   |  #6  
OP Member
Thanks Meter: 6
 
86 posts
Join Date:Joined: Dec 2009
So it's continued to bug me, I'm no trying to solve this myself. I've tried various rubber pieces but everything is a little too deep (the remaining part is quite deep so the outer piece must be very very thin. Currently trial is with a product called sugru which is moldable chewing gum consistancy but solidifies over night. I've packed the port with it and will see if it does the trick! Because the inner piece is still there the new rubber should just bond with that like the original port cover!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes