Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,011 Members 47,701 Now Online
XDA Developers Android and Mobile Development Forum

Usb Port cover missing, can it be replaced?

Tip us?
 
ben.cordy
Old
#1  
Member - OP
Thanks Meter 6
Posts: 72
Join Date: Dec 2009
Default Usb Port cover missing, can it be replaced?

Hi all, just got my SW2 tonight used! Loving it so far! Unfortunately the previous owner pulled the black part of the port cover off by accident and then lost it. Theres still a clear plastic piece with the bits that actually go into the port. Has this happened to anyone else? I'm worried without the black part moisture may get in? I know the remaining bit does fill the post but with out the black square I'm not sure if it's vulnerable.

What do you guys think? Anyone had this break on them?

I've attached an image of the piece that's left!
Attached Thumbnails
Click image for larger version

Name:	2014-05-08 22.09.31.jpg
Views:	175
Size:	241.5 KB
ID:	2733052  
 
kill_dano
Old
#2  
kill_dano's Avatar
Senior Member
Thanks Meter 47
Posts: 193
Join Date: Oct 2007
Quote:
Originally Posted by ben.cordy View Post
Hi all, just got my SW2 tonight used! Loving it so far! Unfortunately the previous owner pulled the black part of the port cover off by accident and then lost it. Theres still a clear plastic piece with the bits that actually go into the port. Has this happened to anyone else? I'm worried without the black part moisture may get in? I know the remaining bit does fill the post but with out the black square I'm not sure if it's vulnerable.

What do you guys think? Anyone had this break on them?

I've attached an image of the piece that's left!
I think the rubber gasket is still attached. Check for it. if so, then find something made of black plastic and shape it into the right size with a dremel. then glue it on.
 
ben.cordy
Old
#3  
Member - OP
Thanks Meter 6
Posts: 72
Join Date: Dec 2009
Quote:
Originally Posted by kill_dano View Post
I think the rubber gasket is still attached. Check for it. if so, then find something made of black plastic and shape it into the right size with a dremel. then glue it on.
Is the rubber gasket that clear is piece? Guessing the black bit is actually very thin as there isn't much more room!
 
princemarcus19
Old
#4  
princemarcus19's Avatar
Senior Member
Thanks Meter 39
Posts: 238
Join Date: Jan 2011
Location: Bronx,NY
**** just happened to me 2 days ago,lucky i have my pieace, amma super gule it bck its hard to pull it out with the cover even thou platic layer is protecting it.

Sent from my C6833 using XDA Free mobile app
 
ben.cordy
Old
#5  
Member - OP
Thanks Meter 6
Posts: 72
Join Date: Dec 2009
Quote:
Originally Posted by princemarcus19 View Post
**** just happened to me 2 days ago,lucky i have my pieace, amma super gule it bck its hard to pull it out with the cover even thou platic layer is protecting it.

Sent from my C6833 using XDA Free mobile app
Gutted! Wish the piece was still here for this one! Doubt Sony can provide replacements!
 
ben.cordy
Old
#6  
Member - OP
Thanks Meter 6
Posts: 72
Join Date: Dec 2009
So it's continued to bug me, I'm no trying to solve this myself. I've tried various rubber pieces but everything is a little too deep (the remaining part is quite deep so the outer piece must be very very thin. Currently trial is with a product called sugru which is moldable chewing gum consistancy but solidifies over night. I've packed the port with it and will see if it does the trick! Because the inner piece is still there the new rubber should just bond with that like the original port cover!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes