Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,214 Members 37,868 Now Online
XDA Developers Android and Mobile Development Forum

MDR10R Headset not being detected correctly

Tip us?
 
goon3r
Old
#1  
Member - OP
Thanks Meter 0
Posts: 37
Join Date: Sep 2010
Location: Miami, FL
Default MDR10R Headset not being detected correctly

Hey All,

I have pair of Sony MDR10R headphones (with mic and remote) that I have been using with a Z1s and Z for several months. Since I have gotten my Z2 I am noticing that the device is being detected as a headphone only device and as a result the mic and remote button do not work. The behavior is inconsistent, but about 90% of the time it is detecting it as headphone only.

Most other headsets with Mic work fine and detect correctly except for these. I have tried a couple different pairs of Sony headphones with remotes and see the same type of inconsistent behavior. As a result I never know how the unit is going to function when I plug in the headphones. I'm just not sure as result if this is a software issue or a problem with the headphone port.

Has anybody seen any similar behavior ?

Below are some screen shots of what I see in the notification tray:


Attached Thumbnails
Click image for larger version

Name:	2014-05-15 22.31.22.png
Views:	1052
Size:	91.9 KB
ID:	2749746   Click image for larger version

Name:	2014-05-15 22.22.01.png
Views:	1045
Size:	90.4 KB
ID:	2749747  
 
Dragooon123
Old
#2  
Senior Member
Thanks Meter 114
Posts: 1,042
Join Date: Aug 2008
Location: National Capital Region(NCR)
Sony supplies some odd mics with their headphones, I have a pair of MDR-1R (awesome headphones btw) but their mics don't work with any android handset
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes