Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Rooted, Carbon ROM, Mobile data and Wifi problems

OP Karlovsky120

20th May 2014, 12:45 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2014
So I have rooted my S4 Mini, as described here and installed JellyBean version of Carbon rom for S4 Mini LTE (i9195, my model).

I used this guide when rooting and I used this rom version.

Everything works as should, but my data network is behaveing strangely. It's not that it's not working, it does connect to via H+, 3G (which imediatley turns into DC which is something I haven't seen on stock rom). But it connects only sometimes and doesn't work at other times in places where it definitly should. And 4G never works (in places it worked on stock).

Disregard Wi-fi part, I had some issues with my router, there was never a problem with my phone (at least regarding the Wi-Fi)

My APN is fine, it wouldn't be able to connect otherwise (and I checked the settings).

Any ideas?

Ask for any additional information. =)
Last edited by Karlovsky120; 20th May 2014 at 02:08 AM.
20th May 2014, 03:42 PM   |  #2  
Aronuser's Avatar
Senior Member
Thanks Meter: 239
 
648 posts
Join Date:Joined: Mar 2014
More
Quote:
Originally Posted by Karlovsky120

So I have rooted my S4 Mini, as described here and installed JellyBean version of Carbon rom for S4 Mini LTE (i9195, my model).

I used this guide when rooting and I used this rom version.

Everything works as should, but my data network is behaveing strangely. It's not that it's not working, it does connect to via H+, 3G (which imediatley turns into DC which is something I haven't seen on stock rom). But it connects only sometimes and doesn't work at other times in places where it definitly should. And 4G never works (in places it worked on stock).

Disregard Wi-fi part, I had some issues with my router, there was never a problem with my phone (at least regarding the Wi-Fi)

My APN is fine, it wouldn't be able to connect otherwise (and I checked the settings).

Any ideas?

Ask for any additional information. =)

I hope somebody else knows, but if you don't find any solution just change the rom
11th July 2014, 08:15 PM   |  #3  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2014
FOUND FIX!!!
I too had this problem on 4.3.1 carbon rom. I wiped data using recovery boot and at first it didn't help. But it started working again in a few seconds. Magical fix. Let me know if this works for you too.
12th July 2014, 10:55 AM   |  #4  
Junior Member
Flag Santiago
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by Karlovsky120

So I have rooted my S4 Mini, as described here and installed JellyBean version of Carbon rom for S4 Mini LTE (i9195, my model).

I used this guide when rooting and I used this rom version.

Everything works as should, but my data network is behaveing strangely. It's not that it's not working, it does connect to via H+, 3G (which imediatley turns into DC which is something I haven't seen on stock rom). But it connects only sometimes and doesn't work at other times in places where it definitly should. And 4G never works (in places it worked on stock).

Disregard Wi-fi part, I had some issues with my router, there was never a problem with my phone (at least regarding the Wi-Fi)

My APN is fine, it wouldn't be able to connect otherwise (and I checked the settings).

Any ideas?

Ask for any additional information. =)

Hi, I'm install the [ROM][UNOFFICIAL][4.4.4] CarbonRom KitKat Weekly's [S4 Mini 3G/LTE/3GDS] [app2sd] on my S4 Mini I9195 LTE and I have no problems with the data network... you could try that ROM, is awesome.
The only issue i have is in the Lockscreen... can't set the weather option in the Lockscreen... the Lockscreen no shows the wheather.
If any can help me with how do that, I will apreciated...... (sorry for my bad english... I'm from South America).
Cheers!
21st July 2014, 12:11 AM   |  #5  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2013
Quote:
Originally Posted by Karlovsky120

So I have rooted my S4 Mini, as described here and installed JellyBean version of Carbon rom for S4 Mini LTE (i9195, my model).

I used this guide when rooting and I used this rom version.

Everything works as should, but my data network is behaveing strangely. It's not that it's not working, it does connect to via H+, 3G (which imediatley turns into DC which is something I haven't seen on stock rom). But it connects only sometimes and doesn't work at other times in places where it definitly should. And 4G never works (in places it worked on stock).

Disregard Wi-fi part, I had some issues with my router, there was never a problem with my phone (at least regarding the Wi-Fi)

My APN is fine, it wouldn't be able to connect otherwise (and I checked the settings).

Any ideas?

Ask for any additional information. =)

same problem. Do you use a 3G or 4G signal from your network provider ?
21st July 2014, 06:09 AM   |  #6  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Feb 2013
Possible fix for you
Quote:
Originally Posted by sheky01

same problem. Do you use a 3G or 4G signal from your network provider ?

Hi again, i spent hours trying to fix this and came up with a solution:

Make a back up of your current rom

Use Odin to flash the I9195XXUBMJ7_I9195OXABMJ7_DBT file ( can provide if needed ) to go back to stock firmware

Make note of the APN settings of the stock firmware, then restore the back up and change the apn settings to the same as the stock and it should work.

This worked for me.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes