Android 5.0.2 and New Factory Images For Nexus 7 (Wi-Fi) Available

Android 5.0 is has been publicly available since early November, and the … more

Github Tutorial App Shows You How to Use… Github

Github can get pretty complicated and using it can become quite daunting, especially … more

Google Glass-like Clip-On For Regular Glasses Developed by Sony

For the price of $2,000, a pair of glasses that can run apps, take pictures, … more

Micromax Takes OnePlus to Court! Android Wear Receives Lollipop – XDA TV

Android 5.0 Lollipop is available officially for the Moto 360! … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Thought all Verizon 4G phones were carrier unlocked.

OP Alexcxvtr

21st June 2014, 08:58 AM   |  #1  
OP Senior Member
Thanks Meter: 13
 
247 posts
Join Date:Joined: May 2011
More
Greetings.

It seems I'm facing a weird problem here.
To begin with, I live in Europe and I've just bought a Verizon M8.
After boot, a pop up reads that this sim card is not from Verizon.
Although, my sim card CAN receive calls and messages (there is also the app from my carrier services) I cannot make any calls.
What happens is that when I'm trying to dial a number, +1 appears in front of the phone number and call is dropped.
+1 is the phone code for the US.
Well, I don't want this.
I thought every single Verizon 4G phone was carrier unlocked out-of-the-box.
To be honest, I know it, because there is some kind of legislation forcing Verizon to sell their 4G phones unlocked.

Could anyone please help me?
What should I do?
Flash another firmware? And which one?
Last edited by Alexcxvtr; 21st June 2014 at 09:02 AM.
21st June 2014, 09:13 AM   |  #2  
Junior Member
Thanks Meter: 6
 
21 posts
Join Date:Joined: Aug 2012
It should be. May need to change the APN settings.
21st June 2014, 09:19 AM   |  #3  
OP Senior Member
Thanks Meter: 13
 
247 posts
Join Date:Joined: May 2011
More
Thought you just pop the sim card in and voila.
I don't know how to change the APN settings.
And why should I do that if the device comes unlocked?
Do I miss something?
Surely, my sim card is not damaged.
21st June 2014, 09:31 AM   |  #4  
Junior Member
Thanks Meter: 6
 
21 posts
Join Date:Joined: Aug 2012
In settings click Mobile Data, then click GSM/UMTS Options. IT should let you change the APN.

Which carrier do you have?
21st June 2014, 10:13 AM   |  #5  
OP Senior Member
Thanks Meter: 13
 
247 posts
Join Date:Joined: May 2011
More
Cosmote (GR)

You think this will work?
21st June 2014, 10:24 AM   |  #6  
Junior Member
Thanks Meter: 6
 
21 posts
Join Date:Joined: Aug 2012
http://www.unlockit.co.nz/mobilesett...ngs.php?id=131

Try that, and click where it says Android Manual setup.
21st June 2014, 01:53 PM   |  #7  
Senior Member
Thanks Meter: 22
 
127 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by Alexcxvtr

Greetings.

It seems I'm facing a weird problem here.
To begin with, I live in Europe and I've just bought a Verizon M8.
After boot, a pop up reads that this sim card is not from Verizon.
Although, my sim card CAN receive calls and messages (there is also the app from my carrier services) I cannot make any calls.
What happens is that when I'm trying to dial a number, +1 appears in front of the phone number and call is dropped.
+1 is the phone code for the US.
Well, I don't want this.
I thought every single Verizon 4G phone was carrier unlocked out-of-the-box.
To be honest, I know it, because there is some kind of legislation forcing Verizon to sell their 4G phones unlocked.

Could anyone please help me?
What should I do?
Flash another firmware? And which one?

Have you looked into the "Set Current Country" options in the Assisted Dialing section of the Phone settings? Or perhaps just turn Assisted Dialing off (I think it's on by default).
The Following User Says Thank You to Dodge DeBoulet For This Useful Post: [ View ]
21st June 2014, 02:06 PM   |  #8  
OP Senior Member
Thanks Meter: 13
 
247 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by Dodge DeBoulet

Have you looked into the "Set Current Country" options in the Assisted Dialing section of the Phone settings? Or perhaps just turn Assisted Dialing off (I think it's on by default).

YESSSSS!!!

Oh, man, thank you so much!
That's it!
Assisted Dialing was enabled and caused the problem.
You are the man!

Now, I will try to find a way to make LTE work.
(I know it doesn't work on other US carriers, but globally it should. I've seen it.)
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes