FORUMS

XDA Picks: Best Apps of the Week (Apr 17 – 24)

Apps are at the front and center of any smartphone experience, and with over a … more

Glimpse Notifications: Easier Lockscreen Notifications

Lollipop brought a revamp to the lockscreen, taking away custom widgets but … more

What Are the Best Looking Apps on Android?

As more developers are updating their apps with Material Design elements, we’re … more

Cyngn Explained: Who’s Cyanogen, What’s Cyanogen OS?

While Cyanogen, Inc has been the source of many headlines lately, there … more
Post Reply Subscribe to Thread Email Thread

[Q] Z Ultra GPE back to stock 4.4.2

21st June 2014, 11:35 PM |#1  
OP Member
Thanks Meter: 4
 
More
I just bought a ZU GPE with 4.4.3 (rooted, custom recovery installed) that has a broken rear camera (can't focus, can't shoot).
Will going back to 4.4.2 fix the issue?
How can I flash the system dump (ZU4.4.2.zip) from the following thread? Will it brick my phone?

http://forum.xda-developers.com/show....php?t=2570197

I am used to going back to stock with RUU files on my HTC M7 and M8 but this is my first Sony and I am completely lost.
Any help would be greatly appreciated.

Thank you.
21st June 2014, 11:55 PM |#2  
Senior Member
Thanks Meter: 682
 
More
Quote:
Originally Posted by ddslee

I just bought a ZU GPE with 4.4.3 (rooted, custom recovery installed) that has a broken rear camera (can't focus, can't shoot).
Will going back to 4.4.2 fix the issue?
How can I flash the system dump (ZU4.4.2.zip) from the following thread? Will it brick my phone?

http://forum.xda-developers.com/show....php?t=2570197

I am used to going back to stock with RUU files on my HTC M7 and M8 but this is my first Sony and I am completely lost.
Any help would be greatly appreciated.

Thank you.

See this post, and yes rolling back to 4.4.2 should fix rear camera.
http://forum.xda-developers.com/show...0&postcount=27
The Following User Says Thank You to adfurgerson For This Useful Post: [ View ]
21st June 2014, 11:59 PM |#3  
OP Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by adfurgerson

See this post, and yes rolling back to 4.4.2 should fix rear camera.
http://forum.xda-developers.com/show...0&postcount=27

Thanks for the reply but that link is for 4.4.3. I just can't seem to find 4.4.2 system, BOOT and FOTAKernal files anywhere.
All I found was a system dump file ZU4.4.2. Where can I find the appropriate files?
Thanks!
22nd June 2014, 12:10 AM |#4  
Senior Member
Thanks Meter: 682
 
More
Quote:
Originally Posted by ddslee

Thanks for the reply but that link is for 4.4.3. I just can't seem to find 4.4.2 system, BOOT and FOTAKernal files anywhere.
All I found was a system dump file ZU4.4.2. Where can I find the appropriate files?
Thanks!

Sorry I didn't catch that the post linked to 4.4.3 files. I rolled back to 4.4.2 with a nandroid backup. If you don't find the files you need by tomorrow I will try to see if I would be able to pull them for you.
The Following User Says Thank You to adfurgerson For This Useful Post: [ View ]
22nd June 2014, 12:11 AM |#5  
OP Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by adfurgerson

Sorry I didn't catch that the post linked to 4.4.3 files. I rolled back to 4.4.2 with a nandroid backup. If you don't find the files you need by tomorrow I will try to see if I would be able to pull them for you.

I have searched all day today with no success. I would really really appreciate it if you could share the file with me.
Thank you!!!!
22nd June 2014, 12:32 AM |#6  
Senior Member
Thanks Meter: 682
 
More
Quote:
Originally Posted by ddslee

I have searched all day today with no success. I would really really appreciate it if you could share the file with me.
Thank you!!!!

You are not the only one trying to get back to 4.4.2, I asked in this post if either of these ideas would work but wasn't answered.
http://forum.xda-developers.com/show...0&postcount=20
The Following User Says Thank You to adfurgerson For This Useful Post: [ View ]
22nd June 2014, 12:52 AM |#7  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,632
 
Donate to Me
More
Quote:
Originally Posted by ddslee

I have searched all day today with no success. I would really really appreciate it if you could share the file with me.
Thank you!!!!

I would try this method http://forum.xda-developers.com/show....php?t=2761698
with the 4.4.2 full OTA

Will it work?
Will the OTA zip need editing to remove the version check, and will that work?

@DooMLoRD?
22nd June 2014, 01:43 AM |#8  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,632
 
Donate to Me
More
Easy enough to remove the version check in the 4.4.2 ota, and I'm sure that it would then install with only a error on patching the bootloader.
Maybe you should move this to the gpe section so doomlord might see it sooner

Sent from CarbonROM on my Z-Ultra
23rd June 2014, 01:25 AM |#9  
blueether's Avatar
Senior Member
Flag Te Awamutu, New Zealand
Thanks Meter: 1,632
 
Donate to Me
More
It will be the first few line that start with assert(...)

Sent from CarbonROM on my Z-Ultra
The Following User Says Thank You to blueether For This Useful Post: [ View ]
23rd June 2014, 02:59 AM |#10  
OP Member
Thanks Meter: 4
 
More
Quote:
Originally Posted by blueether

It will be the first few line that start with assert(...)

Sent from CarbonROM on my Z-Ultra

Thanks for your input but I have no computer science background. I can flash roms and stuff but have no clue how to proceed with this.

All I want to accompish here is to get the camera working so that I can give the phone to my wife for her birthday present.

I bought this phone in used condition thinking it was stock gpe but I got scammed by a seller who I am sure frequents this site because he had rooted, installed custom recovery, played with custom roms, went back to stock, updated to 4.4.3 and sold me a phone with a broken camera as "like new".

I know it is a lot to ask from a total stranger, but would you help this poor noob by uploading a edited 4.4.2 OTA that I can use to fix this phone please?
Last edited by ddslee; 23rd June 2014 at 03:09 AM. Reason: spelling
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes