Document the Story of Your Social Life with 8tory

The different forms of social media are growing every day. It’s hard to imagine a day … more

Make Calling Your Loved Ones Easier and Cheaper this Diwali

Diwali, or Deepawali as some Indians call it, is the pride and joy of Indian … more

Big Android BBQ 5.0 Recap – XDA TV

This fifth annual Big Android BBQ has come and gone. The speakers have spoke, the sponsors have … more

Microsoft to Counter “OK Google” with Bing Torque

When Microsoft is making apps for Android, users should be aware that something … more
Post Reply

How to mod framework-res.apk having issues for call recording?

OP TheArtiszan

23rd June 2014, 11:03 PM   |  #1  
OP Senior Member
Thanks Meter: 96
 
870 posts
Join Date:Joined: Jun 2009
Hello all.
I was wondering if someone might be able to help me with this.
I am using the apk multitool and can decompile the framework but get loads of errors when I try to recompile it.
This method worked well on my s4 and other devices but am having issues with this one.
What programs are you using to decompile and recompile the framework.
Or can anyone mod it to include the wifi tethering bypass and call recording features?
Any help would be greatly appreciated
24th June 2014, 06:08 AM   |  #2  
OP Senior Member
Thanks Meter: 96
 
870 posts
Join Date:Joined: Jun 2009
Can anyone help?
I don't know what I am doing wrong.
The recompile just won't go through.
Even if I don't make any changes.
24th June 2014, 09:51 AM   |  #3  
elesbb's Avatar
Senior Member
Thanks Meter: 4,411
 
6,849 posts
Join Date:Joined: Jun 2010
Donate to Me
Use the tool in my link. Worked just fine for me.

Sent from my SM-G900T using Tapatalk

---------- Post added at 09:51 AM ---------- Previous post was at 09:50 AM ----------

Also post any compile errors.

Sent from my SM-G900T using Tapatalk
24th June 2014, 08:43 PM   |  #4  
OP Senior Member
Thanks Meter: 96
 
870 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by elesbb

Use the tool in my link. Worked just fine for me.

Sent from my SM-G900T using Tapatalk

---------- Post added at 09:51 AM ---------- Previous post was at 09:50 AM ----------

Also post any compile errors.

Sent from my SM-G900T using Tapatalk

Thank you for the help,
I tried using your tool and can decompile the file okay now.
But am still running into problems recompiling it.
I have included the errors I am getting in a code block.
I am running Windows 8 and I am not sure if that might be part of the problem or not.
Any help would be appreciated with that.
Just still kinda amazed as this was working on my s4 without issue
Attached Files
File Type: txt log.txt - [Click for QR Code] (88.5 KB, 2 views)
24th June 2014, 09:16 PM   |  #5  
tp2215's Avatar
Senior Member
Flag Orlando
Thanks Meter: 2,957
 
1,781 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by TheArtiszan

Thank you for the help,
I tried using your tool and can decompile the file okay now.
But am still running into problems recompiling it.
I have included the errors I am getting in a code block.
I am running Windows 8 and I am not sure if that might be part of the problem or not.
Any help would be appreciated with that.
Just still kinda amazed as this was working on my s4 without issue

it's because you didn't install the framework to pc. depending upon what app you use, it needs to have the framework files from your device or it will be missing dependencies every time you recompile.

Sent from my SM-G900T using Tapatalk
25th June 2014, 01:15 AM   |  #6  
OP Senior Member
Thanks Meter: 96
 
870 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by tp2215

it's because you didn't install the framework to pc. depending upon what app you use, it needs to have the framework files from your device or it will be missing dependencies every time you recompile.

Sent from my SM-G900T using Tapatalk

Okay.
I have updated to the newest version of the tool on his page
Used the check mark for installing propritary frameworks and installed framework-res.apk twframework.apk and SystemUI.apk
and still am running into the same errors even though I have the framework installed.
What might I be doing wrong?
25th June 2014, 01:21 AM   |  #7  
tp2215's Avatar
Senior Member
Flag Orlando
Thanks Meter: 2,957
 
1,781 posts
Join Date:Joined: Oct 2010
Donate to Me
More
Quote:
Originally Posted by TheArtiszan

Okay.
I have updated to the newest version of the tool on his page
Used the check mark for installing propritary frameworks and installed framework-res.apk twframework.apk and SystemUI.apk
and still am running into the same errors even though I have the framework installed.
What might I be doing wrong?

what program are you using?

Sent from my SM-G900T using Tapatalk
24th June 2014, 09:44 PM   |  #8  
OP Senior Member
Thanks Meter: 96
 
870 posts
Join Date:Joined: Jun 2009
How would I go about installing them with this tool?
I already have them copied out of the phone.
25th June 2014, 12:59 AM   |  #9  
OP Senior Member
Thanks Meter: 96
 
870 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by TheArtiszan

How would I go about installing them with this tool?
I already have them copied out of the phone.

I think I was using an older version of the program.
Found an update. Will download that and give it a try then.
I will report back what happens.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes


Top Threads in T-Mobile Galaxy S 5 Q&A, Help & Troubleshooting by ThreadRank