Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,781,420 Members 37,406 Now Online
XDA Developers Android and Mobile Development Forum

[solved] "/system/lib/libcrypto.so" has unexpected contents

Tip us?
 
mattileblanc
Old
(Last edited by mattileblanc; 25th June 2014 at 12:24 AM.)
#1  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Apr 2014
Default [solved] "/system/lib/libcrypto.so" has unexpected contents

Hi,

Trying to install latest OTA and get this message while verifying system:
"/system/lib/libcrypto.so" has unexpected contents

Current system:
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.57.0000
(bootloader) version-baseband: 4T.27.3218.14
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 5.11.1540.9
(bootloader) version-misc: PVT SHIP S-OFF

(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0712000
(bootloader) cidnum: 11111111111
(bootloader) battery-status: good
(bootloader) battery-voltage: 4263mV
(bootloader) partition-layout: Generic
(bootloader) security: off
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-e47fb74b
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

I am s-off and originally bought an ATT M7 but I think I am running a WWE version now
 
alray
Old
#2  
alray's Avatar
Senior Member
Thanks Meter 1,050
Posts: 2,714
Join Date: May 2012
Location: Montreal

 
DONATE TO ME
Quote:
Originally Posted by mattileblanc View Post
Hi,

Trying to install latest OTA and get this message while verifying system:
"/system/lib/libcrypto.so" has unexpected contents

Current system:
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.57.0000
(bootloader) version-baseband: 4T.27.3218.14
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 5.11.1540.9
(bootloader) version-misc: PVT SHIP S-OFF
(bootloader) meid: 00000000000000
(bootloader) product: m7_ul
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0712000
(bootloader) cidnum: 11111111111
(bootloader) battery-status: good
(bootloader) battery-voltage: 4263mV
(bootloader) partition-layout: Generic
(bootloader) security: off
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-e47fb74b
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

I am s-off and originally bought an ATT M7 but I think I am running a WWE version now
5.11.1540.9 is the latest dev edition version.
  1. what is the update number you are trying to install?
  2. when you go in settings --> About -->Software Information, what does it says under ROM version?

is your CID really 11111111111 ? CID is only 8 characters, even super cid, should be (8x1): 11111111 not (11x1): 11111111111

the error from the ota installation mean the file was modified so the update can't patch this file. you have to replace the file with the exact file the ota update is expecting. anyway with s-off you could simply run a ruu and then apply ota updates to latest version.
If I've helped you, please hit the ''tanks'' button
If you want a reply, quote or mention me using @alray

Useful links for the HTC One:
nkk71's SuperGUIDE to returning 100% back to stock
Flashing requirements chart by nkk71
HTC1Guru.com by crushalot
 
mattileblanc
Old
(Last edited by mattileblanc; 24th June 2014 at 05:17 AM.) Reason: additional info
#3  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Apr 2014
Quote:
Originally Posted by alray View Post
5.11.1540.9 is the latest dev edition version.
  1. what is the update number you are trying to install?
  2. when you go in settings --> About -->Software Information, what does it says under ROM version?

is your CID really 11111111111 ? CID is only 8 characters, even super cid, should be (8x1): 11111111 not (11x1): 11111111111

the error from the ota installation mean the file was modified so the update can't patch this file. you have to replace the file with the exact file the ota update is expecting. anyway with s-off you could simply run a ruu and then apply ota updates to latest version.

Hi,

My super CID is 11111111, I just typed the value because it was a dump of today when I went back to original CID (CWS_001).
My current software number is 4.19.1540.9, but I do have the newest firmware (5.11.1540.9).

When you say, simply run a RUU ,where would I find a RUU that will keep my version stock with Play Store working etc and how would I install that.
I have done several ADB and fastboot things, but I am a bit confused which is what etc..

What is a RUU exactly?
And which version should I choose. Looking at site: http://androidruu.com/?developer=M7
I don't know if the last RUU I installed was a european one or a WWE. Not sure how to find out.
 
alray
Old
(Last edited by alray; 24th June 2014 at 05:19 AM.)
#4  
alray's Avatar
Senior Member
Thanks Meter 1,050
Posts: 2,714
Join Date: May 2012
Location: Montreal

 
DONATE TO ME
Quote:
Originally Posted by mattileblanc View Post
Hi,

My super CID is 11111111, I just typed the value because it was a dump of today when I went back to original CID (CWS_001).
My current software number is 4.19.1540.9, but I do have the newest firmware (5.11.1540.9).

When you say, simply run a RUU ,where would I find a RUU that will keep my version stock with Play Store working etc and how would I install that.
I have done several ADB and fastboot things, but I am a bit confused which is what etc..
well you don't really need supercid to run this version, better to use the correct one for .1540 version (BS_US001)

Code:
fastboot oem writecid BS_US001
fastboot reboot-bootloader
then run this file (ruu.exe): http://www.htc1guru.com/dld/ruu_m7_u..._signed_3-exe/

then you'll be able to apply the ota update to 5.11.1540.9

keep bootloader unlocked and s-off

btw the ruu will wipe everything on your phone, so if you have files to backup, do it before running the ruu.

.1540 is the dev edition version.
If I've helped you, please hit the ''tanks'' button
If you want a reply, quote or mention me using @alray

Useful links for the HTC One:
nkk71's SuperGUIDE to returning 100% back to stock
Flashing requirements chart by nkk71
HTC1Guru.com by crushalot
 
mattileblanc
Old
#5  
Junior Member - OP
Thanks Meter 2
Posts: 23
Join Date: Apr 2014
Quote:
Originally Posted by alray View Post
well you don't really need supercid to run this version, better to use the correct one for .1540 version (BS_US001)

Code:
fastboot oem writecid BS_US001
fastboot reboot-bootloader
then run this file (ruu.exe): http://www.htc1guru.com/dld/ruu_m7_u..._signed_3-exe/

then you'll be able to apply the ota update to 5.11.1540.9

keep bootloader unlocked and s-off

btw the ruu will wipe everything on your phone, so if you have file to backup, do it before running the ruu.
Okay, I will give it a try. I reckon I will receive a new OTA message after doing the upgrade, or should I save the downloaded file? Not that I can install it with TWRP I guess?
 
alray
Old
#6  
alray's Avatar
Senior Member
Thanks Meter 1,050
Posts: 2,714
Join Date: May 2012
Location: Montreal

 
DONATE TO ME
Quote:
Originally Posted by mattileblanc View Post
Okay, I will give it a try. I reckon I will receive a new OTA message after doing the upgrade, or should I save the downloaded file? Not that I can install it with TWRP I guess?
Yes you'll get a notification to update to latest version after running the ruu but if you don't want to re-download the ota, make a backup of the ota.zip file on your computer, you'll be able to flash it manually after running the ruu. And no you can't install ota with twrp, only with stock recovery. However the ruu will make everything back to stock (including the recovery).
If I've helped you, please hit the ''tanks'' button
If you want a reply, quote or mention me using @alray

Useful links for the HTC One:
nkk71's SuperGUIDE to returning 100% back to stock
Flashing requirements chart by nkk71
HTC1Guru.com by crushalot
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes