Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,780,552 Members 47,966 Now Online
XDA Developers Android and Mobile Development Forum

Xperia S /lt26i black screen no boot

Tip us?
 
peter43
Old
#1  
Member - OP
Thanks Meter 0
Posts: 35
Join Date: Aug 2009
Default Xperia S /lt26i black screen no boot

I hope you guys can help me revive my xperia S.
I have a strange problem with my phone and can't seem te fix it myself.
I can't boot my phone anymore.
I can get it into flash (green led) and fastboot mode (blue led) and can flash it, but without success.

If I connect my phone to the charger I only get a red led but it doesn't seem to charge.
The phone is recognized in windows and I can lock and unlock my bootloader and see the phone information.
but when I push the power button the only thing that happens is a green led for a second but nothing else.
 
TeChNoMiC
Old
#2  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Location: Saarbruecken
what rom?

i had the same problem, the only way for me was
flash the stock rom and then root.
 
peter43
Old
#3  
Member - OP
Thanks Meter 0
Posts: 35
Join Date: Aug 2009
This is what emma tells me
Xperia S JB 4.1.2 (build 6.2.B.1.96)

I have been searching for a stock rom, but can't find it.
Do you have a link ?
 
Mirhawk
Old
#4  
Mirhawk's Avatar
Senior Member
Thanks Meter 121
Posts: 332
Join Date: Jan 2014
Quote:
Originally Posted by peter43 View Post
This is what emma tells me
Xperia S JB 4.1.2 (build 6.2.B.1.96)

I have been searching for a stock rom, but can't find it.
Do you have a link ?
A Google search makes everything easy. Here You go.
Pressing the is appreciated!
Kitkat - Carbon ROM - abcdjdj
 
TeChNoMiC
Old
#5  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Mar 2014
Location: Saarbruecken
Quote:
Originally Posted by Mirhawk View Post
A Google search makes everything easy. Here You go.
Love Google Search
 
peter43
Old
#6  
Member - OP
Thanks Meter 0
Posts: 35
Join Date: Aug 2009
Thank you, thought that was a custom firmware beceause of the name.

I get the following error when I try to flash it

29/012/2014 22:12:15 - INFO - <- This level is successfully initialized
29/012/2014 22:12:15 - INFO - Flashtool Version 0.9.10.1 built on 2013-01-09 19:49:47
29/012/2014 22:12:15 - INFO - You can drag and drop ftf files here to start flashing them
29/012/2014 22:12:21 - INFO - Device connected in flash mode
29/012/2014 22:12:22 - INFO - Selected LT26i_1252-0023_6.2.B.1.96_GENERIC-user_CUST_1257-6921_R3H.ftf
29/012/2014 22:12:22 - INFO - Preparing files for flashing
29/012/2014 22:12:41 - INFO - Please connect your device into flashmode.
29/012/2014 22:12:42 - INFO - Opening device for R/W
29/012/2014 22:12:43 - INFO - Reading device information
29/012/2014 22:12:58 - INFO - Unable to read from phone after having opened it.
29/012/2014 22:12:58 - INFO - trying to continue anyway
29/012/2014 22:12:58 - INFO - Start Flashing
29/012/2014 22:12:58 - INFO - Processing loader
29/012/2014 22:12:58 - INFO - Checking header
29/012/2014 22:12:58 - INFO - Ending flash session
29/012/2014 22:12:58 - ERROR - Error in processHeader : 2
29/012/2014 22:12:58 - ERROR - Error flashing. Aborted
29/012/2014 22:12:58 - INFO - Device disconnected
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes