Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Wifi Button Slides to "On" but Quickly Returns

OP Ocsirf

29th June 2014, 03:26 AM   |  #1  
Ocsirf's Avatar
OP Junior Member
Flag Yep, where I live.
Thanks Meter: 0
 
20 posts
Join Date:Joined: Jun 2010
More
Galaxy Tab 2 7.0 Verizon SCH-i1705 Android Version 4.1.2 Jelly Bean
Kernel 3.0.31-1415457se.infra@SEP-75 #1 SMP PREEMPT Sat Sep 21
21:26:19 KST 2013 Build Number JZ054K.I705VRBLL2

Recently taken off contract with Verizon to go to wifi only. Worked
fine with no SIM card in (other than the "no sim card detected" nag
at boot up).

Then, I rooted it using the Jelly Bean ROM that matched the version
number so I could just customize at will, etc.

Odin 3.09 went perfectly and it fired right up. But then I tried to
hook up with my home wifi network, which is working well with my
other tabs and phones, laptops and jetpack. The wifi slide buttons
snap right back to the left, will not remain in "on," and thus the device
will not even scan for the list of available networks.

Tried toggling airplane mode. Tried unrooting and factory reset. Tried
all the cache wipes (dalvik, etc and via recovery). Tried re-flashing the
same ROM.

Kind of lost. Is it an incompatibility with the kernel? If so, I'm also
wondering about a second issue (that I may have to post in a root forum
around here) wherein I cannot flash ROMs! Nothing works in Odin with
the notable exception of the very same ROM I flashed to root.

Any thoughts about this? I'm pretty good at trouble shooting.. just not
so sure what came about to make this happen.

Help is appreciated, to say the least.

- O
Last edited by Ocsirf; 29th June 2014 at 03:28 AM. Reason: Spelling, typos
29th June 2014, 02:07 PM   |  #2  
Joery360's Avatar
Senior Member
Flag Netherlands
Thanks Meter: 549
 
693 posts
Join Date:Joined: Aug 2012
Donate to Me
More
Quote:
Originally Posted by Ocsirf

Galaxy Tab 2 7.0 Verizon SCH-i1705 Android Version 4.1.2 Jelly Bean
Kernel 3.0.31-1415457se.infra@SEP-75 #1 SMP PREEMPT Sat Sep 21
21:26:19 KST 2013 Build Number JZ054K.I705VRBLL2...

It seems that your wifi drivers doesn't work properly/broken.
Simple solution; reflash the firmware.
29th June 2014, 04:58 PM   |  #3  
Ocsirf's Avatar
OP Junior Member
Flag Yep, where I live.
Thanks Meter: 0
 
20 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by Joery360

It seems that your wifi drivers doesn't work properly/broken.
Simple solution; reflash the firmware.

Thanks for the reply, Joery360.

Yeah, I did that a couple of times. This is what's so puzzling. That ROM is the only
one that I can get into the tab (via Odin at least), and that ROM disables wifi it seems.

That's my other question: why the heck does any other ROM yield "fail" in Odin,
whether stock or custom.

Everything works fine and the device will even go into airplane mode. But wifi and
bluetooth won't turn on.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes