Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,893 Members 42,525 Now Online
XDA Developers Android and Mobile Development Forum

Wifi Button Slides to "On" but Quickly Returns

Tip us?
 
Ocsirf
Old
(Last edited by Ocsirf; 29th June 2014 at 02:28 AM.) Reason: Spelling, typos
#1  
Ocsirf's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 20
Join Date: Jun 2010
Location: Yep, where I live.
Default Wifi Button Slides to "On" but Quickly Returns

Galaxy Tab 2 7.0 Verizon SCH-i1705 Android Version 4.1.2 Jelly Bean
Kernel 3.0.31-1415457se.infra@SEP-75 #1 SMP PREEMPT Sat Sep 21
21:26:19 KST 2013 Build Number JZ054K.I705VRBLL2

Recently taken off contract with Verizon to go to wifi only. Worked
fine with no SIM card in (other than the "no sim card detected" nag
at boot up).

Then, I rooted it using the Jelly Bean ROM that matched the version
number so I could just customize at will, etc.

Odin 3.09 went perfectly and it fired right up. But then I tried to
hook up with my home wifi network, which is working well with my
other tabs and phones, laptops and jetpack. The wifi slide buttons
snap right back to the left, will not remain in "on," and thus the device
will not even scan for the list of available networks.

Tried toggling airplane mode. Tried unrooting and factory reset. Tried
all the cache wipes (dalvik, etc and via recovery). Tried re-flashing the
same ROM.

Kind of lost. Is it an incompatibility with the kernel? If so, I'm also
wondering about a second issue (that I may have to post in a root forum
around here) wherein I cannot flash ROMs! Nothing works in Odin with
the notable exception of the very same ROM I flashed to root.

Any thoughts about this? I'm pretty good at trouble shooting.. just not
so sure what came about to make this happen.

Help is appreciated, to say the least.

- O
 
Joery360
Old
#2  
Joery360's Avatar
Senior Member
Thanks Meter 456
Posts: 600
Join Date: Aug 2012
Location: Netherlands

 
DONATE TO ME
Quote:
Originally Posted by Ocsirf View Post
Galaxy Tab 2 7.0 Verizon SCH-i1705 Android Version 4.1.2 Jelly Bean
Kernel 3.0.31-1415457se.infra@SEP-75 #1 SMP PREEMPT Sat Sep 21
21:26:19 KST 2013 Build Number JZ054K.I705VRBLL2...
It seems that your wifi drivers doesn't work properly/broken.
Simple solution; reflash the firmware.
 
Ocsirf
Old
#3  
Ocsirf's Avatar
Junior Member - OP
Thanks Meter 0
Posts: 20
Join Date: Jun 2010
Location: Yep, where I live.
Quote:
Originally Posted by Joery360 View Post
It seems that your wifi drivers doesn't work properly/broken.
Simple solution; reflash the firmware.
Thanks for the reply, Joery360.

Yeah, I did that a couple of times. This is what's so puzzling. That ROM is the only
one that I can get into the tab (via Odin at least), and that ROM disables wifi it seems.

That's my other question: why the heck does any other ROM yield "fail" in Odin,
whether stock or custom.

Everything works fine and the device will even go into airplane mode. But wifi and
bluetooth won't turn on.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes