Post Reply

[ROM] insanity CM 057 [21.12.2011] - Multi DPI

OP nitr8

5th January 2011, 01:32 PM   |  #2121  
nitr8's Avatar
OP Retired Recognized Developer
Flag Switzerland
Thanks Meter: 2,240
 
1,657 posts
Join Date:Joined: Sep 2006
Donate to Me
More
Battery Questions
Advice and troubleshooting battery issues. Any contributions welcome, please see links in "Other Resorcess" for detailed information.

Disable HSDPA
In the phone dialer enter code: *#301279#
Click [2] CHANGE HSPA REVISION
Click [1] HSPA OFF
Battery Calibration
Remember, always flash with a full battery.
USE phone heavily. Use it till the system turns OFF automatically
Turn OFF phone
Charge till it says it is FULL
Start phone in RECOVERY Mode
Select Advanced CWM Features
Select Wipe Battery Stats
RESTART phone
Other Modem
The JPD modem has been reported to give better battery life.
Gallery Issues
Thumbnails and some database's could get corrupted making the media scanner running berserk, resulting in battery drain.
Delete the following:
dbdata/databases/com.android.providers.media
dbdata/databases/com.cooliris.media
And clear the thumbnails folders on sd cards.
I have created a CWM script to do this for you - Gallery Cleaner

Bump Charging
One technique that has gained popularity in the user community is "bump charging." To bump charge a device do the following:
Turn it off completely
Plug it into a charger.
Wait until the green battery sign says 100% . DO NOT turn the device back on.
Disconnect and immediately reconnect the power cord. (The device will now accept more charge before saying it is full.)
50% Battery without Signal
Well Known Froyo bug that started from the very first firmware release shows phone as 50% time without signal on cell standby when you check in Settings > About phone > Battery use

Apparently this can occur anytime after unplugging your phone from charge so I always do 2 things to fix this and so do many other users.
Turning Flight mode off and on.
In the phone dialer enter code: *#*#4636#*#* > Scroll down a bit >
Select Phone Info
Select "Turn off radio"
Select "Turn on radio"
Exit
Other Resources
Everything You Need To Know About Bump Charging And Inconsistent Battery Drain
How to disable HSPA / HSDPA for better battery life - hardcore
Modem Information - pele78
YABD - Yet Another Battery Drain thread - bokbacken
Alternative Modems
Last edited by nitr8; 5th January 2011 at 09:48 PM.
The Following 2 Users Say Thank You to nitr8 For This Useful Post: [ View ]
5th January 2011, 02:27 PM   |  #2122  
nitr8's Avatar
OP Retired Recognized Developer
Flag Switzerland
Thanks Meter: 2,240
 
1,657 posts
Join Date:Joined: Sep 2006
Donate to Me
More
Quote:
Originally Posted by manageri21

Nitr8 i try the theme generation X, is pretty but i find some problem to install app, (don't install nothing) turn back to stock insanity theme and everything ok

could you expand on this a bit more please?
5th January 2011, 02:40 PM   |  #2123  
Member
Thanks Meter: 16
 
99 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by nitr8

Advice and troubleshooting battery issues. Any contributions welcome, please see links in "Other Resorcess" for detailed information.

I'm sure you are aware of it but there is a thread that discusses the battery drain problem: http://forum.xda-developers.com/showthread.php?t=884816
5th January 2011, 02:46 PM   |  #2124  
nitr8's Avatar
OP Retired Recognized Developer
Flag Switzerland
Thanks Meter: 2,240
 
1,657 posts
Join Date:Joined: Sep 2006
Donate to Me
More
Quote:
Originally Posted by legend_wok

I'm sure you are aware of it but there is a thread that discusses the battery drain problem: http://forum.xda-developers.com/showthread.php?t=884816

Thanks, added that link
5th January 2011, 03:06 PM   |  #2125  
Senior Member
Thanks Meter: 18
 
205 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by nitr8

could you expand on this a bit more please?

download from romManager the theme generation X and install it from CWM, now when i go to market to install something, don't start to download.
and when i click app apk directly from sd start to install but never finish installing.
5th January 2011, 03:16 PM   |  #2126  
Senior Member
Flag Toledo
Thanks Meter: 3
 
141 posts
Join Date:Joined: Aug 2009
More
With 0.3.1 I downloaded and applied Generation X theme through ROM Manager, using ADW EX I got everything Force Closes.

Had to install from scratch and use yesterday's backup so not a big problem. Just advice to make a backup even when applying themes (which I didn't this time because I couldn't imagine how bad was it going to be )
5th January 2011, 03:26 PM   |  #2127  
TrOjAnUK's Avatar
Senior Member
Flag Essex
Thanks Meter: 638
 
1,903 posts
Join Date:Joined: Sep 2009
Donate to Me
More
ANNOUNCEMENT: Bug Fix
Not sure how many if any at all have noticed this but its been driving me nuts.. anyway, in the NEXT release this WILL be fixed!!

If you remove the Email.apk file then apps like Barcode Scanner Force Close, this ment that you had to restore Email.apk or stop using the Barcode Scanner app.

nitr8 has found a fix for the libcamera.so file which allows the removal of Email.apk but still letting Barcode scanner work..

Aint he kleva!

TrOjAn
The Following User Says Thank You to TrOjAnUK For This Useful Post: [ View ]
5th January 2011, 04:17 PM   |  #2128  
aladin6's Avatar
Senior Member
Thanks Meter: 109
 
1,462 posts
Join Date:Joined: Mar 2009
Quote:
Originally Posted by TrOjAnUK

Not sure how many if any at all have noticed this but its been driving me nuts.. anyway, in the NEXT release this WILL be fixed!!

If you remove the Email.apk file then apps like Barcode Scanner Force Close, this ment that you had to restore Email.apk or stop using the Barcode Scanner app.

nitr8 has found a fix for the libcamera.so file which allows the removal of Email.apk but still letting Barcode scanner work..

Aint he kleva!

TrOjAn

Strange! i removed the email.apk and barcode scanner is still working !!!
5th January 2011, 04:39 PM   |  #2129  
uppon2's Avatar
Recognized Contributor
Thanks Meter: 1,202
 
2,625 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by nitr8

Advice and troubleshooting battery issues. Any contributions welcome, please see links in "Other Resorcess" for detailed information.

Disable HSDPA

In the phone dialer enter code: *#301279#
Click [2] CHANGE HSPA REVISION
Click [1] HSPA OFF
Battery Calibration
USE phone heavily. Use it till the system turns OFF automatically
Turn OFF phone
Charge till it says it is FULL
Start phone in RECOVERY Mode
Select Advanced CWM Features
Select Wipe Battery Stats
RESTART phone
Other Modem
The JPD modem has been reported to give better battery life.
Gallery Issues
If you a Flash Addict there is a chance that the thumbnails may become corrupt, due to frequent flashing adn contribute to heavy battery drain.

Delete the following:
dbdata/databases/com.android.providers.media
dbdata/databases/com.cooliris.media
And clear the thumbnails folders on sd cards.
I have created a CWM script to do this for you - Gallery Cleaner

Other Resources
Everything You Need To Know About Bump Charging And Inconsistent Battery Drain
How to disable HSPA / HSDPA for better battery life - hardcore
Modem Information - pele78
YABD - Yet Another Battery Drain thread - bokbacken
Alternative Modem

Nitr8 please add this to the list:

Well Known Froyo bug that started from the very first firmware release shows phone as 50% time without signal on cell standby when you check in Settings > About phone > Battery use

Apparently this can occur anytime after unplugging your phone from charge so I always do 2 things to fix this and so do many other users.

1. Turning Flight mode off and on.
2. Turn the radio off and on by putting this code into your dialer *#*#4636#*#* > Phone info > Scroll down a bit > Turn radio off and on.

For 100% Assurance I always do this after charging my phone to avoid the bug
5th January 2011, 04:40 PM   |  #2130  
Member
Thanks Meter: 95
 
41 posts
Join Date:Joined: Oct 2010
Great work on the rom, guys!
Only I have an issue where my OC settings get messed up at boot, when using xan's voltage app.
It boot's at 100mhz everytime. Also, when I set the boot settings in voltage app, the S_volt_scheduler file updates correctly, but when I reboot the values within that file change, disabling every state, causing it to run at such a minimal speed.
None of this occurs with stock JPY+ SOK 6.1 so I'm guessing it's an issue with your ROM.
Thanks in advance!
Last edited by el afortunado; 5th January 2011 at 05:39 PM. Reason: forgot to mention kernel

Post Reply Subscribe to Thread

Tags
insanity, nitr8, read post 1, read post 2, read post 3
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy S I9000 Android Development by ThreadRank