Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,562 Members 53,641 Now Online
XDA Developers Android and Mobile Development Forum

The HTC Guide: Hermes - (04-07-08)

Tip us?
 
mrvanx
Old
#21  
mrvanx's Avatar
Retired Moderator - OP
Thanks Meter 22
Posts: 2,834
Join Date: Aug 2006
Location: York
Quote:
Originally Posted by gregouille View Post
Hi
I'm quite a noob, so I apologize if i ask for something already mentionned.
I'm on SPL1.09 after install of LVSW 03/20.

I want to install HardSPL v4.
- This means only the bootloader files of the rom will be modified. Am I right ?

I need to check the yellow line.
But do I need to check "Is it hardSPL" ? What is this for ?

Then, as I understand, if i install a new ROM with radio, it'll modify the SPL again ?

Thanx

Greg
Install HardSPLv4 as in the guide, only your SPL will change. For more info read the HardSPL thread But i definatly recommend flashing HardSPLv4 because SPL 1.09 is a brick-maker (from recent events).
 
mrvanx
Old
#22  
mrvanx's Avatar
Retired Moderator - OP
Thanks Meter 22
Posts: 2,834
Join Date: Aug 2006
Location: York
guide updated for LVSW
 
Lowglide
Old
#23  
Junior Member
Thanks Meter 0
Posts: 12
Join Date: Jan 2007
This was a lot of help. I have read the Wiki and the forums and the sheer amount of information that keeps changing so fast makes it rather confusing. But you manged to pull the up-to-date stuff together in one place and make it a easy and linear process. Thank you very much!

I followd all your steps and all portions of my 8525 are now updated. I had previously just done some patches and the OS upgrade which had left me fighting some bugs. Now it seems a lot smoother.

Thanks again for your hard work, and of course the work of the people that make the made the programs that went into it.
Lowglide
 
Murcielago
Old
(Last edited by Murcielago; 27th March 2007 at 08:36 AM.)
#24  
Murcielago's Avatar
Senior Member
Thanks Meter 15
Posts: 284
Join Date: Dec 2003
Location: Mougins
I have some basic questions :
- I actually have LVSW 03/13 version install (20070313_HermesWM6_LVSW_edition_WM6Style.exe)
- I have upgraded to HardSPL 1.30 yesterday (no problem).
- I would like to install LVSW version 03/26 so I have downloaded the 20070326_RUU_Hermes_WWE_3.23.0.2_only_OS.exe file
- When I execute it, it asks me to specify which SPL version I have.

In your guide, you say that I have to use Force Using SSPL....
1) Why shouldn't I select SPL 1.11/1.13/1.30 New Bootloader instead ?
2) If I select this one, does it mean that it's reinstall SPL 1.30 on my Hermes ?
3) What's the difference between selecting Force Using SSPL and SPL 1.11/1.13/1.30 ???

Thanks in advance and I'm sorry if these questions are basic.
Samsung Galaxy SIII - GT-I9305 - XXALK5

 
d1archie
Old
#25  
Member
Thanks Meter 2
Posts: 48
Join Date: Jan 2007
Excellent guide. Thanks for compiling, mr vanx. I'm sure this will be very helpful to a lot of people. Keep up the good work. As a feel good factor, which I'm sure you are already aware of, I know that this guide has helped to avoid many a bricked device.

Thanks again, and keep up the excellent work.
 
Wessel.Dk
Old
#26  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: Mar 2007
Location: Nysted
Sorry, but what is HardSPL and how will i know which version i have? Using a HTC TyTN Hermes 200
 
Murcielago
Old
#27  
Murcielago's Avatar
Senior Member
Thanks Meter 15
Posts: 284
Join Date: Dec 2003
Location: Mougins
Quote:
Originally Posted by Wessel.Dk View Post
Sorry, but what is HardSPL and how will i know which version i have? Using a HTC TyTN Hermes 200
This is explained in the Guide......

Quote:
The first stage of this process is to determine which SPL(bootloader) you have on your device. To do this press and hold both the side OK button and the power button and then press the reset button by putting the stylus into the hole in the bottom of the device. Your device will enter the bootloader and display which IPL and SPL versions are on the device. Make a note of the SPL version on the device, we will use this in a minute.
Samsung Galaxy SIII - GT-I9305 - XXALK5

 
mrvanx
Old
#28  
mrvanx's Avatar
Retired Moderator - OP
Thanks Meter 22
Posts: 2,834
Join Date: Aug 2006
Location: York
notice the line that reads:
Quote:
This stage is crucial to allow (fairly) safe flashing of new roms/radios etc...
This modified bootloader allows the flashing of any ROM to the device (regardless of the CID) and can help to prevent damage to the device if a failed radio flash occurs (since it doesn't read the CID a corrupt one will not present a problem).
Kinda the gist of it, but it also protects against bad NAND blocks in the device now.

For people with older versions of HardSPL (1.10.oli, 1.11.oli, 1.13.oli) get a ROM that has HardSPLv4 and flash it forcing SSPL (we want the new SPL version). If you already have HardSPLv4 (1.30.olipro) you can check the green option and tick the box below it. But forcing SSPL will be ok aswell if it is OS only in the ROM.

Il change my guide slightly, just makes it complicated for newbs to understand?!
 
marisa4755
Old
#29  
Senior Member
Thanks Meter 0
Posts: 307
Join Date: Oct 2005
Newb alert!

Should sim card and sd card be left in the device or taken out. I have searched, but not found an answer to this.

thank you.
Marisa

HTC Diamond
O2 UK
 
mrvanx
Old
#30  
mrvanx's Avatar
Retired Moderator - OP
Thanks Meter 22
Posts: 2,834
Join Date: Aug 2006
Location: York
Leave them in you can remove the SD card if you like.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes