Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,535 Members 39,997 Now Online
XDA Developers Android and Mobile Development Forum

Got Ad-hoc wifi working on my Xoom! (binaries inside)

Tip us?
 
kelvie
Old
(Last edited by kelvie; 13th April 2011 at 06:47 PM.) Reason: Fixed chmod line
#1  
Member - OP
Thanks Meter 44
Posts: 38
Join Date: Apr 2011
Location: Vancouver, BC
Default Got Ad-hoc wifi working on my Xoom! (binaries inside)

I've managed to build a version of wpa_supplicant that has ad-hoc enabled, by forward porting the patch in this thread:

http://forum.xda-developers.com/showthread.php?t=754961

After building and a couple of tests, it works.

To install, you need a rooted Xoom, of course, and just push the file to system/bin/wpa_supplicant.

Because zipfiles don't store permission, you have to make it executable as well.

Code:
Select Code
adb remount
adb push system/bin/wpa_supplicant /system/bin/wpa_supplicant
adb shell chmod 755 /system/bin/wpa_supplicant
I also had to change the permissions on /data/misc/wifi/wpa_supplicant.conf for some reason:
Code:
Select Code
adb shell chown system.wifi /data/misc/wifi/wpa_supplicant.conf
Then reboot, and try it!

It works with my Nokia N8 with JoikuSpot; I can't tether it any other way as the N8 doesn't support the PAN Bluetooth profile, and Android doesn't support DUN.

Don't forget to backup your files, and I am not liable, etc, etc.

The code I used is here:
https://github.com/kelvie/android-wpa_supplicant
Attached Files
File Type: zip wpa_supplicant_xoom_wifi_adhoc.zip - [Click for QR Code] (161.1 KB, 13307 views)
The Following 25 Users Say Thank You to kelvie For This Useful Post: [ Click to Expand ]
 
SaintFarris`
Old
#2  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Apr 2011
Ok heres what happened to me..

I was able to push the first file and when I input the adb shell code it said the device was not connected I am rooted and had no problems rooting or access shell before

So I got a little cocky and thought that the port 5037 that adb communicates with was blocked so I typed adb tcpip 5036 to see if I could get shell access on that port well now when I type adb remount it immediately tells me error: device not found....help!

Got myself stuck without wifi (error)
 
Ehsan Mahmood
Old
#3  
Ehsan Mahmood's Avatar
Senior Member
Thanks Meter 12
Posts: 100
Join Date: Feb 2011
Location: Islamabad

 
DONATE TO ME
Thanks for developing such a great app. If i m not wrong i think its working with all 3G carriers.

You can also turn your Motorola Xoom tablets to WiFi hotspot without rooting by enabling setting which are given here http://goo.gl/mgwdn
Standout from Crowd with Mobile App Marketing Services, we provide App Promo Video Services, App Demo Video Services and App Store Optimization Services.
 
SaintFarris`
Old
#4  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Apr 2011
Also my xoom has been in debug mode and now all of a sudden I noticed that its not entering debug mode when connected there used to a little icon come up and not anymore it acts like nothing yet i can access it on my computer by going my computer and I see Xoom
 
SaintFarris`
Old
#5  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Apr 2011
Ok I got debugging mode back and xoom is plugged in now my problem is when the daemon server starts in adb shell it starts on port 5038

So when I try to copy "adb shell chmod +x /system/bin/wpa_supplicant" it still says device not found and thats if I copy and paste it exactly if I type adb shell it gives me the # Symbol then i put it "chmod +x /system/bin/wpa_supplicant" and it says bad mode

One good thing is I can now type /remount again so what I am doing wrong still stuck without wifi ;\
 
SaintFarris`
Old
#6  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Apr 2011
Ok I've tried everything except reflash my devices I've literally only been able to do step 1 which leaves me with no wifi because i cannot execute the shell commands so please a little help it's been a long night messing with this appreciate your time and I'd love to get this working!
 
Fusius
Old
#7  
Fusius's Avatar
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Mar 2007
Location: Washington, DC
Quote:
Originally Posted by kelvie View Post
I've managed to build a version of wpa_supplicant that has ad-hoc enabled, by forward porting the patch in this thread:

http://forum.xda-developers.com/showthread.php?t=754961

After building and a couple of tests, it works.

To install, you need a rooted Xoom, of course, and just push the file to system/bin/wpa_supplicant.

Because zipfiles don't store permission, you have to make it executable as well.

Code:
Select Code
adb remount
adb push system/bin/wpa_supplicant /system/bin/wpa_supplicant
adb shell chmod +x /system/bin/wpa_supplicant
I also had to change the permissions on /data/misc/wifi/wpa_supplicant.conf for some reason:
Code:
Select Code
adb shell chown system.wifi /data/misc/wifi/wpa_supplicant.conf
Then reboot, and try it!

It works with my Nokia N8 with JoikuSpot; I can't tether it any other way as the N8 doesn't support the PAN Bluetooth profile, and Android doesn't support DUN.

Don't forget to backup your files, and I am not liable, etc, etc.

The code I used is here:
https://github.com/kelvie/android-wpa_supplicant


Ok...I tried this and got the same "bad mode" error at the
"adb shell chmod +x /system/bin/wpa_supplicant" stage.

So, I instead did "adb shell chmod 700 /system/bin/wpa_supplicant" and that was successful, so I finished the steps listed and can see my cell on my Xoom. I have a Windows Mobile 6.5 cell and my Xoom can NOW see my ad-hoc network. Thanks a lot Kelvie.
HTC HD2
Radio: 2.15.50.14
ROM Version: 04.Jul.2011 WWE
ROM Date: 02/11/2011

Motorola Xoom
Version: 4.1.1 (Jelly Bean)
Rooted

Samsung Galaxy Note 3
Android 4.3 (Stock)
Rooted
 
PengLord
Old
#8  
Senior Member
Thanks Meter 25
Posts: 130
Join Date: Oct 2007
If not for the SDCard update from BRD, I think this thread would be getting alot more attention.

Not to be too mistrusting, but I am hesitant about loading this on my Xoom when it is posted by a new user with only one post.
 
SaintFarris`
Old
#9  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Apr 2011
Quote:
Originally Posted by Fusius View Post
Ok...I tried this and got the same "bad mode" error at the
"adb shell chmod +x /system/bin/wpa_supplicant" stage.

So, I instead did "adb shell chmod 700 /system/bin/wpa_supplicant" and that was successful, so I finished the steps listed and can see my cell on my Xoom. I have a Windows Mobile 6.5 cell and my Xoom can NOW see my ad-hoc network. Thanks a lot Kelvie.
Hey that worked instantly love you!
 
kelvie
Old
#10  
Member - OP
Thanks Meter 44
Posts: 38
Join Date: Apr 2011
Location: Vancouver, BC
Quote:
Originally Posted by PengLord View Post
If not for the SDCard update from BRD, I think this thread would be getting alot more attention.

Not to be too mistrusting, but I am hesitant about loading this on my Xoom when it is posted by a new user with only one post.
I completely understand where you're coming from; but check my github repo, and google for me, I do leave a small internet trail...

I (mostly used to, don't do much anymore but answer the odd email) maintain an open source project (Basket for KDE), and try to participate in open source communities as much as I can.

I just did this to tether my Xoom Wifi to my phone, as I had no other way to get internet on the go.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes