Google Invites Selected Devs to Buy Project Tango Development Kit

Just about a month ago, the curious Project Tango development kit was … more

Micromax Yureka: Indian Handset with CyanogenMod

Thesoap opera involving Cyanogen Inc., OnePlus, and Micromax is one of the most talked about … more

Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Flash player kinda sucks ? Hell yeah!

OP alinescoo

15th April 2011, 07:56 AM   |  #1  
OP Senior Member
Thanks Meter: 62
 
586 posts
Join Date:Joined: Mar 2008
More
All this hype around Android made me buy a SGS. Having flash on the browser was one big reason for acquisition. Soon I discovered that flash isn't what is promised, a desktop experience on my mobile device. I say this because most of the time (like 95%) the flash works so bad in my browser, that is barely usable. When trying to watch streams, mostly on news sites I get a message with "The video is not optimized for mobile" and the playback is choppy, sometimes when seeking, takes 10-15 seconds until the choppy playback starts again. If I try to watch something in low quality it works fine, but most of the sites offer good quality video. I expect more from a 1Ghz cpu...
Is this a problem of my device or is it general ? I have the latest Adobe Flash available on the market.
Last edited by alinescoo; 15th April 2011 at 08:09 AM.
15th April 2011, 08:41 AM   |  #2  
rschenck's Avatar
Senior Member
Thanks Meter: 2,006
 
3,846 posts
Join Date:Joined: Feb 2011
More
What firmware and kernel are you using?

Sent from my GT-I9000 using XDA Premium App
15th April 2011, 09:19 AM   |  #3  
Senior Member
Flag Ballyhalbert
Thanks Meter: 23
 
261 posts
Join Date:Joined: Aug 2010
More
Do some research... if you are using the Default browser, open it and in the address bar type:

about:debug

and hit go...

Now go into your browser settings and at the bottom there should be an option to set the UA String, select Desktop....

Downside:
some sites will still see your device as mobile.
you have to re do the fix Every time you load the browser...

Alternative:
try Dolphin HD broswer, it has a US string setting in the options already and only needs set once.

Downside:
Is a little slower to load pages than the default browser.
some sites will still see your device as mobile.

An another point, if you are using 3g... don't expect miracles!
15th April 2011, 09:40 AM   |  #4  
Member
Thanks Meter: 4
 
40 posts
Join Date:Joined: Aug 2010
sadly he's right ;( its not even working properly over wifi so i cant really say the net is the problem.

id say the problem lies in flash itself and/or its something in the memory management since ive seen stock roms delivering way better flashperformance than any custom so far, so possibility is that the stream freezes and has to rebuffer every time the memmngt cuts the memory, else you could just try to flash ubuntu and see if it works any magic ;P what do it know for all its worth it could be tha b0mb

good luck anyways !
15th April 2011, 10:12 AM   |  #5  
Toss3's Avatar
Senior Member
Flag Helsinki
Thanks Meter: 475
 
1,631 posts
Join Date:Joined: May 2008
More
Quote:
Originally Posted by alinescoo

All this hype around Android made me buy a SGS. Having flash on the browser was one big reason for acquisition. Soon I discovered that flash isn't what is promised, a desktop experience on my mobile device. I say this because most of the time (like 95%) the flash works so bad in my browser, that is barely usable. When trying to watch streams, mostly on news sites I get a message with "The video is not optimized for mobile" and the playback is choppy, sometimes when seeking, takes 10-15 seconds until the choppy playback starts again. If I try to watch something in low quality it works fine, but most of the sites offer good quality video. I expect more from a 1Ghz cpu...
Is this a problem of my device or is it general ? I have the latest Adobe Flash available on the market.


Solution: Flash a custom JVK Gingerbread rom and DO NOT install the flash player from the market, but use the one that comes preinstalled! This way you'll have 720p flash videos playing smoothly.
15th April 2011, 10:26 AM   |  #6  
Raulinho7's Avatar
Senior Member
Thanks Meter: 311
 
495 posts
Join Date:Joined: Feb 2011
More
Quote:
Originally Posted by alinescoo

I get a message with "The video is not optimized for mobile" .

I guess its rather a problem with some websites.
I never had problem with Flash player 10.1 or 10.2 (i am MIUI rom but i had previously JVK)
15th April 2011, 10:43 AM   |  #7  
Senior Member
Thanks Meter: 4,428
 
23,044 posts
Join Date:Joined: Oct 2010
No problem with my SGS but i dont use flash that often so it could be as said some sites .
Use Dolphin HD browser mostly .

The video is not optimized for mobile" >> could that be the clue ???


jje
15th April 2011, 12:21 PM   |  #8  
OP Senior Member
Thanks Meter: 62
 
586 posts
Join Date:Joined: Mar 2008
More
I have stock JS4 ROM, sorry forgot to mention this in the main thread. Also I am using flash only via Wifi. Actually I am using Opera Mobile and I've set the UA to Firefox Desktop one. Gonna try the idea with stock browser, maybe Opera has messed up something.

Post Reply Subscribe to Thread

Tags
flash, optimised, sgs
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes