Regain Double Tap to Wake Functionality on the Nexus 6

A few months ago, Google announced its newest flagship device, the Nexus 6, alongside … more

Clean Your Recent Apps – XDA Xposed Tuesday

In this day and age, you have quite a few apps installed and running on your Android … more

Android Studio Reaches Release Candidate Status

Android app developers have a few options when comes to Android IDEs. One of the most … more

Connect ALL THE THINGS with Xender

Smartphones, with all of their all connectivity options courtesy of OEMs, can easily connect themselves … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Serious Facebook authentication issues

OP PhishShticks

29th April 2011, 12:29 AM   |  #1  
PhishShticks's Avatar
OP Junior Member
Flag Lyndhurst, NJ
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Hey guys, just got my G2x a few days ago and I love it, but Facebook has been giving me some serious problems with authentication.

Upon initial launch of the app, it asks for my credentials, which I supply, but then almost immediately a gray popup dialog looks like this:

Code:
/!\ Facebook sign-in

Please re-enter your Facebook password.

Username
(my email)

Password
(password entry field)

[ Sign in ] [ Logout ]
(Sorry, I don't have a screen capture app installed, but I doubt I'm the only one having an issue.)

I enter my password and I get a message saying "Facebook authentication succeeded". But then almost immediately after the message disappears, I'm prompted to re-enter my password again into the same popup dialogue.

Suggestions? Solutions? Any help would be greatly appreciated!

Edit: Also shows a very quick popup dialogue about "Session does not match the current stored session."
Last edited by PhishShticks; 29th April 2011 at 12:43 AM. Reason: More info
29th April 2011, 12:41 AM   |  #2  
kangxi's Avatar
Senior Member
Flag Orlando
Thanks Meter: 165
 
1,115 posts
Join Date:Joined: Jun 2010
Donate to Me
More
My Facebook works perfectly. Maybe try reinstalling it or doing a hard reset. Are you trying to connect some kind of weird way?

Btw, holding home and pressing power takes a screenshot.

Sent from my LG-P999 using XDA App
29th April 2011, 12:45 AM   |  #3  
momentarylapseofreason's Avatar
Senior Member
Flag Chicago
Thanks Meter: 17
 
1,064 posts
Join Date:Joined: Apr 2007
More
Have you updated Facebook's app? The one that came on this phone did have some bugs. I have had zero issues though.
29th April 2011, 01:33 AM   |  #4  
PhishShticks's Avatar
OP Junior Member
Flag Lyndhurst, NJ
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2010
Donate to Me
More
See, the weirdest thing is that my device did not have Facebook preloaded on it. I had to download from the Market. It's up-to-date too. Version 1.5.4

I like on how the G2X is a pure Google phone (besides a few preinstalled T-Mobile apps) but I'm really lost about the Facebook issue.
29th April 2011, 01:38 AM   |  #5  
Senior Member
Flag Savannah
Thanks Meter: 19
 
182 posts
Join Date:Joined: Dec 2010
More
Mine also did not have Facebook or Twitter preloaded

Sent from my T-Mobile G2x using XDA App
29th April 2011, 01:39 AM   |  #6  
dougstoner's Avatar
Senior Member
Flag Atlanta
Thanks Meter: 55
 
870 posts
Join Date:Joined: Apr 2008
More
You could try to uninstall and reinstall the app.

Sent from my LG-P999 using XDA App
29th April 2011, 01:44 AM   |  #7  
PhishShticks's Avatar
OP Junior Member
Flag Lyndhurst, NJ
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Excellent suggestions guys, but I tried it already. Should I unroot and try a hard reset?
29th April 2011, 09:05 AM   |  #8  
PhishShticks's Avatar
OP Junior Member
Flag Lyndhurst, NJ
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Oh man. It's getting a bit out of hand. I was able to take screens and I'll try to upload them ASAP. The only option is to remain signed out of the app.

Major bummer...
30th April 2011, 02:58 AM   |  #9  
PhishShticks's Avatar
OP Junior Member
Flag Lyndhurst, NJ
Thanks Meter: 0
 
23 posts
Join Date:Joined: Jun 2010
Donate to Me
More
Excellent news guys. I solved my own issue. It seems like the mobile app doesn't play nice with HTTPS (secure browsing) if you have it enabled on the Facebook website. After disabling HTTPS on the full Facebook website under Account Settings, I was able to log in and stay logged in without an issue.

Hazzah! I even called T-Mobile to get help and wound up solving the issue while being on the phone with them and now (thanks to me) they have documentation about the issue and how to solve it!

Helping the community by giving back! Viva la Open Source!

Post Reply Subscribe to Thread

Tags
facebook, g2x, t-mobile
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes