Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,740,250 Members 41,190 Now Online
XDA Developers Android and Mobile Development Forum

Phone ringer is silent!

Tip us?
 
bingobob
Old
#1  
Member - OP
Thanks Meter 0
Posts: 55
Join Date: Mar 2007
Default Phone ringer is silent!

My phone wont ring though, BIZARRE, this is not to do with the rom though as i think it was happening with schaps, really really strange.

Any ideas, I just get a phone icon where the signal strength bar is showing handset. No callerid flashing up, not even an option to accept the incoming call. I go to phone options and test the ring tone and it plays just fine.

maybe i should reflash the radio, on 1.50 at the mo which i recently flashed to downgrade from 1.51, any ideas?

maybe i miss something totally obvious.
 
bingobob
Old
#2  
Member - OP
Thanks Meter 0
Posts: 55
Join Date: Mar 2007
bumppppp? anyone?
 
bcobra
Old
(Last edited by bcobra; 27th August 2007 at 04:23 PM.)
#3  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Jun 2007
Default same happening to mine on ultra ultra lite re-furbished

i had to flash another rom, then it worked. when i flashed back to same rom it didnt work again. the problem started after i added some cabs and did my regular tweaks. even with the fresh install of the same rom after flashing another rom it still didnt work.. i even changed radios
 
bingobob
Old
#4  
Member - OP
Thanks Meter 0
Posts: 55
Join Date: Mar 2007
i'm on ultra lite, and it seems nice. So you saying i should flash another rom then come back to ultra lite?
 
bingobob
Old
#5  
Member - OP
Thanks Meter 0
Posts: 55
Join Date: Mar 2007
Ok,

I just reflashed schaps, then flashed ultra lite.

I STILL have this wierd problem, what's going on?

Is my fone knackered? Not much good if it don't ring!
 
bcobra
Old
#6  
Junior Member
Thanks Meter 0
Posts: 7
Join Date: Jun 2007
Default the rom has been discontinued and he is fixing it

known bug.....wait until new relase
 
bingobob
Old
#7  
Member - OP
Thanks Meter 0
Posts: 55
Join Date: Mar 2007
shame it's a nice ROM, nice un' quick. fixed yet ?
 
madjokeer
Old
#8  
Senior Member
Thanks Meter 18
Posts: 234
Join Date: Aug 2006
Default same here..

I noticed that no sound was coming out of the phone when i did a soft reset and the Schap's Rom boot up with the animation + sound didnt sound. Also my speaker phone does not work. Basically and audible sound does not work!!!! i tried flashing it with dutty's rom, still same problem.. any ideas?
 
Quakie
Old
(Last edited by Quakie; 2nd October 2007 at 02:04 AM.) Reason: Update further info regarding test environment
#9  
Quakie's Avatar
Member
Thanks Meter 0
Posts: 57
Join Date: Oct 2006
Location: Vancouver
Cool Hope this helps in resolving this issue!

Hi. I've run into this issue myself too. Here's my environment:
  • Cooked ROM via Pandora's Kitchen 7.1 with 3.61 OS
  • Using Dutty's Touch Dialer (2G) option in BuildOS
Everything was fine with the ringer for a whole week. I then decided to be a bit adventurous and went to look for a 3g dialer because the Touch one is only 2G. I then settled for Schen's 3G dialer 2.0 and followed his instructions in installing it (install OEMSign2007cert.cab first, then the dialer, which was the one with the dialer directory option). I didn't install any colored background cabs as provided by his package.

When I tested the dialer (outgoing portion), it seemed fine. I couldn't test the 3G option because we don't have 3G here yet. The problem began when I received my first call.

I was able to hear the incoming call beep through my BT headset, but that was the only indicator of an incoming call, in addition to the phone icon above the signal meter in the top bar signifying an incoming phone call. Besides that, there were no other indicator such as a pop-up window showing incoming caller's info, phone ringing, or even the vibrate function. I have my phone set to vibrate and ring with the Ringer-Vision.wma as the default ring tone.

I tested the vibrate and ring setting in the phone configuration panel and both the vibration function and ring tone worked. I tried several configurations such as vibrate only, ring only, etc, in addition to other various ring tones of different format (wma, mid, wav). All resulted in success in the phone configuration panel, but in failure when an incoming call came in.

To test the phone function, I used a land line, a cellular line, and SkypeOut. All three resulted in the same failure observed above.

Given that the only thing changed after that week was the 3G dialer, I proceeded to remove it and reboot. It reverted back to the Touch 2G dialer. When the phone rebooted, I retried the above tests and all resulted in the pop-up dialog with incoming caller information (plus the two softkey functions), vibration function, and the proper ringtone.

With the above results, would it help you guys in further diagnosing and fixing this problem? We are slated to have 3G within the next few months and I would like to be able to use this function.

Thanks!

Edit update: One other thing is that I tested the above both with and without my BT headset on.

Quakie
Dream like you'll live forever, live like you'll die tomorrow...

My Gear
------------------------------------------------------------
Machine: Dopod 838 Pro
OS: Pandora 9.5/3.62
Radio: 1.54.07.00

Machine: i-Mate SP5
OS: WM6 For Tornado Perfect English Edition
Radio: 4.1.13.28_02.61.01
------------------------------------------------------------
 
madjokeer
Old
#10  
Senior Member
Thanks Meter 18
Posts: 234
Join Date: Aug 2006
I do understand what you are talking about how you tested out the ringers in the phone options menu.. but for me any type of sound does not work, i ran tests there no sound, speaker phone does not work, MP3 do not sound. The sound only works through a head set. And when im on a call i could hear the other person and vise versa. So the problem is the speaker just went out after a couple of days of having Schap's rom. I tired flashing another rom a couple of days after. No luck. Any ideas?
-thanks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...