5,604,219 Members 49,367 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Why can't i connect using the usb?

Tip us?
 
VH99
Old
#1  
Member - OP
Thanks Meter 1
Posts: 52
Join Date: May 2011
Location: Houston
Exclamation [Q] Why can't i connect using the usb?

Well guys i have a big problem. Its shouldn't be that big considering its a connection problem, but i can't seem to be able to fix it. I've been trying to connect to my laptop/desktop using the supplied micro usb and a blackberry micro usb, but it won't let me transfer files. the option to turn on storage doesn't even pop up on the notifications. it charges but thats it. i have all necessary drivers and the USB debugging option is checked. Any info or help would be welcome thanks!!
 
prettyboy85712
Old
#2  
prettyboy85712's Avatar
Senior Member
Thanks Meter 48
Posts: 995
Join Date: Jun 2007
Location: Tucson, AZ
What O/S are you using?
Phone - Rooted LG G2x
ROM - ParanoidAndroid
Nexus 7
 
C-4Nati
Old
#3  
C-4Nati's Avatar
Senior Member
Thanks Meter 22
Posts: 737
Join Date: Jun 2010
Location: Cincinnati
I had the same problem. No one gave me a problem solving answer

Sent from my LG-P999 using XDA App
 
VH99
Old
#4  
Member - OP
Thanks Meter 1
Posts: 52
Join Date: May 2011
Location: Houston
was running Stock froyo rooted. Then tried with Eagles Blood 1.05 Froyo.

Sent from my LG-P999 using XDA App
 
VH99
Old
#5  
Member - OP
Thanks Meter 1
Posts: 52
Join Date: May 2011
Location: Houston
Well that's encouraging C-4... lol

Sent from my LG-P999 using XDA App
 
fanatiq55
Old
#6  
Junior Member
Thanks Meter 1
Posts: 18
Join Date: Jul 2011
Default .

USB Debugging should be unchecked and Mass Storage is Checked.

Settings > Phone Storage > Mass Storage only = Checked.


hope this helps.
 
VH99
Old
#7  
Member - OP
Thanks Meter 1
Posts: 52
Join Date: May 2011
Location: Houston
I've tried that before w no success :( thanks though

Sent from my LG-P999 using XDA App
 
wakeboarder8156
Old
#8  
Member
Thanks Meter 6
Posts: 98
Join Date: Jan 2010
Mine wouldn't connect until i reinstalled the LG T-Mobile G2x drivers and now it mounts every time. The drivers in the updater tool installed the 3.2.1 drivers which is for the G-slate. You need the 2.2 drivers which are for the G2x, if you need them just pm me and i can send them to you.
 
VH99
Old
#9  
Member - OP
Thanks Meter 1
Posts: 52
Join Date: May 2011
Location: Houston
i deleted and reinstalled the 2.2 drivers with no success. im starting to think there's something wrong with my phone. But it could also be that i'm now running the Gingerbread leak from yesterday. rooted and working perfectly... well almost. i just need to get usb connection working.
 
conspirator_boff
Old
(Last edited by conspirator_boff; 22nd July 2011 at 09:52 PM.) Reason: (Not the same problem, but this might help.)
#10  
Junior Member
Thanks Meter 2
Posts: 4
Join Date: Apr 2011
Location: Portland
Similar issue. This worked for me on Win 7.

Uninstall the LG Drivers and reinstall the G2x 2.2 package from LG.COM /us/support/mc-support/mobile-phone-support.jsp (I can't post links)

Plug the phone in and go to Device Manager. There should be a USB Composite Device that is not properly installed. Right click it and select Update Driver Software.

Select 'Browse my computer', then 'Let me pick'. Choose have disk, and browse to where the LG Drivers are installed. Likely C:\Program Files\LG Electronics\LG United Mobile Driver\ and select lgbus9x.inf.

Then pick LGE Android Platform Composite USB Device from the list of drivers. Should be the top option. Hit next.

I let it sit for a minute while the drivers installed. Some things registered in device manager right away, the LGE USB Modem for one. But, the drives didn't. Unplugged the phone, plugged it back in, and the drives popped up under Portable Devices.

The Following 2 Users Say Thank You to conspirator_boff For This Useful Post: [ Click to Expand ]
Tags
connect, g2x, usb, windows, won't
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...