5,599,977 Members 45,882 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Clock issue after reboot to Windows Mobile

Tip us?
 
lie_ui
Old
#1  
Senior Member - OP
Thanks Meter 2
Posts: 396
Join Date: Oct 2005
Location: TX, US
Default [Q] Clock issue after reboot to Windows Mobile

We discussed before the clock issue in Android (where the clock always lagged).
In my FRX07, I enabled "use network provided time" and it seems to be okay.
What I noticed is that, every time I reboot the phone to Windows Mobile, the clock in Windows Mobile is messed up (not the minutes, but the hours).
Everytime I reboot to Windows Mobile, I would like to correct the hour in the clock.
Look around but I could not find how to enable the clock in WM to use the network provided time as well.
Any input/help will be appreciated. Thanks in advance.
 
arrrghhh
Old
#2  
Retired Forum Moderator / Recognized Developer
Thanks Meter 3099
Posts: 10,588
Join Date: Feb 2007

 
DONATE TO ME
Quote:
Originally Posted by lie_ui View Post
We discussed before the clock issue in Android (where the clock always lagged).
In my FRX07, I enabled "use network provided time" and it seems to be okay.
What I noticed is that, every time I reboot the phone to Windows Mobile, the clock in Windows Mobile is messed up (not the minutes, but the hours).
Everytime I reboot to Windows Mobile, I would like to correct the hour in the clock.
Look around but I could not find how to enable the clock in WM to use the network provided time as well.
Any input/help will be appreciated. Thanks in advance.
This is a WinMo issue, not an Android issue.

Android (and Linux/FreeBSD/every other OS) stores time in UTC, and then works backwards to your local time. WinMo (and Windows OS...) stores it in the local timezone only. So when you boot back to WinMo, it'll be exactly off by whatever offset you are from UTC.

To fix this, you need to resolve on the WinMo side. My phone always gets the time from the carrier - I'm a lucky CDMA user that always gets NITZ from my carrier .

If you're not so lucky and are on a GSM carrier that doesn't update your time properly, then you'll need to find some app in WinMo that keeps the clock synced. I can't help you here - again this is a WinMo problem, not Android!!. My solution for me is to just let the time update from my carrier. Again, if that does not work for you, find some atomic clock app or some such thing. Thanks!
The Following User Says Thank You to arrrghhh For This Useful Post: [ Click to Expand ]
 
ypsmav
Old
#3  
ypsmav's Avatar
Recognized Developer
Thanks Meter 461
Posts: 684
Join Date: Jul 2009
Location: EU
Hi lie_ui,
I use the following trick to avoid the problem when I'm back to WM.
In Android, I set up the time manually and I select a time zone -2 hours.
For example if you are in GMT+5, setup Android manually in GMT+3. In this way you will have no problems.

To avoid the time lag, I use clocksync from the market, which works ok.
Device: HTC Sensation Z710e (Sense 4.1 - S OFF w/Juopunutbear - Rooted)
Device 2: Galaxy TAB 7" (CM10.1 JB 4.2)

Device 3: HTC HD (Blackstone)
Rom: my Blackstone EDGE (Build 29022, Leo 3,14 + Oboe Manila 2.5.2021)


If you like my ROM or helped you in anyway, click the thanks button!
The Following User Says Thank You to ypsmav For This Useful Post: [ Click to Expand ]
 
lie_ui
Old
#4  
Senior Member - OP
Thanks Meter 2
Posts: 396
Join Date: Oct 2005
Location: TX, US
Thanks for the ideas! I will try it. Do mind explain to me where the -2 hours coming from? Just try to understand the logic. Thanks.
 
arrrghhh
Old
#5  
Retired Forum Moderator / Recognized Developer
Thanks Meter 3099
Posts: 10,588
Join Date: Feb 2007

 
DONATE TO ME
Quote:
Originally Posted by lie_ui View Post
Thanks for the ideas! I will try it. Do mind explain to me where the -2 hours coming from? Just try to understand the logic. Thanks.
Re-read my post. He's trying to circumvent the UTC effect... So he's setting it 2hrs back to offset UTC for his timezone...
 
Daved+
Old
#6  
Daved+'s Avatar
Senior Member
Thanks Meter 17
Posts: 373
Join Date: May 2008
I don't want to use a wrong timezone and I'm on GSM so I use ClockSync to set the time correctly in Android but I haven't found a similar application to do the same in WinMo so I'm setting my time manually everytime I want to use WinMo, it really sucks. Does anyone know any application that will sync the time automatically via NTP on WinMo?
Say thanks by clicking on the Thanks button!

Samsung T-Mobile Note III x 2, Samsung Galaxy Gear, B&N Nook HD+, Samsung S4, LG Optimus G Pro, LG Optimus G, Samsung I9000B, HTC Rhodium, HTC Touch, HTC Raphael, HTC Mogul, HTC Apache, Pantech Hero, Samsung Drift, Samsung Heat, Curitel TX-55C, Moto V3i, Moto V3, Moto V3620, Moto Lite II, etc, etc
 
arrrghhh
Old
#7  
Retired Forum Moderator / Recognized Developer
Thanks Meter 3099
Posts: 10,588
Join Date: Feb 2007

 
DONATE TO ME
Quote:
Originally Posted by Daved+ View Post
I don't want to use a wrong timezone and I'm on GSM so I use ClockSync to set the time correctly in Android but I haven't found a similar application to do the same in WinMo so I'm setting my time manually everytime I want to use WinMo, it really sucks. Does anyone know any application that will sync the time automatically via NTP on WinMo?
This is the Android Development section... Please ask in the general/WinMo section. Thanks.

Gooooogle found this, no clue if it works or not:

http://www.ehow.com/how_6717575_conf...e-use-ntp.html
 
korn2
Old
#8  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Nov 2009
Can we add some command or setting in Android's "STARTUP.txt" to offset the time?
But it still don't solve the time problem if we boot back to WinMo.
 
arrrghhh
Old
#9  
Retired Forum Moderator / Recognized Developer
Thanks Meter 3099
Posts: 10,588
Join Date: Feb 2007

 
DONATE TO ME
Quote:
Originally Posted by korn2 View Post
Can we add some command or setting in Android's "STARTUP.txt" to offset the time?
But it still don't solve the time problem if we boot back to WinMo.
It's really a WinMo issue. If your phone syncs its time with the carrier in WinMo, the problem is solved. I've never had this issue, but I guess my carrier always sends out NITZ so my time is always correct... love that CDMA .

Since it is a WinMo issue, you'll have to solve it with a WinMo app - find some atomic clock application for WinMo that automatically syncs the time in WinMo. ClockSync for Android, something similar for WinMo and you won't have the issue.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Control TWRP from within Android with TWRP Coordinator

You may recall that back when TWRP2 introduced a couple of years ago, it brought with … more

Keep Track of Everything Your Device Does with Event Logger

Regardless of their OS choice, computing power users generally share one common … more

A More Competitive Spin on the Addictive 2048 Puzzle

You may recall that a few weeks ago, we talked about a rather interesting take on … more

Multiboot in Progress for the Sony Xperia Z1

As we’ve mentioned quite a few times in the past, multiboot is quite the interesting … more