Remove All Ads from XDA

[Gingerbread Root] Pete's Motorola Root Tools

1,139 posts
Thanks Meter: 232
By infazzdar, Senior Member on 12th September 2011, 02:40 AM
Post Reply Subscribe to Thread Email Thread
This does not work with Droid X System Version .621.

(Information on this post was taken from Pete's website:

NOTE: If you were rooted on the original OTA and took the update to .602 and lost root, read the 'Droid X' notes under the how-to.


How to: One Click Root for Windows 7/Vista

1. Your phone must be connected via USB data cable to your computer and be recognized.

2. If your phone is connected, but not recognized, you may need to install one of these software drivers:
-Windows universal 32-bit Motorola drivers version 5.2.0
-Windows universal 64-bit Motorola drivers version 5.2.0

3. Download this one-click root package:

4. Extract the contents of the one-click root package to a new folder on your computer.

5. Make sure USB Debugging is enabled on your device. This should be under Settings -> Applications -> Development -> USB Debugging.

6. From the new folder on your computer, double-click on Pete's_Motrola_Root_Tools.exe to begin the root process.

7. Click 'Root My Phone'.


Droid X Note:

Droid X Notes

Your phone may need to be in either charging mode or PC mode or you may need to toggle it a number of times for the device to recognized correctly.

If you are trying to root from the OTA Gingerbread update and you were previously rooted, you will probably experience problems with this root method because of the pre-existence of busybox and superuser.apk. For that reason, you may need to attempt both the script method (for Windows XP users) and program executable method (Windows Vista/7 users). If you are still having problems, please follow these instructions:
Open a Command Prompt in the folder where you extracted the one-click root package (see instructions for rooting). If you are using Windows 7, you can just use Shift+Right-Click on the folder you extracted the package and choose to "Open a command prompt here". For other operating systems or versions of Windows, you may require some DOS experience or need to Google how to change directories.

In the command prompt, type the following command:


adb shell

If you receive any kind of error, then you may not be in the folder where you extracted ADB.exe or you may need to reboot your computer, your phone, or check the connection. You should receive an ADB prompt ending with either a # or a $.

If the line ends with a $, then run the one-click exploit for Windows XP (even if you have Windows Vista or 7) and only complete step 1.

When you have adb shell ending with a #, type the following commands:


mount -o remount,rw /dev/block/system /system
rm /system/bin/su
rm /system/xbin/su

Ignore any messages that warn you about the file not being found/missing. We're removing old copies of su/superuser which are causing this one-click root method to fail.

(credit: KevlarGibs)

Additionally, during the parts of the one-click root that reboot your phone, your phone will most likely reboot into recovery instead of into the standard Android lock screen. If this is the case, simply unplug the cable and reboot the phone manually. When you are finished rebooting, plug the phone back in again. Some people have had to reboot their PC too.

Finally, some users have mentioned that the root isn't taking affect right away for all apps. Eventually, after several reboots, the phone finally takes root. We're not sure why this is (I don't have a Droid X -- I'm just re-posting this information for brevity).


Please try the Windows Vista/7 method first! It will work better for most Windows XP users.
Only use this method if the other has not worked yet.


Nothing you see here is my work. All credit goes to Pete and everyone he's credited. I simply created this thread on XDA using Pete's information.
Last edited by infazzdar; 1st September 2012 at 09:41 PM.
The Following 20 Users Say Thank You to infazzdar For This Useful Post: [ View ] Gift infazzdar Ad-Free
12th September 2011, 02:41 AM |#2  
infazzdar's Avatar
OP Senior Member
Thanks Meter: 232
Donate to Me
Reserved for future information.
The Following 2 Users Say Thank You to infazzdar For This Useful Post: [ View ] Gift infazzdar Ad-Free
13th September 2011, 11:08 PM |#3  
Junior Member
Thanks Meter: 0
Thumbs up Awesome
Great tool, thanks so much!
17th September 2011, 02:51 PM |#4  
Thanks Meter: 5
Confirmed OTA
Works fine!!!
18th September 2011, 07:28 PM |#5  
Junior Member
Thanks Meter: 0
Awesome! Works perfectly!
19th September 2011, 08:05 PM |#6  
debaucher's Avatar
Thanks Meter: 15
Nice, I may give it a go (may sbf to 602 for a clean start)

20th September 2011, 04:56 PM |#7  
Junior Member
Thanks Meter: 0
I SBF'd to .602 on my DX and the root was successful but I can't get my phone to boot into CWM Recovery. I tried following the special DX instructions but can't get the ADB Shell to show anything but a $.

Whats next for me to try to get this working?
21st September 2011, 03:11 PM |#8  
Junior Member
Thanks Meter: 0
Hi I'm trying to unroot my x2 and it keeps saying Error: you are missing adb.exe, which was packaged with this program. The adb.exe is in the same folder as all of the other files i extracted to my restore folder. Any ideas?
21st September 2011, 04:04 PM |#9  
Senior Member
Northern Virginia
Thanks Meter: 7
I will try this at thanksgiving for my dad's X

It was rooted froyo and got the ota GB and wont root. Hopefully this works
23rd September 2011, 05:35 AM |#10  
Los Angeles
Thanks Meter: 2
Originally Posted by choonami

I SBF'd to .602 on my DX and the root was successful but I can't get my phone to boot into CWM Recovery. I tried following the special DX instructions but can't get the ADB Shell to show anything but a $.

Whats next for me to try to get this working?

Your preinstall is full. With Root Explorer go to preinstall/app/ and delete something (NFS). Reflash Clockwork mod. Then try again.

Sent from my PC36100 using XDA Premium App
24th September 2011, 09:12 PM |#11  
Thanks Meter: 1
I have just updated from 602 to 605 ota official.
Did run the process as guided above, but nothing seemed to happen on my droidX, and I cant see any super user. and did try to instal CWM to my device, its said the device has not rooted.
Any one got the same issue?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes