Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q]Android Market 3.1.5 update denies many apps (Device not compatible)

OP PVTD

2nd October 2011, 11:57 PM   |  #1  
PVTD's Avatar
OP Member
Flag Arezzo
Thanks Meter: 15
 
35 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Hello XDA
First post here, altho am an old XDA searcher hehe.

I just flashed a new ROM, [18.Sep.11][ZIP]★★★★★HyperDroid-CM7-v3.0.1[a2sd][CyanogenMod7 LEO 2.3.5][seader_R5]

Now, the good thing is, I can use my small standard battery pack again as it doesnt drain it that fast.
Bad part is...

As I backed up most off my apps from my previous ROM and imported them here, I cannot update them anymore.
And most apps I wana download just cannot be downloaded because of incompatibility (my behind!)


Now am stuck with retarded alted apps for twitter, FB and many other apps, or just not using them at all anymore...

It there a workaround for this issue? Maybe downgrade the market (which prob will auto update again...)

I might have seen a post with some one saying "you got to edit some .ini file in your root with a android notepad" but seems like I cant even install a simple Android notepad, so therefore quite anoying...
Edit to that part:
I did manage to get a rooted combination to mod the build.prop file
This is what I changed:

Code:
ro.product.model=HTC Vision	
ro.product.brand=tmobile
ro.product.name=vision
ro.product.device=vision
ro.product.board=vision

ro.product.manufacturer=HTC
But, it did not work...

Thanks in advance, keep the trolling for yourself or your little brother, just share what you think is a fix for this, I will thank you for it.

PVTD

EDIT 2: Current solution is on the 2th post.
Last edited by PVTD; 3rd October 2011 at 03:13 AM.
3rd October 2011, 02:25 AM   |  #2  
PVTD's Avatar
OP Member
Flag Arezzo
Thanks Meter: 15
 
35 posts
Join Date:Joined: Oct 2011
Donate to Me
More
I did find a fix who takes a bit of work, but I hope to get some one to make a decent full fix for it

Here is how I did it:
First, locate the Android Market in your apps list and select it.
You will find a button saying "Uninstall Updates", use it.
Once it's done, open the Android Market, press "I agree" and notice the app will auto close.

Act fast, as the app is downloading the updated market in silent mode.
What you do is open a rooted file explorer. Any should do.
Go to "root/cache/downloaded/ and delete everything inside.

Then it should be done, as that worked for me, tho not sure how long it would take to update again.

Hope this works for you

PVTD

Sent from my HTC Vision using XDA App (It did fool the XDA app xD should be HTC HD2)
Last edited by PVTD; 3rd October 2011 at 03:14 AM.
The Following 2 Users Say Thank You to PVTD For This Useful Post: [ View ]
6th October 2011, 12:15 AM   |  #3  
Junior Member
Thanks Meter: 6
 
11 posts
Join Date:Joined: Sep 2010
Thumbs up The Fix
You'll need Root Explorer

Open Root Explorer
Open the system folder
Long hold on build.prop and choose open in text editor
find the line that says ro.sf.lcd_density=
Change the numbers from 192 to 160
Save the file
Reboot your phone
Go to application management
choose the All tab
find market
choose it and then choose to force stop
then clear your cache
close out of file manager
reopen market place
you should now be able to get to the apps that you couldn't!
The Following 6 Users Say Thank You to tmtx76 For This Useful Post: [ View ]
28th October 2011, 06:15 AM   |  #4  
famewolf's Avatar
Senior Member
Thanks Meter: 413
 
2,759 posts
Join Date:Joined: Jul 2006
The rom on my hd2 comes with the new market by default...at first I thought the device incompatible messages were due to my 192dpi but even reverting to 240 it still showed same. Is there another solution?
28th October 2011, 09:30 AM   |  #5  
Droski's Avatar
Senior Member
Flag Seattle
Thanks Meter: 13
 
183 posts
Join Date:Joined: Sep 2010
Exclamation
Side note--There is an LCD density changing app so you can change on the fly with out having to go through all the file system stuff. Also the LCD density change seems to work for some and not for others, so to me it's a bust.

Now for the market-- The only thing that I have found to work short of altering the market itself, is using the market on my computer and pushing to my phone. This of course is a hassle and requires you to keep track of when updates come out for the apps you have.... But it works. I most recently had this problem with widget locker only seconds before I had it uninstalled it from my phone. Went on the web and pushed it to my phone, boom, installed.
Last edited by Droski; 28th October 2011 at 09:32 AM.
9th November 2011, 02:33 PM   |  #6  
Member
Thanks Meter: 4
 
42 posts
Join Date:Joined: Nov 2011
Changing the LCD density didn't work for me.. I just reverted to the old Market app to allow installation of some apps.
9th November 2011, 05:05 PM   |  #7  
Junior Member
Thanks Meter: 6
 
23 posts
Join Date:Joined: Jul 2010
More
I had same problem... here's how I fixed it. Change LCD density to default 240, then reboot. Then go to settings-applications-manage apps-market. Under market push clear data. Open market and agree and that worked for me.

I was getting a yellow banner in market that said "your device is not compatible with this item"

Sent from my HTC HD2 using xda premium
The Following 4 Users Say Thank You to chevyboy33 For This Useful Post: [ View ]
15th November 2011, 06:01 PM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by chevyboy33

I had same problem... here's how I fixed it. Change LCD density to default 240, then reboot. Then go to settings-applications-manage apps-market. Under market push clear data. Open market and agree and that worked for me.

I was getting a yellow banner in market that said "your device is not compatible with this item"

Sent from my HTC HD2 using xda premium

Thanks Chevyboy33,

This worked on my HD2 CM7 build
21st November 2011, 06:03 PM   |  #9  
Junior Member
Thanks Meter: 2
 
18 posts
Join Date:Joined: Jan 2010
Quote:
Originally Posted by tmtx76

You'll need Root Explorer

Open Root Explorer
Open the system folder
Long hold on build.prop and choose open in text editor
find the line that says ro.sf.lcd_density=
Change the numbers from 192 to 160
Save the file
Reboot your phone
Go to application management
choose the All tab
find market
choose it and then choose to force stop
then clear your cache
close out of file manager
reopen market place
you should now be able to get to the apps that you couldn't!

i dont see "thanks" button but, GREAT THANKS, It's working!!!!
The Following 2 Users Say Thank You to krzychoo89 For This Useful Post: [ View ]
27th November 2011, 04:33 PM   |  #10  
Junior Member
Thanks Meter: 1
 
12 posts
Join Date:Joined: Feb 2008
Quote:
Originally Posted by chevyboy33

I had same problem... here's how I fixed it. Change LCD density to default 240, then reboot. Then go to settings-applications-manage apps-market. Under market push clear data. Open market and agree and that worked for me.

I was getting a yellow banner in market that said "your device is not compatible with this item"

Sent from my HTC HD2 using xda premium

Just flashed AmeriCanAndroid AOSP HD2 GB2.3.7 CM7.1 and experienced the same problem. This solution also worked for me. I installed all the apps that I weren't able to, then changed back to custom dpi and rebooted again.

Thanks

Post Reply Subscribe to Thread

Tags
android market, bug, compatible, hd2
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes