Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,808,174 Members 35,830 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Gapps Package Bugs.. where to report?

Tip us?
 
gizzmoffm
Old
(Last edited by gizzmoffm; 11th October 2011 at 07:20 PM.) Reason: gapps version info
#1  
Member - OP
Thanks Meter 5
Posts: 39
Join Date: Oct 2010
Lightbulb [Q] Gapps Package Bugs.. where to report?

While testing CM7.1 I found that my google cloud backup was not working.
Restore worked fine, but backup was enabled, but not provisioned.
So I started reproducing that error, created logs and finally found that there is an incompatible version mismatch between several components of the gapps package.

In this special case, the GoogleBackupTransport.apk shows version 2.3 whereas other components show version 2.3.3 and 2.3.4 - a colorful mixture...
Some code from the newer packages is calling a service intent of GoogleBackupTransport which does not exist in version 2.3.
Read the full "story" in CM bug tracker, issue 4353 (I'm not allowed yet to post URLs here)

CM Team told me that they are not responsible for gapps - which I understand and respect.

So where could I report such an issue? Who created those packages?
In my special case, I used a newer GoogleBackupTransport.apk from an older Oxygen ROM, based on 2.3.5 - backup is working fine now, I'm happy.

I also considered creating a gapps package based on the 2.3.7 Versions that can be found in the oxygen-rom repositories, but those are not universal packages with all DPI versions, so I won't do that work if that's not a full replacement for the universal package...

Now, how to proceed getting this fixed? Or who could (and likes to) build a universal gapps package based on 2.3.7. A consistent package might solve other maybe yet undiscovered issues as well.

Edit: I'm talking about gapps-gb-20110828-signed.zip, but older versions are affected, too.
 
thegriso
Old
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Feb 2011
Any luck addressing this? I'm having the same problem.
 
gizzmoffm
Old
(Last edited by gizzmoffm; 13th February 2012 at 05:38 PM.)
#3  
Member - OP
Thanks Meter 5
Posts: 39
Join Date: Oct 2010
No, nothing happened. This will be fixed in ICS Gapps, as this is a complete new package.
To workaround this issue, do the following:
Get the GoogleBackupTransport apk in Version 2.3.7. You could extract it from the latest Oxygen ROM, for example (www.oxygen.im), or go to the oxygen github repository if you do not want to download the whole ROM, get it here:
https://github.com/oxygen-rom/androi...ead/system/app
Replace the old Version in your ROM, then delete data partition.
You have to run the Setup wizard again to activate the backup system, the only way to do this is a factory reset or a clear data from recovery.

Sent from my HTC Desire using XDA App
Tags
bug, gapps
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes