Post Reply

[PORT] Amazon Kindle Fire "Silk" Browser

OP TyHi

30th December 2011, 03:57 AM   |  #1  
OP Member
Flag Wisconsin
Thanks Meter: 70
 
71 posts
Join Date:Joined: Dec 2011
Update: I know this thread is super old but a Fellow member got us a working link: http://forum.xda-developers.com/atta...3&d=1325992799 Thanks lifegap .[/I]

After many test I managed to get Silk to work on a different OS. This worked on CM7 for Kindle Fire. If you get any errors please post.

Here is the link to the spreadsheet. Please check to see if your device is supported!


Install Tutorial:
1. Download the pack here.

2. Use Root Explorer to copy the lib files to /system/lib set permissions the same as the others.

3. Install all of the .apks like you would side load.

4. Copy the com.amazon.cloud9-1.apk from /data/app to /system/app

5. Reboot and enjoy

Check out this post from theverge! Here!

Edit (7/8/2012): Removed dead download links. All installer seems to be lost forever. If anyone still has the file please PM me. There is now no more spreedsheet editing. Most devices are listed so check it out.

Edit (1/6/2012): Made and Uploaded Silk Installer. Please read the directions in a later post. This is my last post for this project but I will still support it if people have erorrs.

Edit (1/4/2012): Updated SilkPort with puneet_champ's apk. Also Please stop screwing around with the spreadsheet.

Edit (1/4/2012): Updated Silk Pack/Added new mirror. (Removed Account and Sync) and Cleaned the post.

Edit (1/4/2012) As suggested by Cobracat03 you could try OTARootKeeper to use Amazon Prime Videos. If you can login to your amazon account through the Account and Sync settings post your method here or PM me if you can't post.
Last edited by TyHi; 23rd January 2013 at 03:10 AM.
The Following 59 Users Say Thank You to TyHi For This Useful Post: [ View ]
30th December 2011, 07:38 AM   |  #2  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jan 2010
Thumbs up
this worked for me on cm7 thanks!
30th December 2011, 08:51 AM   |  #3  
Senior Member
Flag Knoxville, TN
Thanks Meter: 16
 
114 posts
Join Date:Joined: Dec 2010
This worked on my ATRIX also. Interesting. I used everything but the account and sync aol because it would have replaced one of my files and I didn't want to do that.

Sent from my MB860 using xda premium
30th December 2011, 08:54 AM   |  #4  
Member
Flag Cedar Rapids
Thanks Meter: 19
 
73 posts
Join Date:Joined: May 2011
More
Thanks so much for this! I've been patiently waiting for someone to do this! I tried myself but couldn't get it to work right.

Edit: I followed the instuctions, except I couldn't replace the accounts and sync, I haven't tried to manually do it via root explorer. I didn't think it worked at first, I tried to open the silk browser it FC'd on me. So I reset my kindle and it's working like a charm
Last edited by brett10; 30th December 2011 at 09:18 AM.
31st December 2011, 01:52 AM   |  #5  
Senior Member
Thanks Meter: 31
 
127 posts
Join Date:Joined: Aug 2009
Donate to Me
It appears that the AccountAndSync.apk may be needed in order to get Prime videos working. Currently it doesn't recognize one as a prime subscriber.

The Silk Browser has the 'Accelerate Browsing' option checked (active) and greyed out (cannot deactivate).

Overall works well... Thanks!

Edit: I renamed the existing AccountAndSync.apk and added the one from the package. Still cannot find a way of adding credentials that are recognized by the VOD app. Currently it says that unit is not configured properly for playing videos when a video purchase is attempted.
Last edited by terracode; 31st December 2011 at 03:08 AM.
31st December 2011, 03:14 AM   |  #6  
Member
Thanks Meter: 6
 
57 posts
Join Date:Joined: Feb 2011
More
Works perfectly! Thank you! Now is there any way you can port the stock rom keyboard? That would be great!
31st December 2011, 03:16 AM   |  #7  
OP Member
Flag Wisconsin
Thanks Meter: 70
 
71 posts
Join Date:Joined: Dec 2011
I'll look into allowing Amazon Video. Don't know about the settings in Silk.
31st December 2011, 03:32 AM   |  #8  
OP Member
Flag Wisconsin
Thanks Meter: 70
 
71 posts
Join Date:Joined: Dec 2011
Updated the main post with more info.
31st December 2011, 07:54 PM   |  #9  
Senior Member
Thanks Meter: 6
 
262 posts
Join Date:Joined: Nov 2010
got the libs moved just fine. couldn't install any of the apk's. got a parsing problem each time. any ideas? i'm using a rooted optimus v with the bumblebee rom.
31st December 2011, 08:06 PM   |  #10  
OP Member
Flag Wisconsin
Thanks Meter: 70
 
71 posts
Join Date:Joined: Dec 2011
Try installing the apks in adb.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Kindle Fire Android Development by ThreadRank