Post Reply

[OBSOLETE] unofficial CyanogenMod 9/ClockworkMod Recovery 5 for Allwinner A10 devices

OP fun_

12th January 2012, 04:34 PM   |  #171  
FezzFest's Avatar
Senior Member
Flag Antwerp
Thanks Meter: 14
 
124 posts
Join Date:Joined: Oct 2009
More
Hi fun,

Did you succeed in modifying the goodix_touch module for ICS? I'd like to try building CyanogenMod 9 for the Bmorn V11 (CM7 from source works fine apart from the issues on page 15), Bmorn seems to take their time for ICS
Last edited by FezzFest; 12th January 2012 at 04:59 PM.
12th January 2012, 09:26 PM   |  #172  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2012
Quote:
Originally Posted by fun_

here is not "give me ROM!" thread. did you really see ONDA's web site before asking?

Yes I did, otherwise I wouldn't ask. But never mind, I still can't find it on their website.
13th January 2012, 12:02 AM   |  #173  
OP Senior Member
Thanks Meter: 639
 
2,376 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by ljeh

Yes I did, otherwise I wouldn't ask. But never mind, I still can't find it on their website.

even if you couldn't find it, there is no reason to ask it on this dev thread.
or do you think I said a lie?
http://www.onda.cn/Support/Search.aspx
I can see "V0.5" very clearly.
13th January 2012, 12:55 AM   |  #174  
OP Senior Member
Thanks Meter: 639
 
2,376 posts
Join Date:Joined: Aug 2010
Quote:
Originally Posted by FezzFest

Did you succeed in modifying the goodix_touch module for ICS? I'd like to try building CyanogenMod 9 for the Bmorn V11 (CM7 from source works fine apart from the issues on page 15), Bmorn seems to take their time for ICS

I investigated about TS issue and I'm thinking I can fix it but it's not yet done. please understand I'm really busy and I can't promise when it's done. my work may be done after weeks or months even if it's easy.

my plan is(it's not promise)
1. fix TS issue and make CM9 for A10 with GB ROM(2.6.36 kernel). primary target is NOVO7A with 2.0.4 GB ROM.
2. make CM9/CWM for A10 with ICS ROM(3.0.8 kernel). at least partition layout and format are different so it need to be done separately. primary target is NOVO7A with v0.3(or later) ICS ROM.

if all A10 tablets get ICS ROM, then I just do only 2. but probably I should do 1. for some tablets.
13th January 2012, 01:03 AM   |  #175  
OP Senior Member
Thanks Meter: 639
 
2,376 posts
Join Date:Joined: Aug 2010
sometimes I get message like as "fun_, you are bad guy because you didn't give me what I want". yes, it's true.

sometimes I get "fun_, I can help you so please tell me everything how to do it step by step". sorry, I can't help you.
sometimes I get "fun_, you should try my unconfirmed idea to improve (something)". sorry, I have no time to try your idea.
sometimes I get "my tablet is bricked. please help me". well, what should I do?

surprisingly some kind of people try to break my project. you may think I'm paranoid, but in fact, I needed to close one of my project
(even now I can't understand their message like as "fun_ just use my output! everything is done by me!" "fun_, you must respect others' work!".)

I hope this thread will not be filled by such kind of messages.
(but sometimes this message fires up "some kind of people"'s mind...)

thank you for your cooperation.
13th January 2012, 11:07 AM   |  #176  
OP Senior Member
Thanks Meter: 639
 
2,376 posts
Join Date:Joined: Aug 2010
hmm. TS works now... to some degree.

there is legacy TS support code in CM9. it didn't work well on NOVO7A with 2.6.36 kernel. I found some issue(?) in that code, I modified it, then TS is working. singletouch works fine, but multitouch has small issue.

this is first CM9 for me. I'm not sure how it works. probably I should fix TS driver in kernel(module). but legacy TS support code may be helpful for other tablets too.

I can see some issues on some places, but it may be good to release it. I'll prepare...
13th January 2012, 11:20 AM   |  #177  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Jan 2012
hi i have a tablo 7" and ive been trying for 2 days to get a rom to work.i can get the cwm recovery no problem but when i flash the update it just reboots over and over.
13th January 2012, 12:05 PM   |  #178  
Mitred's Avatar
Member
Thanks Meter: 4
 
76 posts
Join Date:Joined: Apr 2011
Quote:
Originally Posted by spiros100

hi i have a tablo 7" and ive been trying for 2 days to get a rom to work.i can get the cwm recovery no problem but when i flash the update it just reboots over and over.

I dont think fun has made rom available for other tablets yet just ainol7
if and when he does he will post about it
The Following User Says Thank You to Mitred For This Useful Post: [ View ]
13th January 2012, 04:45 PM   |  #179  
FezzFest's Avatar
Senior Member
Flag Antwerp
Thanks Meter: 14
 
124 posts
Join Date:Joined: Oct 2009
More
Quote:
Originally Posted by fun_

hmm. TS works now... to some degree.

there is legacy TS support code in CM9. it didn't work well on NOVO7A with 2.6.36 kernel. I found some issue(?) in that code, I modified it, then TS is working. singletouch works fine, but multitouch has small issue.

this is first CM9 for me. I'm not sure how it works. probably I should fix TS driver in kernel(module). but legacy TS support code may be helpful for other tablets too.

I can see some issues on some places, but it may be good to release it. I'll prepare...

Great! I can't wait I'm going to prepare my build environment (downloading sources takes about 4 hours...).
13th January 2012, 04:51 PM   |  #180  
djsebyss's Avatar
Senior Member
Thanks Meter: 87
 
135 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by tatalor

Hello all,

I have an "Alldro Speed" tablet (a10 based) which I managed to brick somehow (i played with root tools and recovery erase, and now it is stuck at the splash screen - minimal ADB access. but no further boot into android). Since there is no support for this tablet, I searched for similar ones and found this thread.

Tried to put the recovery, it seems to boot into it (the / is mounted on a 30mb partiotion with 7mb occupied (similar to the partition I write the recovery.cpio over)), but I have no GUI! (no menu, just blank screen. ADB works ok).

Pls. help. (I can provide some traces, if needed).
Thank you!

I think your alldro needs the original rom back... I had the same problem with the splash screen and I send it back to allview... They said it was a "soft" error and reflashed with a new one (different from the original but still 2.3.4).
Now... I found something interesting by pressing the vol. down button + power... it's a bootmenu or something (not the recovery, that's vol. up + power) in chinese I think, maybe somebody can translate it from the screenshot I made...

Last edited by djsebyss; 13th January 2012 at 04:56 PM.

Post Reply Subscribe to Thread

Tags
p76ti
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Miscellaneous Android Development by ThreadRank