Post Reply

unable to write files to external sd card

OP Mr Dasher

9th January 2012, 11:35 PM   |  #21  
Member
Flag Philly PA
Thanks Meter: 8
 
47 posts
Join Date:Joined: Jul 2011
Quote:
Originally Posted by thaloneus

I can't post a link to the original post on another forum that worked for me so I will quote it:

Simple solution for external sdcard write access on Android 3.2...if you're rooted

I've found a simple solution for gaining write access to the external sdcard (/mnt/sdcard2) on Android 3.2. The sdcard is mounted r/w, but the owning group is media_rw which is linked to the WRITE_MEDIA_STORAGE permission. Unfortunately, this permission was not required for access to the external sdcard prior to 3.2 so most file management utilities do not request it when they run...meaning they only have read access to the card.

The simple solution, if you're rooted, is as follows:
1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
3. Add an additional group definition for this permission...<group gid="media_rw" />
4. Save the changes to the file.
5. Restart your tablet.

After this change, any apps that request the WRITE_EXTERNAL_STORAGE permission (which includes almost anything that access either of the sdcards) will gain group membership in both sdcard_rw AND media_rw, giving them r/w access to both sdcard filesystems.

Good Stuff - worked for me. Thanks.
16th January 2012, 02:13 AM   |  #22  
KnoxBNYC's Avatar
Senior Member
Flag New York, NY
Thanks Meter: 57
 
274 posts
Join Date:Joined: Dec 2011
More
Thumbs up
Quote:
Originally Posted by boonhim

Please someone provide me more details or give me the picture of the edited .xml thanks.

Sent from my GT-P6200L using Tapatalk

This is my screen shot. After pulling my hair out over my Tab 7;0 Plus not being able to write to its SD card, I tried this idea from this forum and it worked like a charm!!

(See the top line of the screen cap.)

Knox B.
Attached Thumbnails
Click image for larger version

Name:	export_02.jpg
Views:	2272
Size:	46.3 KB
ID:	858832  
16th January 2012, 02:17 AM   |  #23  
KnoxBNYC's Avatar
Senior Member
Flag New York, NY
Thanks Meter: 57
 
274 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by thaloneus

I can't post a link to the original post on another forum that worked for me so I will quote it:

Simple solution for external sdcard write access on Android 3.2...if you're rooted

I've found a simple solution for gaining write access to the external sdcard (/mnt/sdcard2) on Android 3.2. The sdcard is mounted r/w, but the owning group is media_rw which is linked to the WRITE_MEDIA_STORAGE permission. Unfortunately, this permission was not required for access to the external sdcard prior to 3.2 so most file management utilities do not request it when they run...meaning they only have read access to the card.

The simple solution, if you're rooted, is as follows:
1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
3. Add an additional group definition for this permission...<group gid="media_rw" />
4. Save the changes to the file.
5. Restart your tablet.

After this change, any apps that request the WRITE_EXTERNAL_STORAGE permission (which includes almost anything that access either of the sdcards) will gain group membership in both sdcard_rw AND media_rw, giving them r/w access to both sdcard filesystems.

@thaloneus :

Thank you SOOO much for this.

But, I have to frickin' ask:

Is this a bug?

An oversight on Samsung's part?

A problem with Honeycomb?

Do other Honeycomb devices have the same problems?

Do all Honeycomb devices have this problem??

16th January 2012, 02:44 AM   |  #24  
garyd9's Avatar
Recognized Developer
Flag Pittsburgh, PA
Thanks Meter: 1,989
 
1,968 posts
Join Date:Joined: Sep 2006
Quote:
Originally Posted by KnoxBNYC

But, I have to frickin' ask: ... Is this a bug? ...
Do all Honeycomb devices have this problem??

Not a bug. Its a design change with honeycomb that very few (if any) app developers have caught up with. I think that at least some tablet makers have modified that .xml file in their stock firmware, but certainly not all of them.

Gary
16th January 2012, 11:57 PM   |  #25  
SuperBoUDS's Avatar
Senior Member
Thanks Meter: 49
 
155 posts
Join Date:Joined: Jan 2012
Thumbs up
Quote:
Originally Posted by thaloneus

The simple solution, if you're rooted, is as follows:
1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
3. Add an additional group definition for this permission...<group gid="media_rw" />
4. Save the changes to the file.
5. Restart your tablet.

After this change, any apps that request the WRITE_EXTERNAL_STORAGE permission (which includes almost anything that access either of the sdcards) will gain group membership in both sdcard_rw AND media_rw, giving them r/w access to both sdcard filesystems.

I have the same problem and this tip work for me. Thank u for useful tip .
20th January 2012, 03:49 PM   |  #26  
Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Mar 2011
Unhappy
I'm afraid this didn't work for me. I'm a bit new to working with an android device, but I have rooted the unit, and then acquired root explorerer, and then carefully edited the xml file noted. I rebooted and still cannot write to the extSD.

When I went back into the xml file, I noted that in place of two "group" tags (including the one I added for "media_rw"), only the one I added was in the permissions group noted. The one that was there when I edited is now gone. Even root explorer was not able to test create a new folder on the extSD.

Any suggestions?

CORRECTION: I can now navigate to the extSD and create folders via root explorer. But so far, other file managers (beyond the systems default) do not seem able to do so. Strange (to me). This also means I cannot copy and paste files either except through root explorer (which is sort of unfriendly to this newb vs. other file managers).
Last edited by Sigilist; 20th January 2012 at 04:06 PM. Reason: UPDATE
20th January 2012, 04:00 PM   |  #27  
zetajunkie's Avatar
Senior Member
Flag Brooklyn, NY
Thanks Meter: 5
 
190 posts
Join Date:Joined: Apr 2006
More
Quote:
Originally Posted by Sigilist

I'm afraid this didn't work for me. I'm a bit new to working with an android device, but I have rooted the unit, and then acquired root explorerer, and then carefully edited the xml file noted. I rebooted and still cannot write to the extSD.

When I went back into the xml file, I noted that in place of two "group" tags (including the one I added for "media_rw"), only the one I added was in the permissions group noted. The one that was there when I edited is now gone. Even root explorer was not able to test create a new folder on the extSD.

Any suggestions?

My solution was to use a different text editor than stock (used "Text Edit," free through market) after using Root Explorer to set the folder to r/w (read/write). I had no luck using the stock editor...
20th January 2012, 09:07 PM   |  #28  
Senior Member
Thanks Meter: 9
 
398 posts
Join Date:Joined: Jan 2004
Following the instruction, I can write to the External-SD card with Root Explorer, but if you reboot your table, whatever in there would be gone...

Does it happens to You?

Thanks
20th January 2012, 09:43 PM   |  #29  
Member
Thanks Meter: 12
 
49 posts
Join Date:Joined: Dec 2011
More
Quote:
Originally Posted by KChauJen

Following the instruction, I can write to the External-SD card with Root Explorer, but if you reboot your table, whatever in there would be gone...

Does it happens to You?

Thanks

It does not.

I almost forgot this important step when I edited the file:

"The simple solution, if you're rooted, is as follows:
1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
3. Add an additional group definition for this permission...<group gid="media_rw" />
4. Save the changes to the file.
5. Restart your tablet."

Check to make sure you are saving the edit before you reboot.
The Following 2 Users Say Thank You to StingerDog For This Useful Post: [ View ]
20th January 2012, 11:06 PM   |  #30  
Senior Member
Thanks Meter: 9
 
398 posts
Join Date:Joined: Jan 2004
Quote:
Originally Posted by StingerDog

It does not.

I almost forgot this important step when I edited the file:

"The simple solution, if you're rooted, is as follows:
1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
3. Add an additional group definition for this permission...<group gid="media_rw" />
4. Save the changes to the file.
5. Restart your tablet."

Check to make sure you are saving the edit before you reboot.

Oh yeah!!! of course, if it doesn't, then it can't be created on the new files or folder in external storage.

Double check again, created the new text file on the root of "extStorages", then reboot.... result: File is gone

FYI

The Following User Says Thank You to KChauJen For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes