5,596,354 Members 39,080 Now Online
XDA Developers Android and Mobile Development Forum

Debian for Nandroid

Tip us?
 
farhang_za
Old
#11  
Junior Member
Thanks Meter 0
Posts: 28
Join Date: Oct 2010
well i have tried my best but this is NOT realy working for me!
i get this Error :

# su
# sh /sdcard/deboot
mkdir failed for /sdcard/debian, File exists
losetup: /dev/block/loop5
mount: mounting /dev/block/loop5 on /sdcard/debian failed: Device or resource by
mount: mounting devpts on /sdcard/debian/dev/pts failed: No such file or directy
mount: mounting proc on /sdcard/debian/proc failed: No such file or directory
mount: mounting sysfs on /sdcard/debian/sys failed: No such file or directory
mount: mounting /sdcard on /sdcard/debian/root/sdcard failed: No such file or dy
net.ipv4.ip_forward = 1
chroot: can't execute '/bin/bash': No such file or directory
#
 
farhang_za
Old
#12  
Junior Member
Thanks Meter 0
Posts: 28
Join Date: Oct 2010
finallly got that working!
but this damn androidVNC wont connect!!
it says VNC connection failed!!!
 
diesburg
Old
#13  
diesburg's Avatar
Senior Member
Thanks Meter 100
Posts: 469
Join Date: Jan 2008
Quote:
Originally Posted by farhang_za View Post
finallly got that working!
but this damn androidVNC wont connect!!
it says VNC connection failed!!!
https://market.android.com/details?i...oremote.vncpro

I use that... remote vnc pro.... like $6 but it works great.....
 
farhang_za
Old
#14  
Junior Member
Thanks Meter 0
Posts: 28
Join Date: Oct 2010
Quote:
Originally Posted by diesburg View Post
https://market.android.com/details?i...oremote.vncpro

I use that... remote vnc pro.... like $6 but it works great.....
yeah! it worked thanks maan
 
Robbie P
Old
#15  
Robbie P's Avatar
Recognized Contributor
Thanks Meter 2679
Posts: 3,755
Join Date: Feb 2011
Location: London
I keep getting the error message
"sdcard/deboot: line 5: syntax error: unexpected "else"
#"
I checked out the linked thread by the OP and downloaded another deboot file but still got the same error.
I have got WP7 dual booted with american android with a 16GB SDcard partitioned 50:50
I managed to get Ubuntu 10.10 working via VNC off the SDcard but would like to get this debian to work to free up storage space.
Any suggestions would be appreciated
 
plasmastrike
Old
#16  
plasmastrike's Avatar
Senior Member
Thanks Meter 18
Posts: 117
Join Date: Aug 2008
Location: North ogden
i also got this error

# su
# sh /sdcard/deboot
mkdir failed for /sdcard/debian, File exists
losetup: /dev/block/loop5
mount: mounting /dev/block/loop5 on /sdcard/debian failed: Device or resource by
mount: mounting devpts on /sdcard/debian/dev/pts failed: No such file or directy
mount: mounting proc on /sdcard/debian/proc failed: No such file or directory
mount: mounting sysfs on /sdcard/debian/sys failed: No such file or directory
mount: mounting /sdcard on /sdcard/debian/root/sdcard failed: No such file or dy
net.ipv4.ip_forward = 1
chroot: can't execute '/bin/bash': No such file or directory
#

what do you have to do to fix it. is it a rom problem becouse i have hyperdriod gbx v12
http://forum.xda-developers.com/showthread.php?t=918899
is it different form hyperdriod gbx 2.01 becouse that is what imperiallight is using, im even using a 16gb sdcard but class 2
 
hendydundy
Old
(Last edited by hendydundy; 21st May 2011 at 11:19 AM.)
#17  
Member
Thanks Meter 5
Posts: 72
Join Date: Dec 2009
I also got the same problem...

any body know how to fix it??

Edit: solve the problem, reinstall the ROM from scratch..
Next.. ubuntu

Quote:
Originally Posted by plasmastrike View Post
i also got this error

# su
# sh /sdcard/deboot
mkdir failed for /sdcard/debian, File exists
losetup: /dev/block/loop5
mount: mounting /dev/block/loop5 on /sdcard/debian failed: Device or resource by
mount: mounting devpts on /sdcard/debian/dev/pts failed: No such file or directy
mount: mounting proc on /sdcard/debian/proc failed: No such file or directory
mount: mounting sysfs on /sdcard/debian/sys failed: No such file or directory
mount: mounting /sdcard on /sdcard/debian/root/sdcard failed: No such file or dy
net.ipv4.ip_forward = 1
chroot: can't execute '/bin/bash': No such file or directory
#

what do you have to do to fix it. is it a rom problem becouse i have hyperdriod gbx v12
http://forum.xda-developers.com/showthread.php?t=918899
is it different form hyperdriod gbx 2.01 becouse that is what imperiallight is using, im even using a 16gb sdcard but class 2
 
Cruonit
Old
#18  
Cruonit's Avatar
Member
Thanks Meter 91
Posts: 61
Join Date: Jan 2007
When connection via VNC client fails try:

vncserver :1
or
vncserver :2 (the port is 5902)

in the debian console
 
z3nful
Old
#19  
z3nful's Avatar
Senior Member
Thanks Meter 285
Posts: 247
Join Date: Jan 2011
Location: Phoenix
Quote:
Originally Posted by plasmastrike View Post
i also got this error

# su
# sh /sdcard/deboot
mkdir failed for /sdcard/debian, File exists
losetup: /dev/block/loop5
mount: mounting /dev/block/loop5 on /sdcard/debian failed: Device or resource by
mount: mounting devpts on /sdcard/debian/dev/pts failed: No such file or directy
mount: mounting proc on /sdcard/debian/proc failed: No such file or directory
mount: mounting sysfs on /sdcard/debian/sys failed: No such file or directory
mount: mounting /sdcard on /sdcard/debian/root/sdcard failed: No such file or dy
net.ipv4.ip_forward = 1
chroot: can't execute '/bin/bash': No such file or directory
#

what do you have to do to fix it. is it a rom problem becouse i have hyperdriod gbx v12
http://forum.xda-developers.com/showthread.php?t=918899
is it different form hyperdriod gbx 2.01 becouse that is what imperiallight is using, im even using a 16gb sdcard but class 2
First off, you already have the .img mounted(/sdcard/debian device busy), and the rest of the file structre wasn't created right.

to create it manually, run these in terminal:
Code:
cd /sdcard
rm /debian
mkdir /debian
cd debian
mkdir /dev/pts
mkdir /proc
mkdir /sys
 
Robbie P
Old
(Last edited by Robbie P; 8th February 2012 at 01:21 PM.)
#20  
Robbie P's Avatar
Recognized Contributor
Thanks Meter 2679
Posts: 3,755
Join Date: Feb 2011
Location: London
I just managed to boot this using SD Android via haret.
I couldn't get it to work before using ACA sd, see my previous post.
I used http://forum.xda-developers.com/show....php?t=1437463 SD ICS from tytung.
First boot created debian folder ok but after second boot I could not connect with VNC due to localhost:1 being used by /tmp/X1-lock. I tried using 5902 but no go.
After reading up whether you can delete this, it seems you can.
So using root browser (from market-free) I deleted /mnt/sdcard/debian/tmp/X1-lock (and also X11-UNIX in same place, as this also gives the same problem) and then entering the commands in terminal
I haven't had any problems so far.
Remember to backup everything before trying this, I don't accept responsibility etc.
Note; megaupload link in first post gone, use link in original thread

HTC HD2 (EU)
SPL 2.08. HSPL3;
Magldr 1.13 thanks bepe & Cotulla
On NAND - WP7.8 pdaimatejam v8.8 thanks to pdaimatejam, DFT, YukiXDA, xboxmod etc
On SDcards - Numerous Android SD builds & NativeSD ROMs (Thanks boonbing, Xylograph, securecrt & Almighty tytung!)
Radio 2.15.50.14 & Thanks to everyone@XDA
Recognised Contributor Code of Conduct

Learning Never Ends Team member

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes