Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,884 Members 52,736 Now Online
XDA Developers Android and Mobile Development Forum

ICS roms choppy video fix

Tip us?
 
eclipsekid07
Old
(Last edited by eclipsekid07; 25th February 2012 at 07:42 AM.) Reason: correction
#1  
Junior Member - OP
Thanks Meter 5
Posts: 17
Join Date: Nov 2010
Default ICS roms choppy video fix

I couldn't find a video player that would work with cyanogen mod 9 ics rom because lack of hardware acceleration i found that MX video player (free) does work perfectly on my p1000 galaxy tab when set to software decoding though just thought i would let everyone know because i was trying multiple things to get it to work. I have only tried this with .3gp video though. My ics rom does everything I need it to now, hope this helps .
 
qm4n76
Old
#2  
qm4n76's Avatar
Senior Member
Thanks Meter 106
Posts: 334
Join Date: Oct 2011
Location: Gorontalo
Quote:
Originally Posted by eclipsekid07 View Post
I couldn't find a video player that would work with cyanogen mod 9 ics rom because lack of hardware acceleration i found that MX video player (free) does work perfectly on my p1000 galaxy tab when set to software decoding though just thought i would let everyone know because i was trying multiple things to get it to work. I have only tried this with .3gp video though. My ics rom does everything I need it to now, hope this helps .
I don't have any problem with video player in cm9
Check this
Itís your Android, your one and only Android-so take excellence very personally
[TABLET1] Gtab P1000 for daily use SOLD OUT
[TABLET2] Gtab P1000 for testing of any P1000 ROM
[PHONE1] iPhone 4 Trade with GT-N7000
[PHONE2] SGS 2 [ROM-ICS]-[--VK--ô]-[-XWLPG-V5.1.2]
[PHONE3] Axio VIGO-410 MIUI 1.11.11 by tjstyle

[PHONE4] NOKIA XM5800 death
[PHONE5] NEXUS 4
 
eclipsekid07
Old
#3  
Junior Member - OP
Thanks Meter 5
Posts: 17
Join Date: Nov 2010
Quote:
Originally Posted by qm4n76 View Post
I don't have any problem with video player in cm9
Check this
If you look in the description of the video you posted its using mx video player thats why its working because currently there is no hardware acceleration.
 
rjumawan
Old
#4  
Senior Member
Thanks Meter 6
Posts: 348
Join Date: Jun 2007
I still get like a tear looking thing on the upper right part of the screen.How to fix that?

Sent from my SCH-I800 using XDA App
 
eclipsekid07
Old
(Last edited by eclipsekid07; 2nd March 2012 at 02:20 PM.) Reason: grammer
#5  
Junior Member - OP
Thanks Meter 5
Posts: 17
Join Date: Nov 2010
Default Settings for Mx Video Player to play .3gp videos

I checked s/w decoder, fast mode and deinterlace in decoder settings that mad my .3gp video played fine i am not sure with other video formats if they will work though what kind of video format are you using?
 
qm4n76
Old
#6  
qm4n76's Avatar
Senior Member
Thanks Meter 106
Posts: 334
Join Date: Oct 2011
Location: Gorontalo
Quote:
Originally Posted by eclipsekid07 View Post
If you look in the description of the video you posted its using mx video player thats why its working because currently there is no hardware acceleration.
There is HW acceleration enable on mx video player that I'm using playing the video on my post.

Sent from my GT-P1000 using XDA Premium HD app
Itís your Android, your one and only Android-so take excellence very personally
[TABLET1] Gtab P1000 for daily use SOLD OUT
[TABLET2] Gtab P1000 for testing of any P1000 ROM
[PHONE1] iPhone 4 Trade with GT-N7000
[PHONE2] SGS 2 [ROM-ICS]-[--VK--ô]-[-XWLPG-V5.1.2]
[PHONE3] Axio VIGO-410 MIUI 1.11.11 by tjstyle

[PHONE4] NOKIA XM5800 death
[PHONE5] NEXUS 4
 
eclipsekid07
Old
#7  
Junior Member - OP
Thanks Meter 5
Posts: 17
Join Date: Nov 2010
Quote:
Originally Posted by qm4n76 View Post
There is HW acceleration enable on mx video player that I'm using playing the video on my post.

Sent from my GT-P1000 using XDA Premium HD app

When I posted this It was working with software decoder only, you are using a slimdizzy rom a nightly build I was using "CM9 (WIP)" at the time. Now hardware acceleration works fine anyways on Milestone 4 rom.
 
eclipsekid07
Old
#8  
Junior Member - OP
Thanks Meter 5
Posts: 17
Join Date: Nov 2010
Default Update MoboPlayer works better than Mx Video Player

I have found out MoboPlayer is a better solution for a video player. Mx Video Player seems to have some glitches with video playback. I am using build #28 AOKP ICS rom with MoboPlayer and am very pleased with MoboPlayer it works perfect with no choppy playback at all.
 
qm4n76
Old
(Last edited by qm4n76; 26th March 2012 at 06:21 AM.) Reason: add quote
#9  
qm4n76's Avatar
Senior Member
Thanks Meter 106
Posts: 334
Join Date: Oct 2011
Location: Gorontalo
Quote:
Originally Posted by eclipsekid07 View Post
When I posted this It was working with software decoder only, you are using a slimdizzy rom a nightly build I was using "CM9 (WIP)" at the time. Now hardware acceleration works fine anyways on Milestone 4 rom.
Quote:
Originally Posted by eclipsekid07 View Post
I checked s/w decoder, fast mode and deinterlace in decoder settings that mad my .3gp video played fine i am not sure with other video formats if they will work though what kind of video format are you using?

there is a new kernel from HumberOS, this kernel can apply for all CM9 ROM , it's fix wifi and video HW accel, chek this
Quote:
Originally Posted by humberos View Post
Main Features:
  • New wifi driver
  • HW/Accel without green glitch.

Download

http://www.humberos.com.br/p/android-ics.html

Enjoy!

Greetings from Brazil!
Itís your Android, your one and only Android-so take excellence very personally
[TABLET1] Gtab P1000 for daily use SOLD OUT
[TABLET2] Gtab P1000 for testing of any P1000 ROM
[PHONE1] iPhone 4 Trade with GT-N7000
[PHONE2] SGS 2 [ROM-ICS]-[--VK--ô]-[-XWLPG-V5.1.2]
[PHONE3] Axio VIGO-410 MIUI 1.11.11 by tjstyle

[PHONE4] NOKIA XM5800 death
[PHONE5] NEXUS 4
The Following User Says Thank You to qm4n76 For This Useful Post: [ Click to Expand ]
 
eclipsekid07
Old
#10  
Junior Member - OP
Thanks Meter 5
Posts: 17
Join Date: Nov 2010
Quote:
Originally Posted by qm4n76 View Post
there is a new kernel from HumberOS, this kernel can apply for all CM9 ROM , it's fix wifi and video HW accel, chek this
Thanks , I will definitely try this might fix the issue i have with game loft nova game also.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes