5,596,354 Members 37,924 Now Online
XDA Developers Android and Mobile Development Forum

Screen blank on power on

Tip us?
 
PaulMdx
Old
#1  
Senior Member - OP
Thanks Meter 0
Posts: 209
Join Date: Mar 2007
Default Screen blank on power on

I've had a problem with my E900 since I got it with regards to the screen. I was hoping Mango might fix it but it doesn't seem to have.

Sometimes if I press the power button the screen backlight comes on (i.e. screen goes from off state to powered) but there is nothing on the screen. No amount of button pressing will cause the screen to show anything.

If this happens I have to turn the device off again (backlight then goes off) and try again. Sometimes it can take 2-3 times before it turns on successfully with the lock screen.

I also have this if an incoming call attempts to wake the phone and also alarms too.

Does anyone else have this issue?
 
mcm69
Old
#2  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Oct 2011
I confirm this one popping sometimes. Not that often that it becomes annoying, but nevertheless.
 
prelud
Old
#3  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Feb 2009
Did you find a solution to this problem? I am experiencing it too and it is very annoying!
 
the_ape
Old
#4  
the_ape's Avatar
Senior Member
Thanks Meter 226
Posts: 684
Join Date: May 2005
Location: UK
I've recently inherited one as well (E900 that is).

The one I have has been dropped, the backlight powers, but no drawing on the screen.

I've disassembled and re plugged everything (bugger stripping down!) but still no luck. I've done a VolUp+Down+Cam+power hard reset, and when I plug into PC Zune says setup needs completing (so it has reformatted) but still no luck.

I cant see anything fried, and no damaged ribbons as far as I can see, any ideas?
Ashleigh

Phones : Note 3 9005 / Galaxy S3 i9300 & i9305 / S3 Mini i8190N / Nokia Lumia 920 / SanDiego / iPad 3G / HP ElitePad 900
OS's : 4.3 / 4.3 / 4.3 / 4.1.2 / Amber / 4.1 / 7.0.4JB / Win 8.1

Galaxy S3 i9300 Blocking Mode icon Remover - Dead Project
Galaxy S3 i9300 Smart Rotate enabler - Dead Project
Note 3 Touchwiz Launcher 5x4


If I've helped in any way, why not click the thanks button, cheers
 
PaulMdx
Old
#5  
Senior Member - OP
Thanks Meter 0
Posts: 209
Join Date: Mar 2007
I sold the phone a while ago, and never solved the problem. I think it's a firmware issue.
 
JosipoGo
Old
#6  
Member
Thanks Meter 1
Posts: 48
Join Date: Nov 2011
Location: Sarajevo
Quote:
Originally Posted by PaulMdx View Post
I've had a problem with my E900 since I got it with regards to the screen. I was hoping Mango might fix it but it doesn't seem to have.

Sometimes if I press the power button the screen backlight comes on (i.e. screen goes from off state to powered) but there is nothing on the screen. No amount of button pressing will cause the screen to show anything.

If this happens I have to turn the device off again (backlight then goes off) and try again. Sometimes it can take 2-3 times before it turns on successfully with the lock screen.

I also have this if an incoming call attempts to wake the phone and also alarms too.

Does anyone else have this issue?
hi.
What do you mean "somethimes if I press power button"?
Is it pressed with purpose to lock the phone, press it to turn off phone (background slider shows to power off - on Mango and beyond version) or press it accidentally?
Cheers.
 
prelud
Old
#7  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Feb 2009
So, I did a phone reset. Unfortunately the issue is still present!

Sometimes when I press the power button to unlock the phone the screen is lit, but stays blank i.e. no lockscreen wallpaper, no nothing. The same happens sometimes when I get a phone call - the phone rings and vibrates, the screen is lit but stays blank.
When this happens I have to press the power button to put the phone into sleep mode and press it again to wake it up.
What I found is, when the issue occurs the screen is actually responsive. For example I can slid up and unlock the phone then I hear the unlock "pop" sound. It's just that nothing is drawn on it!
I was wondering if anyone else experienced the same behavior and found a resolution. Also I am not sure if this is a software or a hardware problem. If I could confirm it was a hardware problem I would call LG and have the phone repaired or replaced.
 
billybrown
Old
#8  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Feb 2012
i have exactly the same issue as you, it gets really annoying.
i heard from someone online that the only way to resolve it is to replace the motherboard
 
prelud
Old
#9  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Feb 2009
Quote:
Originally Posted by billybrown View Post
i have exactly the same issue as you, it gets really annoying.
i heard from someone online that the only way to resolve it is to replace the motherboard
I am pretty certain this is a hardware issue. I am calling LG tomorrow and hopefully they'll take the phone for repair/replacement.
 
prelud
Old
(Last edited by prelud; 14th March 2012 at 11:48 PM.)
#10  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Feb 2009
I sent my phone for repair. Today I got it back, and guess what?!
The issue is still present! It seems, they "couldn't reproduce" or something.
What should I do now?

EDIT: If anyone is interested, here is a video I just captured which clearly demonstrates the problem. http://youtu.be/38kF9RYs_bU

I'm sending the phone back for repair tomorrow with this video attached.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Force Translucent Status Bar in KitKat ROMs with Xposed

It’s been a while since Android 4.4KitKat wasreleased, and we’re slowly … more

Fix the Ambient Light Issues on Your Google Nexus 5 using Xposed

The Google Nexus 5 is a great and rather popular device. This LG-produced … more

Google Glass XE16 Update Factory Image and Rooted Bootloader Now Available

You may recall that early yesterday, we talked about the XE16 … more