5,814,797 Members 51,096 Now Online
XDA Developers Android and Mobile Development Forum

Sony Ericsson LiveView™ Issues

Tip us?
 
zbt1985
Old
#631  
Senior Member
Thanks Meter 11
Posts: 289
Join Date: Dec 2008
Location: Vibrant
hey all, i know this is a stupid question, but i can't seem to get any of the plugins working.

I haven't used my liveview in a long time and decided that i would try it again.

but i don't remember how to get the plugins to show up on my liveview...i went into the pluggin area on the liveview app itself, but can't seem to get it to find any of the plugins...

any help?


Thanks in advance!
 
gelvlc
Old
#632  
gelvlc's Avatar
Member
Thanks Meter 6
Posts: 57
Join Date: Feb 2011
Location: valencia
Quote:
Originally Posted by zbt1985 View Post
hey all, i know this is a stupid question, but i can't seem to get any of the plugins working.

I haven't used my liveview in a long time and decided that i would try it again.

but i don't remember how to get the plugins to show up on my liveview...i went into the pluggin area on the liveview app itself, but can't seem to get it to find any of the plugins...

any help?


Thanks in advance!
Hi.
I think you must install the plugins from the market, no?
Good luck!

Enviado desde mi Galaxy Tab P1000 2.3.6 Hyperdroid Rom
 
skitty
Old
#633  
Senior Member
Thanks Meter 47
Posts: 176
Join Date: Jul 2005
Quote:
Originally Posted by zbt1985 View Post
hey all, i know this is a stupid question, but i can't seem to get any of the plugins working.

I haven't used my liveview in a long time and decided that i would try it again.

but i don't remember how to get the plugins to show up on my liveview...i went into the pluggin area on the liveview app itself, but can't seem to get it to find any of the plugins...

any help?


Thanks in advance!
are you on ICS? (Android 4.0)

Sent from my Galaxy Nexus using xda premium
 
pjku79
Old
(Last edited by pjku79; 28th February 2012 at 01:35 PM.)
#634  
Junior Member
Thanks Meter 0
Posts: 11
Join Date: Feb 2012
I have read through tons and tons of threads with suggestions on how to fix the liveview, but there seems to be a lot of different answers. Is there a consensus on what the best way to resolve the connection issue is? Is there some where is have a step by step for someone that is a beginner? Also, while I am asking questions, I noticed some instructions said you had to be rooted, but with all my searching I couldn't find instructions on how to root the liveview. Is that documented some where.
 
ayturkozmen
Old
(Last edited by ayturkozmen; 28th February 2012 at 11:53 PM.)
#635  
Senior Member
Thanks Meter 27
Posts: 113
Join Date: Dec 2009
Location: Ankara
Quote:
Originally Posted by pjku79 View Post
I have read through tons and tons of threads with suggestions on how to fix the liveview, but there seems to be a lot of different answers. Is there a consensus on what the best way to resolve the connection issue is? Is there some where is have a step by step for someone that is a beginner? Also, while I am asking questions, I noticed some instructions said you had to be rooted, but with all my searching I couldn't find instructions on how to root the liveview. Is that documented some where.

Before Liveview pair your device and then perform the following steps;


Quote:
Originally Posted by Drakosha View Post
Fivef, you're genius! You actually made this half-incomplete device usable!!!

People, I really think this information should be sicked to the first page, or posted in the FAQ, This simple hack changes everything about LiveView experience! So, I'd like to summarize here all the steps for correcting issues, which, by the way, SHOULD have been corrected by SonyEricsson much earlier.

Below is a small guide for turning LiveView from nerve-bending hell spawn to incredibly useful device. Root is required.

(assuming your phone has CM7 or factory Gingerbread - here I'm using HD2 + CM7 2.3.4)
1) Update LV firmware to the latest one
2) Install from the market "LiveView Application 1.0.A.0.18" ONLY, do not install "LiveWare Manager"
3) Install your favorite plugins
4) Install from the market "Minfree Manager" and set "Secondary server" memory limit to 8 - 10mb (this will help LV App to stay activated all the time)
5) Insert "LiveView Application 1.0.A.0.18" to ignore list of all automatic task killers like "ES Task Manager" or "Auto memory manager"
6) Put LV into discovery mode and pair it to your phone. BT window will say "Paired but not connected", that's correct.
7) Using Root Explorer, apply the incredible patch from Fivef (this seems to be needed only for non-Sense 2.3.x devices - looks like Sense allows LV to connect without confirmation)8) Find in the market & install the BEST Android program I've seen yet - "AutomateIt!"
9) Create the following rule in this program:
TRIGGER: BLUETOOTH DEVICE CONNECTED (LIVEVEW)
ACTION: START APPLICATION (LIVEVIEW)
Using this incredible program, you can completely control every aspect of your phone's behavior - for example, automatically start PlayerPro and disable WiFi when wired headset is connected, automatically start WiFi when GPS detects that you have entered your home or office (!) and do million other cool things.

By now, LiveView is set to operate completely by itself - no matter, what state is your phone in the moment, just switch the watch "on" and in a second it's connected. No more manual start of LV app, countless disconnects and unnerving connect confirmations. In fact, LV is starting to work better than SE MBW-150 used to work on WM6.5!

I suggest sticking this post to the front page, so that newcomers wouldn't have to search for days (like I had to...)

Best regards,
Draco.


Quote:
Originally Posted by timspb View Post
I think this is easily fixed by editing the /system/build.prop
if we have not such line, we need to add this:


# apps to be kept in memory (specified by process name)
# use with caution, RAM is limited!
sys.keep_app_1=com.sonyericsson.extras.liveview.la unch

and then we must to restore the premissions of build.prop

and the system not stop this app due to low memory.
P.S. Sorry for my english

also;

Rom using data> misc> bluetooth> incoming_connection.conf file exists;

00:21:9E:94:AD:23,-1,1326587152292-1000 ------> MN800

MN800 row changed;

00:21:9E:94:AD:23,1,1326587152292-1000 ------> MN800


I obtained this way the best results.
The Following User Says Thank You to ayturkozmen For This Useful Post: [ Click to Expand ]
 
slammish
Old
#636  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Feb 2012
after updating my linkkeys file and the firmware with the sony ericsson updater my liveview no longer connects at all, just tries to pair until the liveview decides to turn off. takes about 3-5 minutes - it succeeds in supressing the pair request dialogue, but i think that may be keeping it from being paired all together.

any suggestions? i set the linkkeys file back to how it was, but it doesn't help. i've restarted the phone. is there a way to reset the linkkeys file?
 
ayturkozmen
Old
#637  
Senior Member
Thanks Meter 27
Posts: 113
Join Date: Dec 2009
Location: Ankara
Quote:
Originally Posted by slammish View Post
after updating my linkkeys file and the firmware with the sony ericsson updater my liveview no longer connects at all, just tries to pair until the liveview decides to turn off. takes about 3-5 minutes - it succeeds in supressing the pair request dialogue, but i think that may be keeping it from being paired all together.

any suggestions? i set the linkkeys file back to how it was, but it doesn't help. i've restarted the phone. is there a way to reset the linkkeys file?
Approval of the your LiveView device want to pair 2 times. After approval of the first check should not see the second window, in this case lowering the statusbar can see and confirm the confirmation prompt. After the second approval, pair problem must be resolved.

Sorry my bad English.
 
slammish
Old
(Last edited by slammish; 29th February 2012 at 03:57 PM.)
#638  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Feb 2012
Quote:
Originally Posted by ayturkozmen View Post
Approval of the your LiveView device want to pair 2 times. After approval of the first check should not see the second window, in this case lowering the statusbar can see and confirm the confirmation prompt. After the second approval, pair problem must be resolved.

Sorry my bad English.
the english isn't so bad- i can make it out- i'm just glad you responded so quickly. there's nothing to approve at all though, there are no prompts whatsoever to pair with my liveview anymore- even in the statusbar.

my liveview first shows the circular sync icon, then the phone shows that the liveview is paired but not connected, then the liveview will sit with the phone icon ... the liveview icon for more than 3 minutes, then it will shut off. no notifications on my phone or on the liveview. sometimes the liveview will show a lightning bolt when it fails to pair, but mine doesn't even do that anymore.
 
ayturkozmen
Old
#639  
Senior Member
Thanks Meter 27
Posts: 113
Join Date: Dec 2009
Location: Ankara
Quote:
Originally Posted by slammish View Post
the english isn't so bad- i can make it out- i'm just glad you responded so quickly. there's nothing to approve at all though, there are no prompts whatsoever to pair with my liveview anymore- even in the statusbar.

my liveview first shows the circular sync icon, then the phone shows that the liveview is paired but not connected, then the liveview will sit with the phone icon ... the liveview icon for more than 3 minutes, then it will shut off. no notifications on my phone or on the liveview. sometimes the liveview will show a lightning bolt when it fails to pair, but mine doesn't even do that anymore.

Liveview reset of your device is useful. To do this, need to re-install the SonyEricsson Update Service software using.
 
slammish
Old
(Last edited by slammish; 29th February 2012 at 08:08 PM.)
#640  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Feb 2012
i just did an update again (reset) and it still does the same thing

my phone no longer asks me to pair the device. i think it's my phone's problem, not the liveview- i think it's whatever that linkkeys file is. i removed all edits i made to that file though- and i saved it as all files instead of txt, so that's not it.

would it hurt anything to wipe out the linkkeys file? do you think it would reset it?

update: okay, now when i use root explorer to view the linkkeys file with text editor it is blank. i go to paste in my original file's contents and save, it saves, then it's blank again.

this is so frustrating

Tags
live view, liveview, mn800, sony ericsson
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes