Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[JT1134's ROM] ICS is Here (Post Updated With Screenshots)

OP rami98

28th February 2012, 08:57 AM   |  #411  
motcher41's Avatar
Senior Member
Flag Brainerd, Minnesota
Thanks Meter: 1,299
 
3,445 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by XbirthofaheroX


Its a race!
Sent from my SCH-I510 using XDA App

I'm a bit behind.in the thread but I wouldn't call it a race lol cm9 and stock "touchwiz" ics are like apples and oranges

sent from my eclipsed chargecrack
28th February 2012, 09:00 AM   |  #412  
motcher41's Avatar
Senior Member
Flag Brainerd, Minnesota
Thanks Meter: 1,299
 
3,445 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by JihadSquad

OK I just flashed this. Ignore anything I said about lag. This now looks optimized for our system, compared to the previous version. A lot more was changed since the original release.

I think it runs more smoothly than with GB.

On a side note I can't get USB mass storage or ADB to work with my PC. Anyone else have this problem?

In dev tools there is a box in one of the menus that has "wait for debugger"....check that and reboot adb worked then can't remember if mass storage did.
I did the adb devices during start up and it link and I pulled a logcat out too

sent from my eclipsed chargecrack
28th February 2012, 02:53 PM   |  #413  
Member
Thanks Meter: 4
 
34 posts
Join Date:Joined: Oct 2009
Quote:
Originally Posted by JihadSquad

Does anyone know if the newest build fixes the home button?

It does indeed.

Things I've found that are broken:

-Data
-Camera
-Voice Search/Recording (Evernote, at least.)

I also had some pretty horrendous lagginess when first setting up, but after a reboot, it went away and stayed away.

Back on Eclipse as my daily because I need those three things to make the switch, but it was a pretty great experience otherwise. DEFINITELY excited about the progress jt has made.
28th February 2012, 08:10 PM   |  #414  
Recognized Developer
Thanks Meter: 3,148
 
1,089 posts
Join Date:Joined: May 2010
Donate to Me
Quote:
Originally Posted by JihadSquad

OK I just flashed this. Ignore anything I said about lag. This now looks optimized for our system, compared to the previous version. A lot more was changed since the original release.

I think it runs more smoothly than with GB.

On a side note I can't get USB mass storage or ADB to work with my PC. Anyone else have this problem?

I attempted to make use of the legacy USB manager to avoid having to update the kernel drivers, but this doesn't seem to work correctly since the kernel lacks a USB switch. Usually after a few reboots adb works, or you can start it manually using the built in terminal. Mass storage has to be started in terminal also. Ex: echo '/dev/block/mmcblk1p1' > /sys/devices/platform/usb_mass_storage/lun1/file

Sent from my Galaxy Nexus using XDA App
Last edited by jt1134; 28th February 2012 at 08:17 PM.
The Following 5 Users Say Thank You to jt1134 For This Useful Post: [ View ]
28th February 2012, 08:13 PM   |  #415  
Recognized Developer
Thanks Meter: 3,148
 
1,089 posts
Join Date:Joined: May 2010
Donate to Me
Quote:
Originally Posted by jkat797

Does anybody notice that the vibration when receiving a text is unbelievably low? Or is just me? I'm trying to get to the bottom of this. By the way great job jt!!

Sent from my SCH-I510 using XDA App

Vibration is weird...I hacked some debug into the kernel that can fix it, curious whether it works in the kernel I released.

echo 1 > /sys/class/vibetonz/immTest/immTest

That fixes it with the debug kernel module, if it works with the kernel I released then chalk it up to one more thing Samsung left out of their shipped source code. Either way it'll be resolved in any future releases.

Sent from my Galaxy Nexus using XDA App
Last edited by jt1134; 28th February 2012 at 08:15 PM.
The Following 5 Users Say Thank You to jt1134 For This Useful Post: [ View ]
28th February 2012, 08:16 PM   |  #416  
JihadSquad's Avatar
Senior Member
Flag Madison, WI
Thanks Meter: 244
 
1,586 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by jt1134

I attempted to make use of the legacy USB manager to avoid having to update the kernel drivers, but this doesn't seem to work correctly since the kernel lacks a USB switch. Usually after a few reboots adb works, or you can start it manually using the built in terminal. Mass storage has to be started in terminal also.

Sent from my Galaxy Nexus using XDA App

Quote:
Originally Posted by jt1134

Vibration is weird...I hacked some debug into the kernel that can fix it, curious whether it works in the kernel I released.

echo 1 > /sys/class/vibetonz/immTest/immTest

That fixes it with the debug kernel module, if it works with the kernel I released then chalk it up to one more thing Samsung left out of their shipped source code. Either way it'll be resolved in any future releases.

Sent from my Galaxy Nexus using XDA App

Thanks for the info. Unfortunately the cell reception is very low compared to TW so I can't use the ROM to test it.
28th February 2012, 08:21 PM   |  #417  
Recognized Developer
Thanks Meter: 3,148
 
1,089 posts
Join Date:Joined: May 2010
Donate to Me
Quote:
Originally Posted by SpiffyRob

It does indeed.

Things I've found that are broken:

-Data
-Camera
-Voice Search/Recording (Evernote, at least.)

I also had some pretty horrendous lagginess when first setting up, but after a reboot, it went away and stayed away.

Back on Eclipse as my daily because I need those three things to make the switch, but it was a pretty great experience otherwise. DEFINITELY excited about the progress jt has made.

Weird...voice input using Google voice search seems to work for me

Sent from my Galaxy Nexus using XDA App
The Following 2 Users Say Thank You to jt1134 For This Useful Post: [ View ]
28th February 2012, 08:34 PM   |  #418  
JihadSquad's Avatar
Senior Member
Flag Madison, WI
Thanks Meter: 244
 
1,586 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by jt1134

Weird...voice input using Google voice search seems to work for me

Sent from my Galaxy Nexus using XDA App

Voice search worked for me too. One interesting thing I found though is that in the old build, you could go into the camera and get a black picture. You could then switch to the front facing camera, which worked. On this build the camera app force closes so you cant use FFC at all.
28th February 2012, 09:46 PM   |  #419  
Senior Member
San Fernando Valley
Thanks Meter: 56
 
526 posts
Join Date:Joined: Aug 2010
More
Wow ATM I using this rom and it's crazy smooth. Way smoother than GB. I have yet to see any lag. I will be using this rom till Friday so if anyone has questions feel free to ask and ill check..jt is a beast for hookin us up with this flavor of Android

Btw: I was on eclipse 1.3 (rfs not ext 4) and when I flashed it never booted up. So I Odin danalo all in one Odin w/ IMO 4.0 kernel and made sure it was on ext 4. I then flashed ICS and it booted up real quick. Quick question: what recovery should I flash so I can't go back to my recovery of eclipse 1.3 with no problem?
Sent from my SCH-I510 using XDA App
Last edited by jager420; 28th February 2012 at 09:57 PM.
28th February 2012, 09:51 PM   |  #420  
Senior Member
San Fernando Valley
Thanks Meter: 56
 
526 posts
Join Date:Joined: Aug 2010
More
Delete.........10char
Last edited by jager420; 28th February 2012 at 09:55 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes