FORUMS

AOSP 5.1 Lollipop for Nexus Q

Google Nexus Q is an intriguing device released with Android 4.0 Ice Cream Sandwich. It was abandoned by … more

XDA Picks: Best Apps of the Week (Apr 17 – 24)

Apps are at the front and center of any smartphone experience, and with over a … more

Glimpse Notifications: Easier Lockscreen Notifications

Lollipop brought a revamp to the lockscreen, taking away custom widgets but … more

What Are the Best Looking Apps on Android?

As more developers are updating their apps with Material Design elements, we’re … more
Post Reply Subscribe to Thread Email Thread

[Q] Extremely Slow 3G/4G Speeds T-mobile

28th February 2012, 06:42 AM |#1  
OP Member
Flag Mission, TX
Thanks Meter: 0
 
More
Hello, I've been having a problem for the last few months. I don't know if its been posted already, but as the title states, I've been having EXTREMELY slow download speeds on the T-Mobile network, and I'm not throttled.
I see people complaining about how their internet speed is about 150kB/s.
Well mine, on 3g, averages out to about 3-6kB/s.
I get faster speeds on EDGE, pulling in about 25-30kB/s.
Does anyone know why?
I didn't have this problem before, I used to pull in around 400-500kB normally. As of around summer, internets been slow as molasses. Unless its around 4:00 am. Then its moderately fast.
Any suggestions? I'm shown to be in 3G/4G coverage, and I certainly showed it before, now, its just frustrating.
 
 
28th February 2012, 07:01 AM |#2  
Senior Member
Thanks Meter: 77
 
More
Check to see if you're being throttled. If not, then it's probably congestion. Hard to tell without going through the usual tests.
28th February 2012, 07:30 AM |#3  
silverton's Avatar
Senior Member
Flag Seattle, WA
Thanks Meter: 120
 
Donate to Me
More
Are you positive you're not being throttled?
28th February 2012, 08:39 AM |#4  
jojo_16's Avatar
Senior Member
Flag HI
Thanks Meter: 13
 
Donate to Me
More
Where u from probably congested?

Sent from my HTC Vision using xda premium
28th February 2012, 12:06 PM |#5  
tarroyo's Avatar
Senior Member
Flag Hollywood, CA
Thanks Meter: 230
 
More
Try flashing the latest 04.19 radio then match the RIL files.
Last edited by tarroyo; 28th February 2012 at 12:08 PM. Reason: correction
29th February 2012, 01:24 AM |#6  
OP Member
Flag Mission, TX
Thanks Meter: 0
 
More
Quote:
Originally Posted by alpha-niner64

Check to see if you're being throttled. If not, then it's probably congestion. Hard to tell without going through the usual tests.

I know for a fact I'm not, I'm on a new billing period, and I haven't even used about 1GB
29th February 2012, 02:51 AM |#7  
Junior Member
Thanks Meter: 3
 
More
Mine speed is about 600-800kb/s, but sometimes it goes down to tens,or ever 0. Check first whether other devices work well or not.. Or fash the radio.

Sent from my HTC Vision using XDA App
29th February 2012, 03:25 AM |#8  
sino8r's Avatar
Senior Member
Flag Birmingham, Alabama
Thanks Meter: 668
 
More
Quote:
Originally Posted by urfavoriteemo

I know for a fact I'm not, I'm on a new billing period, and I haven't even used about 1GB

Have you ever been throttled before? Are you over your limit or come close? That's WAY TOO severe to be congested. I'd call Customer Care and check with them. You might be able to tell by trying out the old wap.voicestream.com APN...
1st March 2012, 10:16 PM |#9  
Member
10,000 Lakes
Thanks Meter: 0
 
More
Have you tried rebooting your phone? sometimes that could be the case.
Post Reply Subscribe to Thread

Tags
internet, slow, tmobile
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes