Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,985 Members 53,611 Now Online
XDA Developers Android and Mobile Development Forum

Buil.prop fix for Random Reboots on ICS

Tip us?
 
lunadomain
Old
(Last edited by lunadomain; 2nd March 2012 at 09:54 PM.) Reason: Made a mistake; it should be ro.ril.disable.power.collapse=1
#1  
lunadomain's Avatar
Senior Member - OP
Thanks Meter 19
Posts: 113
Join Date: Jul 2007
Exclamation Buil.prop fix for Random Reboots on ICS

I read all the posts about the random reboots, and seemed to me it happens when the TF goes on deep-sleep mode. So I added these 2 lines to my build.prop and have not gotten anymore reboots:

ro.ril.disable.power.collapse=1
pm.sleep_mode=2

If someone can try it, and post your results to verify, it could help others that are having this issue.
The Following 4 Users Say Thank You to lunadomain For This Useful Post: [ Click to Expand ]
 
kokopopz
Old
#2  
Member
Thanks Meter 17
Posts: 77
Join Date: Nov 2011
Quote:
Originally Posted by lunadomain View Post
I read all the posts about the random reboots, and seemed to me it happens when the TF goes on deep-sleep mode. So I added these 2 lines to my build.prop and have not gotten anymore reboots:
Thanks for the suggestion. It has been how long since you add the 2 lines? My first reboot and the second one has a gap of more than 48 hours.
 
steve.garon
Old
#3  
steve.garon's Avatar
Senior Member
Thanks Meter 641
Posts: 1,018
Join Date: Apr 2010
Location: Ottawa, On

 
DONATE TO ME
Quote:
Originally Posted by lunadomain View Post
I read all the posts about the random reboots, and seemed to me it happens when the TF goes on deep-sleep mode. So I added these 2 lines to my build.prop and have not gotten anymore reboots:

ro.ril.disable.power.collapse=0
pm.sleep_mode=2

If someone can try it, and post your results to verify, it could help others that are having this issue.
What is the effect of that mod on battery life?

Sent from my Nexus S using Tapatalk
Steve Garon on GitHUB

Nexus 4: Unlocked with Stock JB 4.2
Nexus 7: Unlocked with Stock JB 4.2
 
luna_c666
Old
#4  
Senior Member
Thanks Meter 352
Posts: 776
Join Date: Dec 2011
Thanks Luna d did you see where someone said gnufabio had tweeted it was a problem with the old nvidia drivers? Wondering if you came up with this independent of gnufabio's discovery..
LIFE IS TOO SHORT TO REMOVE USB SAFELY
If I helped, click Thanks!
Asus Transformer EPIC NOOB GUIDE----TextButtons for ICS TF101----Sleek Buttons for ICS TF101


Devices:
Sprint Samsung Galaxy SIII (Goodness JB ROM)
2 Epic4G's (CM10.1, CleanGB for the boy)
TF101 (CM10)
MyTouch4G (Lost or stolen )
 
lunadomain
Old
#5  
lunadomain's Avatar
Senior Member - OP
Thanks Meter 19
Posts: 113
Join Date: Jul 2007
Exclamation 48 hours and no reboot

Quote:
Originally Posted by luna_c666 View Post
Thanks Luna d did you see where someone said gnufabio had tweeted it was a problem with the old nvidia drivers? Wondering if you came up with this independent of gnufabio's discovery..
No, I just thought that since some of the reports were mentioning the Deep-Sleep state, then disabling this could solve the problem. So I decided to root and modify the build.prop by adding those two lines. I haven't had a single reboot in more than 48 hours now. Before the modification I would get a reboot every 8-12 hours.
The Following User Says Thank You to lunadomain For This Useful Post: [ Click to Expand ]
 
lunadomain
Old
#6  
lunadomain's Avatar
Senior Member - OP
Thanks Meter 19
Posts: 113
Join Date: Jul 2007
Wink Battery Life Effect: Negible

Quote:
Originally Posted by steve.garon View Post
What is the effect of that mod on battery life?

Sent from my Nexus S using Tapatalk
I didn't see much of a change in battery life. Try the mod and see how it goes for you.
The Following User Says Thank You to lunadomain For This Useful Post: [ Click to Expand ]
 
Sir Flashalot
Old
(Last edited by Sir Flashalot; 3rd March 2012 at 10:48 AM.)
#7  
Sir Flashalot's Avatar
Senior Member
Thanks Meter 247
Posts: 536
Join Date: Feb 2011
Location: Camelot
Added end rebooted. Experienced only a few reboots in the past 5 days. Wiped data from HC Revolver 3.11.1 and flashed ICS last week.

Will report. The first command line sounds promising already. I don't know zilch about coding so excuse me from being nub, but shouldn't that 0 be changed in 1 because the disable function should be 'enabled' (assuming 0= enable and 1= enabled)? Sounds more logical to me.
Motorola Defy | MB525 | BL6 | KitKat 4.4 | Quarx AOSP/CM11 20.01.2014 | SetVsel 18/300 28/600 38/800 58/1000 | green lens
ASUS Transformer | TF101 | B70 | KitKat 4.4.2 | Timduru KatKiss #19
 
lunadomain
Old
#8  
lunadomain's Avatar
Senior Member - OP
Thanks Meter 19
Posts: 113
Join Date: Jul 2007
Exclamation Good catch; I edited the first post.

Quote:
Originally Posted by Martijn1971 View Post
Added end rebooted. Experienced only a few reboots in the past 5 days. Wiped data from stock HC Revolver and flashed ICS last week.

Will report. The first command line sounds promising already. I don't know zilch about coding so excuse me from being nub, but shouldn't that 0 be changed in 1 because the disable function should be 'enabled' (assuming 0= enable and 1= enabled)? Sounds more logical to me.
Good catch, guess I made a mistake when I typed the post. Yes, it should be 1 to disable the Power Collapse.
The Following 2 Users Say Thank You to lunadomain For This Useful Post: [ Click to Expand ]
 
ibrumfield
Old
#9  
Member
Thanks Meter 8
Posts: 40
Join Date: Jul 2010
Location: Columbus
Default Random reboots

I have random reboots after I close my transformer with the dock attached, i open it and both batteries are dead and it is stuck at the asus boot screen, I edited my build prop and will post my results...
 
Sir Flashalot
Old
(Last edited by Sir Flashalot; 3rd March 2012 at 12:34 PM.)
#10  
Sir Flashalot's Avatar
Senior Member
Thanks Meter 247
Posts: 536
Join Date: Feb 2011
Location: Camelot
Quote:
Originally Posted by lunadomain View Post
Good catch, guess I made a mistake when I typed the post. Yes, it should be 1 to disable the Power Collapse.
Ok changed 0 to 1. Did not have a reboot in the past twelve hours, but I had them seldomly anyway. Will report again.

-edit: just had a 1st reboot within an hour of changing from 0 to 1. Happened when I left my appartment (and my wifi connection) and opened my tablet in the train. I have wifi turned of during sleep. I also upgraded YouTube app for testing purposes during that period (although I never use it) to test 720p. Not sure if it's related.
Motorola Defy | MB525 | BL6 | KitKat 4.4 | Quarx AOSP/CM11 20.01.2014 | SetVsel 18/300 28/600 38/800 58/1000 | green lens
ASUS Transformer | TF101 | B70 | KitKat 4.4.2 | Timduru KatKiss #19

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes