Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

(LOCKED/UNLOCKED) Solve battery drain issue on 4.0.2.A.0.42/62 on Stock kernel (V)

OP aimcr7

3rd April 2012, 01:06 PM   |  #171  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by aimcr7

Let it settle for couple days, after 3 or 4 charging and discharging it will be fine.

What rom do you use? And dont bloat your phone with any battery tweaks.

And give me a screenshot about your battery usage.

Sent from my MT15i using XDA

h tt p://i .imgur. com/ TNQAk.png (sorry i dont have 8 post even)

Display - 47%
Cell Standby - 17%
Phone idle - 13%
Music - 11%
Voice calls - 5%
Mediaserver - 3%
Wi-Fi - 2%
Android System - 2%

Battery remaining 22%

These are my stats, i've just back to 4.0.2.a.42, root and calibrated the battery with BatteryCalibrator. It seems it's during a few more. At leats the graph is better than before


edit: I've tested for about 24h and after calibration, none of these stats have changed. I will test 4.0.2.a.42 and 283 kernel more thoroughly.
Last edited by psylock; 4th April 2012 at 03:23 PM.
4th April 2012, 05:02 PM   |  #172  
aimcr7's Avatar
OP Senior Member
Flag Yogyakarta
Thanks Meter: 785
 
1,828 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by psylock

h tt p://i .imgur. com/ TNQAk.png (sorry i dont have 8 post even)

Display - 47%
Cell Standby - 17%
Phone idle - 13%
Music - 11%
Voice calls - 5%
Mediaserver - 3%
Wi-Fi - 2%
Android System - 2%

Battery remaining 22%

These are my stats, i've just back to 4.0.2.a.42, root and calibrated the battery with BatteryCalibrator. It seems it's during a few more. At leats the graph is better than before


edit: I've tested for about 24h and after calibration, none of these stats have changed. I will test 4.0.2.a.42 and 283 kernel more thoroughly.

I mean, charge and discharge for three or four times then see how it works.
BatteryCalibrator not even do anything to your battery.

Sent from my MT15i using XDA
The Following User Says Thank You to aimcr7 For This Useful Post: [ View ]
4th April 2012, 05:45 PM   |  #173  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by aimcr7

I mean, charge and discharge for three or four times then see how it works.
BatteryCalibrator not even do anything to your battery.

Sent from my MT15i using XDA

Thanks, i will try it and post the results!
8th April 2012, 06:13 PM   |  #174  
billykhan's Avatar
Senior Member
Flag Islamabad
Thanks Meter: 12
 
109 posts
Join Date:Joined: Feb 2012
More
Hello aimcr7 I let it settle like you said but wasn't working so I used the same calibration app again it made it somewhat better but still some drain while browsing only.

Sent from my MT11i using XDA
8th April 2012, 08:56 PM   |  #175  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by psylock

Thanks, i will try it and post the results!

I selfquote .

I've been testing for 4 days but none of these solutions have solved my problem, i think i'll send it for technical support (it's still under warranty)...

If anyone have any suggestion before i send it, i would appreciate it so much...
9th April 2012, 12:22 AM   |  #176  
aimcr7's Avatar
OP Senior Member
Flag Yogyakarta
Thanks Meter: 785
 
1,828 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by billykhan

Hello aimcr7 I let it settle like you said but wasn't working so I used the same calibration app again it made it somewhat better but still some drain while browsing only.

Sent from my MT11i using XDA

How much you got for one charge to discharge?

Sent from my Xperia Neo using XDA
9th April 2012, 12:26 AM   |  #177  
aimcr7's Avatar
OP Senior Member
Flag Yogyakarta
Thanks Meter: 785
 
1,828 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by psylock

I selfquote .

I've been testing for 4 days but none of these solutions have solved my problem, i think i'll send it for technical support (it's still under warranty)...

If anyone have any suggestion before i send it, i would appreciate it so much...

Try turn off your bluetooth, wifi, and gps if you dont use it, and check your applications, maybe some apps eat your battery so much.

Or reflash your phone (dont restore your apps), then check wether it still drain or not.

Sent from my Xperia Neo using XDA
9th April 2012, 05:26 PM   |  #178  
Junior Member
Thanks Meter: 0
 
13 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by aimcr7

Try turn off your bluetooth, wifi, and gps if you dont use it, and check your applications, maybe some apps eat your battery so much.

Or reflash your phone (dont restore your apps), then check wether it still drain or not.

Sent from my Xperia Neo using XDA


I've done what you said before, no wifi nor bluetooth. I've make all the tests with all wiped and just flashed, and no results, 30% in about 8 hours, and battery is full drained in about 20h
9th April 2012, 06:27 PM   |  #179  
aimcr7's Avatar
OP Senior Member
Flag Yogyakarta
Thanks Meter: 785
 
1,828 posts
Join Date:Joined: Jun 2010
More
Quote:
Originally Posted by psylock

I've done what you said before, no wifi nor bluetooth. I've make all the tests with all wiped and just flashed, and no results, 30% in about 8 hours, and battery is full drained in about 20h

Its normal mate.
How long your display usage time?

Sent from my Xperia Neo using XDA
9th April 2012, 06:53 PM   |  #180  
billykhan's Avatar
Senior Member
Flag Islamabad
Thanks Meter: 12
 
109 posts
Join Date:Joined: Feb 2012
More
Quote:
Originally Posted by aimcr7

How much you got for one charge to discharge?

Sent from my Xperia Neo using XDA

About 1 day average use 10 hours heavy use its got better I think

Sent from my MT11i using XDA

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes