MultiROM Once Again Available for the Galaxy S4

Multiboot, or the ability to select betweenmultiple operating systems on a single device at … more

Build an Impractical But Awesome Lego Mindstorm Dock

The vast majority of what we cover here on the XDA-Developers News Portal relates to … more

MultiROM Makes its Way Over to the HTC One (M8)

While browsing our forum, you will undoubtedly find more than a few enticing ROMs available … more

Welcome to the New XDA-Developers Portal!

You may recall that a few weeks ago, we opened up the XDA-2015 forum themesto intrepid users … more
Post Reply

Issue with SD card?

26th March 2012, 07:55 PM   |  #1  
DarkhShadow's Avatar
OP Senior Member
Flag Essex
Thanks Meter: 278
 
1,798 posts
Join Date:Joined: Sep 2011
More
So I have this weird problem

I have a SD card inserted into my tablet and for a while it was working fine, but a few days ago it went funny
It mounts fine ie it shows in notification and I can access it via /mint/sdcard but it does not show any media in any app, is this related to ICS update? I'm running 4.0.5

Sent from my ARCHOS 80G9 using XDA Premium HD app
26th March 2012, 08:39 PM   |  #2  
DarkhShadow's Avatar
OP Senior Member
Flag Essex
Thanks Meter: 278
 
1,798 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by DarkhShadow

So I have this weird problem

I have a SD card inserted into my tablet and for a while it was working fine, but a few days ago it went funny
It mounts fine ie it shows in notification and I can access it via /mint/sdcard but it does not show any media in any app, is this related to ICS update? I'm running 4.0.5

Sent from my ARCHOS 80G9 using XDA Premium HD app

OK so I rebuilt the media database and it seems to be working again, will let you know if it happens again

Sent from my ARCHOS 80G9 using XDA Premium HD app
26th March 2012, 09:41 PM   |  #3  
Senior Member
Thanks Meter: 43
 
162 posts
Join Date:Joined: Dec 2006
Donate to Me
Is that the MicroSD card that you're talking about?

I use one exclusively for videos and using the Archos video app I have no troubles detecting it. Haven't used any third-party apps though.
26th March 2012, 09:51 PM   |  #4  
DarkhShadow's Avatar
OP Senior Member
Flag Essex
Thanks Meter: 278
 
1,798 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by theguy

Is that the MicroSD card that you're talking about?

I use one exclusively for videos and using the Archos video app I have no troubles detecting it. Haven't used any third-party apps though.

Yes the MicroSD
Stuff wasn't showing up in gallery, music, google music or videos

Sent from my ice cream powered Nexus S
4th April 2012, 10:52 AM   |  #5  
VOODOOS!L's Avatar
Senior Member
Thanks Meter: 11
 
434 posts
Join Date:Joined: Nov 2005
My microSD card suddenly became read only... Don't know since when exactly, i think after official upgrade to 4.0.5
Tried to remount several times, yet still read only
Will try reformat, but since almost 24gb on it that's not the easiest solution..
4th April 2012, 01:36 PM   |  #6  
Senior Member
Thanks Meter: 632
 
1,264 posts
Join Date:Joined: Aug 2007
Quote:
Originally Posted by VOODOOS!L

My microSD card suddenly became read only... Don't know since when exactly, i think after official upgrade to 4.0.5
Tried to remount several times, yet still read only
Will try reformat, but since almost 24gb on it that's not the easiest solution..

Sounds like some trouble with the filesystem or data corruption on your card.
Try using a linux host and run some file system checks.
Normally it should be possible to fix it.

BTW, have you checked dmesg output if you insert the card into your Archos device?

Regards,

scholbert
4th April 2012, 04:33 PM   |  #7  
Member
Thanks Meter: 2
 
36 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by VOODOOS!L

My microSD card suddenly became read only... Don't know since when exactly, i think after official upgrade to 4.0.5
Tried to remount several times, yet still read only
Will try reformat, but since almost 24gb on it that's not the easiest solution..

I noticed this too. Apparently all firmwares after the very first release of ICS (So, not including that one) have this bug. Archos is not only aware of it, but apparently is said to have fixed it with the latest test firmware according to what an archos employee said over at archosfans forums. I'm about to install the test firmware to try it, and I'll report back in a bit.

Update: I can confirm that the permissions for the SD card have been fixed in the 4.0.6 TEST firmware. Which means all apps can now read AND write to the SD card again.

Sent from my ARCHOS 80G9 using Tapatalk
Last edited by bkromhout; 4th April 2012 at 04:42 PM.
4th April 2012, 08:09 PM   |  #8  
Member
Flag Kent
Thanks Meter: 5
 
30 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by VOODOOS!L

My microSD card suddenly became read only... Don't know since when exactly, i think after official upgrade to 4.0.5
Tried to remount several times, yet still read only
Will try reformat, but since almost 24gb on it that's not the easiest solution..

Found this on the net and it worked for me (now have full r/w on SD card)

Simple solution for external sdcard write access on Android 3.2...if you're rooted
I've found a simple solution for gaining write access to the external sdcard (/mnt/sdcard2) on Android 3.2. The sdcard is mounted r/w, but the owning group is media_rw which is linked to the WRITE_MEDIA_STORAGE permission. Unfortunately, this permission was not required for access to the external sdcard prior to 3.2 so most file management utilities do not request it when they run...meaning they only have read access to the card.

The simple solution, if you're rooted, is as follows:
1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
3. Add an additional group definition for this permission...<group gid="media_rw" />
4. Save the changes to the file.
5. Restart your tablet.

After this change, any apps that request the WRITE_EXTERNAL_STORAGE permission (which includes almost anything that access either of the sdcards) will gain group membership in both sdcard_rw AND media_rw, giving them r/w access to both sdcard filesystems.

It works for 4.0.5 too as that's what I'm running atm .

Psi.
The Following User Says Thank You to psiman24 For This Useful Post: [ View ]
4th April 2012, 08:34 PM   |  #9  
Member
Thanks Meter: 2
 
36 posts
Join Date:Joined: May 2011
More
Or you could just try to update to the test firmware. It runs stable and fixes the issue without needing to root or modify permissions. (And It still fixes it if you are rooted too, like I am)

Sent from my ARCHOS 80G9 using Tapatalk
9th April 2012, 09:26 AM   |  #10  
VOODOOS!L's Avatar
Senior Member
Thanks Meter: 11
 
434 posts
Join Date:Joined: Nov 2005
Thx a lot psiman24, i followed your instructions. using Rom Toolbox I was able to overwrite the file and now it seems to be working all fine again. Will wait for official release before installing 4.0.6


_________

Archos 80S G9 16GB TI4430, rooted ICS@BLUE v1

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes