Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[DEV] CM11 Work-In-Progress

OP dalingrin

9th April 2012, 04:45 AM   |  #2221  
racks11479's Avatar
Senior Member
Flag Fresh Meadows
Thanks Meter: 751
 
990 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by shumash

Help please:

make: *** No rule to make target `out/target/product/encore/obj/lib/crtbegin_static.o', needed by `out/target/product/encore/obj/EXECUTABLES/init_intermediates/LINKED/init'. Stop.

Trying to get my first build on Ubuntu 11.10, and I got this far (after hours)

Need more than that, please post a logcat to pastebin.com
The Following User Says Thank You to racks11479 For This Useful Post: [ View ]
9th April 2012, 05:55 AM   |  #2222  
eyeballer's Avatar
Recognized Contributor / Recognized Developer
Thanks Meter: 3,362
 
1,261 posts
Join Date:Joined: Jun 2010
Donate to Me
Quick note for those building at home: A few weeks ago fattire/keyodi removed "0 0 android" from egl.cfg in an effort to stabilize the opengl builds, while we all sync our /device repo and egl.cfg is correct there, the make system actually seems to overwrite it in /out with the egl.cfg that we first pulled from our devices using extract-files.sh. This egl.cfg lives in /vendor/bn/encore/proprietary. So be sure to copy the updated version over to /vendor.

This explains why both Samiam303's and my builds have "0 0 android" still present.
The Following 4 Users Say Thank You to eyeballer For This Useful Post: [ View ]
9th April 2012, 04:52 PM   |  #2223  
Junior Member
Thanks Meter: 2
 
21 posts
Join Date:Joined: Nov 2007
Quote:
Originally Posted by Kem-El

devs, I have a question (which I've asked before, but have yet to get any feedback) ...

First, some background:
Starting with the 2012-02-02 samiam build (february, but could have actually been 1 or 2 builds before) after flashing the update, I noticed that my Evernote app lost its tablet layout, reverting back to the phone UI.
I looked through the log files and noticed the Evernote was logging the NC screen size as 4.xxx inches, comind from the Android API, android.uitil.DisplayMetrics. (The Evernote forum site mentioned that anything less than 7 inches would revert to the phone interface, understandable).

So, I modified the Evernote app, forcing it to ignore the phone UI ... everything was back to normal.

Or so I thought. I've noticed that several apps (Evernote, IMDB, and at least 1 other, although I forgot which one) display phone interfaces instead of the tablet.

(I'm currently running eyeballer's opengl ... and have the same issue.
I run the default DPI of 160, so this should not be the issue.)

I reinstalled fattire's sneakpeak2-fullofbugs.zip, after performing a factory reset ... then installed the IMDB app.
Lo' and behold, IMDB with the tablet interface!

So the question:
Any ideas what could've changed in /system that would cause the android API to report the wrong screen size / or whatever else affects tablet UI?

Obviously, something between sneakpeak2 and 2012-02-02 nightly+ is causing the problem with some apps displaying as phone UI.

I am having the same issue... Would love to hear some input.
9th April 2012, 05:05 PM   |  #2224  
leapinlar's Avatar
Recognized Contributor
Thanks Meter: 3,695
 
8,415 posts
Join Date:Joined: Oct 2006
Donate to Me
More
Quote:
Originally Posted by cpkroboth

I am having the same issue... Would love to hear some input.

It is the kernel mod made on 2/2 that is causing the problem. If you read his followup post, you will see keyodi sent him the pre-2/2 kernel and he tested it with the latest build and the phone mode went away.
The Following User Says Thank You to leapinlar For This Useful Post: [ View ]
9th April 2012, 06:43 PM   |  #2225  
BitingChaos's Avatar
Senior Member
Flag St. Louis
Thanks Meter: 39
 
201 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by Nburnes

See the button that says "Thanks"?

This is why we have it.

Thanks
The Following 2 Users Say Thank You to BitingChaos For This Useful Post: [ View ]
10th April 2012, 12:39 AM   |  #2226  
tonyp's Avatar
Recognized Developer / Contributor
Thanks Meter: 33,693
 
4,792 posts
Join Date:Joined: Feb 2011
Donate to Me
Quote:
Originally Posted by BitingChaos

Thanks

Don't troll please, particulary in the dev section.
He's absolutely right, you should use the thanks button, what point are you trying to proof?
10th April 2012, 04:42 AM   |  #2227  
Senior Member
Thanks Meter: 43
 
360 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by fattire

So if you're using the new kernel/wifi combo (2.6.32.59), don't use interactivex governor or you'll have sleep problems. I just switched to conservative and now mine is working 100%.

I just got an SOD with Conservative, after running just fine with it for a couple of days.

*sigh*

Sent from my NookColor using xda premium
10th April 2012, 10:05 AM   |  #2228  
Senior Member
Thanks Meter: 476
 
131 posts
Join Date:Joined: Feb 2011
Question An update Part 2
Here's our second attempt at releasing the 2.6.32.59 kernel!

What's New
  1. updated accelerometer driver - not sure if this fixes anything, but newer is better right?
  2. reverted the omaplfb files - should fix apps not displaying in the tablet UI
  3. modified wifi module - fix SOD or at least less SOD, i hope
  4. latest cyanoboot
That's it folks! Again, you have 24 hours to register your complaints, otherwise we're pushing the new kernel. The timer starts now!

update-encore-kernel-2.6.32.59-take2.zip
md5: f6ba392f3c868783deadb0f85952c88d
(source for kernel-- see the cyanoboot thread for cyanoboot source)

Note: Yes, the keyboard is now smaller, however it's the same size as it was in sneekpeek 1 and 2 or prior to us updating the pvr drivers


WARNING AS USUAL, YOU USE THIS ENTIRELY AT YOUR OWN RISK. SEE ALL APPLICABLE DISCLAIMERS IN THE GPL AND ELSEWHERE IN THIS THREAD.
Last edited by keyodi; 10th April 2012 at 10:12 AM.
The Following 16 Users Say Thank You to keyodi For This Useful Post: [ View ]
10th April 2012, 10:45 AM   |  #2229  
fattire's Avatar
Recognized Developer
Thanks Meter: 4,755
 
1,717 posts
Join Date:Joined: Oct 2010
Wink ..but wait, there's more!
And the "special" cyanoboot comes by way of j4mmer! It's just a temp thing to play with while we figure out what the right orientation should be as well as other questions.

Check out the link above and join in the discussion!
10th April 2012, 01:57 PM   |  #2230  
Junior Member
Thanks Meter: 2
 
21 posts
Join Date:Joined: Nov 2007
Quote:
Originally Posted by leapinlar

It is the kernel mod made on 2/2 that is causing the problem. If you read his followup post, you will see keyodi sent him the pre-2/2 kernel and he tested it with the latest build and the phone mode went away.

Yes.. I did find the follow up post.


Also Running the 2.6.32.59 Rom with non openGL rom, and a 64Meg swap file. My nook is stable and the speed is equal to CM7.1 nightly 253.

I am not a modder or coder, so the work you all do is amazing to me.

---------- Post added at 11:57 AM ---------- Previous post was at 11:41 AM ----------

Quote:
Originally Posted by keyodi

Here's our second attempt at releasing the

Note: Yes, the keyboard is now smaller, however it's the same size as it was in sneekpeek 1 and 2 or prior to us updating the pvr drivers


WARNING AS USUAL, YOU USE THIS ENTIRELY AT YOUR OWN RISK. SEE ALL APPLICABLE DISCLAIMERS IN THE GPL AND ELSEWHERE IN THIS THREAD.

Installed, and first thing I notice. I can no longer long press keyboard for ALT entry of Numbers and punctuation.
Last edited by cpkroboth; 10th April 2012 at 01:48 PM.

Post Reply Subscribe to Thread

Tags
cm10, cm9, jellybean, nook color ics, winning
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes